aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-05-12 20:13:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-05-12 20:13:10 +0000
commit3bc4db8e654a021095d7521e3cb00ecbdb3b02f8 (patch)
treeb18ed21712fb6848978d9f6cec7fa0758272dd54 /finance
parent1d74ca6aa8062e6621e282bb3c6a9fa67e41c41a (diff)
downloadports-3bc4db8e654a021095d7521e3cb00ecbdb3b02f8.tar.gz
ports-3bc4db8e654a021095d7521e3cb00ecbdb3b02f8.zip
- Fix build on amd64
PR: ports/145922 Submitted by: Mike Bowie <mbowie@buzmo.com> (maintainer) - Portlint
Notes
Notes: svn path=/head/; revision=254220
Diffstat (limited to 'finance')
-rw-r--r--finance/php-tclink/Makefile24
-rw-r--r--finance/php-tclink/files/patch-php_tclink.c15
2 files changed, 24 insertions, 15 deletions
diff --git a/finance/php-tclink/Makefile b/finance/php-tclink/Makefile
index 9b052b642e81..f7bbbd57d506 100644
--- a/finance/php-tclink/Makefile
+++ b/finance/php-tclink/Makefile
@@ -5,24 +5,18 @@
# $FreeBSD$
#
-PORTNAME= tclink
-PORTVERSION= 3.4.4
-CATEGORIES= finance
-MASTER_SITES= http://www.trustcommerce.com/downloads/
-PKGNAMEPREFIX= php-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-php
+PORTNAME= tclink
+PORTVERSION= 3.4.4
+CATEGORIES= finance
+MASTER_SITES= http://www.trustcommerce.com/downloads/
+PKGNAMEPREFIX= php-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-php
-MAINTAINER= mbowie@buzmo.com
-COMMENT= A PHP extension for TrustCommerce credit card processing
+MAINTAINER= mbowie@buzmo.com
+COMMENT= A PHP extension for TrustCommerce credit card processing
USE_PHP= yes
USE_PHPEXT= yes
USE_OPENSSL= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= does not compile on amd64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/finance/php-tclink/files/patch-php_tclink.c b/finance/php-tclink/files/patch-php_tclink.c
new file mode 100644
index 000000000000..667a1160c89b
--- /dev/null
+++ b/finance/php-tclink/files/patch-php_tclink.c
@@ -0,0 +1,15 @@
+--- php_tclink.c.orig 2010-04-21 10:49:52.000000000 -0700
++++ php_tclink.c 2010-04-21 10:50:12.000000000 -0700
+@@ -46,7 +46,11 @@
+ #ifdef STANDARD_MODULE_HEADER
+ STANDARD_MODULE_HEADER,
+ #endif
+- "tclink", php_tclink_functions, NULL, NULL, NULL, NULL, PHP_MINFO(tclink), STANDARD_MODULE_PROPERTIES
++ "tclink", php_tclink_functions, NULL, NULL, NULL, NULL, PHP_MINFO(tclink),
++#if ZEND_MODULE_API_NO >= 20010901
++ TCLINK_VERSION,
++#endif
++ STANDARD_MODULE_PROPERTIES
+ };
+
+ #define PHP_TCLINK_DEFAULT_BUFFER_SIZE 8196