aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-03-02 15:42:09 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-03-02 15:42:09 +0000
commit5adadef81fe7be3fa0dd1c0a4367bbd16d9cbda3 (patch)
tree3855afbbcf2ca8119a775e03bdfdc020c0897dea /finance
parent91e0361e6cba96552345df2d4bb406b71790bb95 (diff)
downloadports-5adadef81fe7be3fa0dd1c0a4367bbd16d9cbda3.tar.gz
ports-5adadef81fe7be3fa0dd1c0a4367bbd16d9cbda3.zip
Clear up some unused depends. bump portrevision for this change.
White space nit, and check for libgwengui-gtk2.so only when building with AQBANKING support. Submitted by: Jason E. Hale <bsdkaffee@gmail.com>
Notes
Notes: svn path=/head/; revision=270124
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 1505ee2ecd75..d970d5bbc7fc 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnucash
PORTVERSION= 2.4.3
+PORTREVISION= 1
CATEGORIES= finance gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION}
@@ -16,8 +17,7 @@ COMMENT= Quicken-like money and finance manager
BUILD_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile \
${LOCALBASE}/share/guile/1.8/slibcat:${PORTSDIR}/lang/slib-guile
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring \
+LIB_DEPENDS= gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring \
goffice-0.8.8:${PORTSDIR}/devel/goffice
RUN_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile \
${LOCALBASE}/share/guile/1.8/slibcat:${PORTSDIR}/lang/slib-guile \
@@ -36,7 +36,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
USE_GETTEXT= yes
-USE_XORG= xpm x11
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
USE_PERL5= yes
@@ -46,7 +45,7 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-error-on-warning \
+CONFIGURE_ARGS= --disable-error-on-warning \
--disable-doxygen
MAN1= gnucash.1
@@ -115,7 +114,7 @@ PLIST_SUB+= PYTHON=""
PLIST_SUB+= PYTHON="@comment "
.endif
-.if !defined(PACKAGE_BUILDING) && !exists(${LOCALBASE}/lib/libgwengui-gtk2.so.0)
+.if !defined(PACKAGE_BUILDING) && defined(WITH_AQBANKING) && !exists(${LOCALBASE}/lib/libgwengui-gtk2.so.0)
BROKEN= Please rebuild devel/gwenhywfar with the WITH_GTK2 option set
.endif