aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-04-07 18:27:27 +0000
committerRene Ladan <rene@FreeBSD.org>2021-04-07 18:27:27 +0000
commit6fd9355a02eb408256aedbc0a1fef246bec6dec6 (patch)
tree36848430ab5bddf01d1351ffecfc9f6e067907e2 /finance
parent0bf8c12f5dab36ae633f8fc922f3416e893b5059 (diff)
downloadports-6fd9355a02eb408256aedbc0a1fef246bec6dec6.tar.gz
ports-6fd9355a02eb408256aedbc0a1fef246bec6dec6.zip
Remove expired ports:
devel/buildtool-doc 2021-04-01 devel/buildtool: Unmaintained and dead upstream, does not build with -fno-common (llvm 11) 2021-04-01 misc/floatator: Unmaintained and dead upstream, does not build with -fno-common (llvm 11) 2021-04-01 finance/wmstock: Unmaintained and dead upstream, does not build with -fno-common (llvm 11) 2021-04-01 ftp/frox: Unmaintained and dead upstream, does not build with -fno-common (llvm 11)
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/wmstock/Makefile31
-rw-r--r--finance/wmstock/distinfo2
-rw-r--r--finance/wmstock/files/patch-Makefile22
-rw-r--r--finance/wmstock/files/patch-getquote28
-rw-r--r--finance/wmstock/pkg-descr4
-rw-r--r--finance/wmstock/pkg-plist3
7 files changed, 0 insertions, 91 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 8e6c1b2927d7..019b5f241fa1 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -112,7 +112,6 @@
SUBDIR += vanitygen
SUBDIR += venice
SUBDIR += weberp
- SUBDIR += wmstock
SUBDIR += xtrader
.include <bsd.port.subdir.mk>
diff --git a/finance/wmstock/Makefile b/finance/wmstock/Makefile
deleted file mode 100644
index e04776e6db67..000000000000
--- a/finance/wmstock/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# Created by: Will Andrews <andrews@technologist.com>
-
-PORTNAME= wmstock
-PORTVERSION= 0.11
-PORTREVISION= 4
-CATEGORIES= finance windowmaker
-MASTER_SITES= http://www.mattfischer.com/wmstock/src/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Cool WindowMaker Dockapp that shows stock ticker(s)
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/../COPYING
-
-DEPRECATED= Unmaintained and dead upstream, does not build with -fno-common (llvm 11)
-EXPIRATION_DATE=2021-04-01
-
-USES= gmake shebangfix xorg
-USE_XORG= xpm
-SHEBANG_FILES= getquote
-
-CFLAGS+= -fcommon
-
-WRKSRC= ${WRKDIR}/wmstock/src
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/wmstock ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/getquote ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/wmstock.1x ${STAGEDIR}${PREFIX}/man/man1/wmstock.1
-
-.include <bsd.port.mk>
diff --git a/finance/wmstock/distinfo b/finance/wmstock/distinfo
deleted file mode 100644
index 6502ecead547..000000000000
--- a/finance/wmstock/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (wmstock-0.11.tar.gz) = e7fa585ee9961fbe2d5fe9dd4d89bb5e83af218201f04ab1e1375e0d7ee153d3
-SIZE (wmstock-0.11.tar.gz) = 45078
diff --git a/finance/wmstock/files/patch-Makefile b/finance/wmstock/files/patch-Makefile
deleted file mode 100644
index edbc21726149..000000000000
--- a/finance/wmstock/files/patch-Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.orig 2000-04-19 15:17:30 UTC
-+++ Makefile
-@@ -2,14 +2,15 @@
- # <mfischer@umr.edu>
- # based on wmWeather - see ../Credits for more information
-
--CC = gcc
-+CC ?= gcc
- DEBUG = -DMLF_DEBUG -DTIME_DEBUG
- GCOV = -fprofile-arcs -ftest-coverage
-
- #standard, should work for most Linux/Solaris (may need to be changed for HP)
--INCDIR = -I/usr/X11R6/include/X11 -I/usr/X11R6/include
--DESTDIR= /usr/X11R6
--LIBDIR = -L/usr/X11R6/lib
-+X11BASE ?= ${LOCALBASE}
-+INCDIR = -I${LOCALBASE}/include/X11 -I${LOCALBASE}/include
-+DESTDIR= ${PREFIX}
-+LIBDIR = -L${LOCALBASE}/lib
-
- # for linux
- LIBS = -lXpm -lX11 -lXext
diff --git a/finance/wmstock/files/patch-getquote b/finance/wmstock/files/patch-getquote
deleted file mode 100644
index 1fd17392c77e..000000000000
--- a/finance/wmstock/files/patch-getquote
+++ /dev/null
@@ -1,28 +0,0 @@
---- getquote.orig 2000-05-14 17:28:49 UTC
-+++ getquote
-@@ -1,6 +1,6 @@
- #!/usr/bin/perl
-
-- $wget_loc = "wget";
-+ $wget_loc = "fetch";
-
- # used to have some "which" here, replaced it..
-
-@@ -77,7 +77,7 @@ sub get_quote_data
- #
-
- $tempfile = "stock.tmp.$$";
-- $wget_args = " --cache=off --tries 0 -q -O $home/.wmstock/$tempfile \"$URL\"";
-+ $wget_args = " -p -o $home/.wmstock/$tempfile \"$URL\"";
- $command = $wget_loc.$wget_args;
- $result = system ("$wget_loc$wget_args");
- if ($result != 0) {
-@@ -118,7 +118,7 @@ sub look_for_new_version
- $version = $_[0];
- $vtempfile = "newest";
- $vers_url="http://www.mattfischer.com/wmstock/src/$vtempfile";
-- $wget_args = " --cache=off --tries 0 -q -O $home/.wmstock/$vtempfile \"$vers_url\"";
-+ $wget_args = " -p -o $home/.wmstock/$vtempfile \"$vers_url\"";
-
- $command = $wget_loc.$wget_args;
-
diff --git a/finance/wmstock/pkg-descr b/finance/wmstock/pkg-descr
deleted file mode 100644
index a199ab720131..000000000000
--- a/finance/wmstock/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-wmstock is a cool WindowMaker dockapp that shows stock
-ticker(s) that are retrieved from Yahoo.
-
-WWW: https://mattfischer.com/wmstock/
diff --git a/finance/wmstock/pkg-plist b/finance/wmstock/pkg-plist
deleted file mode 100644
index d80d75243886..000000000000
--- a/finance/wmstock/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/wmstock
-bin/getquote
-man/man1/wmstock.1.gz