aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /finance
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'finance')
-rw-r--r--finance/alkimia/Makefile2
-rw-r--r--finance/gnucash/Makefile2
-rw-r--r--finance/skrooge/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/finance/alkimia/Makefile b/finance/alkimia/Makefile
index 13cecc438804..ba07798b6530 100644
--- a/finance/alkimia/Makefile
+++ b/finance/alkimia/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LIB
# Depending on ecm via USE_KDE causes unwanted CMAKE_ARGS to be set
BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/kf5-extra-cmake-modules
-USES= cmake:outsource compiler:c++11-lang pathfix tar:xz
+USES= cmake compiler:c++11-lang pathfix tar:xz
USE_LDCONFIG= yes
SLAVE?= qt5
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index c73c731c1a51..bb376bfe660d 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -55,7 +55,7 @@ PYTHON_USES= python:3.3+
TEST_BUILD_DEPENDS= ${NONEXISTENT}:devel/googlemock:build \
gtest-config:devel/googletest
-USES= cmake compiler:c++11-lib desktop-file-utils gettext-tools libtool localbase \
+USES= cmake:insource compiler:c++11-lib desktop-file-utils gettext-tools libtool localbase \
perl5 pkgconfig shebangfix tar:bzip2
USE_XORG= x11
USE_CXXSTD= c++11
diff --git a/finance/skrooge/Makefile b/finance/skrooge/Makefile
index d9eec076d25e..cfaa50dfd6db 100644
--- a/finance/skrooge/Makefile
+++ b/finance/skrooge/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libofx.so:finance/libofx \
libqca-qt5.so:devel/qca@qt5 \
libsqlcipher.so:databases/sqlcipher
-USES= cmake:outsource compiler:c++11-lib desktop-file-utils \
+USES= cmake compiler:c++11-lib desktop-file-utils \
gettext grantlee:5 kde:5 pkgconfig python:3.4+ qt:5 shared-mime-info \
shebangfix sqlite:3 tar:xz
USE_KDE= activities archive attica5 auth bookmarks codecs completion \