aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-03-18 01:00:15 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-03-18 01:00:15 +0000
commit77674cb6622cdd4ad4faf50a411e884bc9bb60b2 (patch)
tree5969747371a319b112fdb57c5132c669e01bf4c9 /finance
parent9cc67b09503d0486bbf7f1488fff87432a064519 (diff)
downloadports-77674cb6622cdd4ad4faf50a411e884bc9bb60b2.tar.gz
ports-77674cb6622cdd4ad4faf50a411e884bc9bb60b2.zip
- Update to 7.05
PR: 144569 Submitted by: John Hein <jhein@symmetricom.com> (maintainer)
Notes
Notes: svn path=/head/; revision=251192
Diffstat (limited to 'finance')
-rw-r--r--finance/opentaxsolver/Makefile2
-rw-r--r--finance/opentaxsolver/distinfo6
-rw-r--r--finance/opentaxsolver/files/patch-src-GUI-ots_gui.c96
-rw-r--r--finance/opentaxsolver/files/patch-src-Makefile.unix18
-rw-r--r--finance/opentaxsolver/pkg-plist39
5 files changed, 129 insertions, 32 deletions
diff --git a/finance/opentaxsolver/Makefile b/finance/opentaxsolver/Makefile
index ae6365ab28b5..bf47675c56cf 100644
--- a/finance/opentaxsolver/Makefile
+++ b/finance/opentaxsolver/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ${UPPORTNAME:L}
-PORTVERSION= 7.00
+PORTVERSION= 7.05
CATEGORIES= finance
MASTER_SITES= SF/${PORTNAME}/OTS_2009/v${PORTVERSION}
DISTNAME= ${UPPORTNAME}2009_${PORTVERSION}
diff --git a/finance/opentaxsolver/distinfo b/finance/opentaxsolver/distinfo
index 0699b1415749..dbb9cee0efdb 100644
--- a/finance/opentaxsolver/distinfo
+++ b/finance/opentaxsolver/distinfo
@@ -1,3 +1,3 @@
-MD5 (OpenTaxSolver2009_7.00.tgz) = 4609c4d030c3daaa502b36bc11559d63
-SHA256 (OpenTaxSolver2009_7.00.tgz) = ecda7974e7de8c1a1fc0eeb119196287767a3e9bbfe0531a44870e66cdc9d94c
-SIZE (OpenTaxSolver2009_7.00.tgz) = 349182
+MD5 (OpenTaxSolver2009_7.05.tgz) = 230657dae70ea63a309d082be17d622e
+SHA256 (OpenTaxSolver2009_7.05.tgz) = 5f6959d8ea07f4d01fb8b515bd4137f1ade26aabea9b9e556dd4f6c32d938698
+SIZE (OpenTaxSolver2009_7.05.tgz) = 431597
diff --git a/finance/opentaxsolver/files/patch-src-GUI-ots_gui.c b/finance/opentaxsolver/files/patch-src-GUI-ots_gui.c
index 2ffa0d80f6ef..81a7f3956a35 100644
--- a/finance/opentaxsolver/files/patch-src-GUI-ots_gui.c
+++ b/finance/opentaxsolver/files/patch-src-GUI-ots_gui.c
@@ -1,28 +1,104 @@
---- src/GUI/ots_gui.c.orig 2008-02-10 12:57:32.000000000 -0700
-+++ src/GUI/ots_gui.c 2008-02-19 18:17:30.000000000 -0700
-@@ -1026,7 +1026,7 @@
+--- src/GUI/ots_gui.c.orig 2010-03-02 06:46:32.000000000 -0700
++++ src/GUI/ots_gui.c 2010-03-08 17:55:11.000000000 -0700
+@@ -638,7 +638,7 @@
+ /* Now create enough tabbed-panels to hold all the lines. */
+ npanels = nlines / lines_per_page + 1;
+ panelnames = (char **)malloc( (npanels+1) * sizeof(char *));
+- for (j=0; j<npanels; j++) {panelnames[j] = (char *)malloc(30); sprintf( panelnames[j], "Page %d ", j+1); }
++ for (j=0; j<npanels; j++) {panelnames[j] = (char *)malloc(30); snprintf(panelnames[j], sizeof(panelnames[j]), "Page %d ", j+1); }
+ Panels = Otk_Tabbed_Panel_New( main_panel, npanels, panelnames, Otk_LightGray, 1, 1, 98, 98, 5 );
+ TabbedPanel = Panels;
+
+@@ -698,7 +698,7 @@
+ switch (entry->kind)
+ {
+ case VKIND_FLOAT: // printf("Formbox: '%s'\n", messg);
+- sprintf(messg, "%12.2f", entry->value );
++ snprintf(messg, sizeof(messg), "%12.2f", entry->value );
+ pos_x = leftmargin;
+ leftmargin = leftmargin + box_width + 1.5;
+ pos_y = (float)linenum * 9.0 + 6.5;
+@@ -986,9 +986,9 @@
+ return;
+ }
+ if (PLATFORM_KIND==Posix_Platform)
+- sprintf(cmd,"%s %s &", taxsolvecmd, working_file );
++ snprintf(cmd, sizeof(cmd), "%s %s &", taxsolvecmd, working_file );
+ else
+- sprintf(cmd,"%s %s", taxsolvecmd, working_file );
++ snprintf(cmd, sizeof(cmd), "%s %s", taxsolvecmd, working_file );
+
+ printf("Invoking '%s'\n", cmd );
+ system(cmd); /* Invoke the TaxSolver. */
+@@ -1022,7 +1022,7 @@
+
+ void togprntcmd_in(void *x)
+ {
+- sprintf(printer_command,"%s %s", base_printer_command, wrkingfname);
++ snprintf(printer_command, sizeof(printer_command), "%s %s", base_printer_command, wrkingfname);
+ Otk_Modify_Text( printerformbox, printer_command );
+ }
+
+@@ -1030,7 +1030,7 @@
+ { char tmpstr[MaxFname];
+ int k;
+ predict_output_filename(wrkingfname,tmpstr);
+- sprintf(printer_command,"%s %s", base_printer_command, tmpstr);
++ snprintf(printer_command, sizeof(printer_command), "%s %s", base_printer_command, tmpstr);
+ Otk_Modify_Text( printerformbox, printer_command );
+ }
+
+@@ -1058,7 +1058,7 @@
+ Otk_Add_BoundingBox( printpopup, Otk_Blue, 1.0, 18.0, 16.0, 63.0, 47.0 );
+
+ if (working_file==0) strcpy(wrkingfname,filename_dat); else strcpy(wrkingfname,working_file);
+- sprintf(printer_command,"%s %s", base_printer_command, wrkingfname);
++ snprintf(printer_command, sizeof(printer_command), "%s %s", base_printer_command, wrkingfname);
+
+ OtkMakeTextLabel( printpopup, "Print Command:", Otk_Black, /*scale=*/ 1.5, /*weight=*/ 1, /*x=*/ 4, /*y=*/ 57 );
+ printerformbox = OtkMakeTextFormBox( printpopup, printer_command, 60, 28.5, 55, 68, 18, acceptprinter_command2, 0 );
+@@ -1117,15 +1117,15 @@
+ if (k>0) k--;
+ while ((k>0) && (tmpstr[k]!=slashchr)) k--;
+ if (tmpstr[k]==slashchr) tmpstr[k+1] = '\0';
+- else {sprintf(tmpstr,".%c", slashchr);}
+- sprintf(directory_dat,"%sexamples_and_templates%c", tmpstr, slashchr);
++ else {snprintf(tmpstr, sizeof(tmpstr), ".%c", slashchr);}
++ snprintf(directory_dat, sizeof(directory_dat), "%sexamples_and_templates%c", tmpstr, slashchr);
+ Otk_Browse_Files( "Select TaxSolver:", MaxFname, directory_dat, wildcards_dat, taxsolvestrng, open_taxfile );
+ return;
}
else
{
+ selected_other = 0;
- sprintf(tmpstr,"%s%s", invocation_path, strg);
+ snprintf(tmpstr, sizeof(tmpstr), "%s%s", invocation_path, strg);
printf("Setting Tax Program to be: '%s'\n", tmpstr);
taxsolvecmd = strdup(tmpstr);
strcpy(taxsolvestrng,tmpstr);
-@@ -1037,8 +1037,8 @@
+@@ -1136,8 +1136,8 @@
if (k>0) k--;
while ((k>0) && (tmpstr[k]!=slashchr)) k--;
if (tmpstr[k]==slashchr) tmpstr[k+1] = '\0';
- else {sprintf(tmpstr,".%c", slashchr);}
- sprintf(directory_dat,"%sexamples_and_templates%c", tmpstr, slashchr);
+ else {snprintf(tmpstr, sizeof(tmpstr), ".%c", slashchr);}
-+ snprintf(directory_dat, sizeof(directory_dat), "%sexamples_and_templates%c", "%%PREFIX%%/share/ots/", slashchr);
- /* CA_540 MA_1 NC_400 NJ_1040 NY_IT201 OH_1040 PA_40 US_1040 US_1040_Sched_C VA_760 */
- if (strstr(strg,"CA_540")) strcat(directory_dat,"CA_540"); else
- if (strstr(strg,"MA_1")) strcat(directory_dat,"MA_1"); else
-@@ -1118,7 +1118,7 @@
++ snprintf(directory_dat, sizeof(directory_dat), "%sexamples_and_templates%c", tmpstr, slashchr);
+
+ sel = strstr( strg, "_2009" );
+ sel[0] = '\0';
+@@ -1208,7 +1208,7 @@
+ {printf("Unknown command-line parameter '%s'\n", argv[argn]); /* exit(1); */ }
+ argn = argn + 1;
+ }
+- sprintf(vrsnmssg,"OTS GUI v%1.2f", version); printf("%s\n\n",vrsnmssg);
++ snprintf(vrsnmssg, sizeof(vrsnmssg), "OTS GUI v%1.2f", version); printf("%s\n\n",vrsnmssg);
+ invocation_path = strdup(argv[0]);
+ k = strlen(invocation_path)-1;
+ while ((k>0) && (invocation_path[k]!=slashchr)) k--;
+@@ -1234,7 +1234,7 @@
main_panel =
- OtkMakePanel( OtkOuterWindow, Otk_Raised, Otk_LightGray, 1, 7.5, 98, 87 ); /* Main Panel. */
+ OtkMakePanel( bckgrnd, Otk_Raised, Otk_LightGray, 1, 7.5, 98, 87 ); /* Main Panel. */
Otk_SetBorderThickness( main_panel, 0.25 );
- sprintf(tmpstr,"%s..%csrc%cGUI%cotslogo.ppm", invocation_path, slashchr, slashchr, slashchr );
+ snprintf(tmpstr, sizeof(tmpstr), "%%PREFIX%%/share/ots/otslogo.ppm");
diff --git a/finance/opentaxsolver/files/patch-src-Makefile.unix b/finance/opentaxsolver/files/patch-src-Makefile.unix
deleted file mode 100644
index 9cfa2f28069a..000000000000
--- a/finance/opentaxsolver/files/patch-src-Makefile.unix
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/Makefile.unix.orig 2010-01-05 22:20:59.000000000 -0700
-+++ src/Makefile.unix 2010-01-25 12:12:00.000000000 -0700
-@@ -20,6 +20,7 @@
-
- all: ../bin/taxsolve_US_1040_2009 \
- ../bin/taxsolve_US_1040_Sched_C_2009 \
-+ ../bin/taxsolve_CA_540_2009
- # ../bin/taxsolve_NC_D400_2009 \
- # ../bin/taxsolve_NJ_1040_2009 \
- # ../bin/taxsolve_PA_40_2009 \
-@@ -28,7 +29,6 @@
- # ../bin/taxsolve_NY_IT201_2009 \
- # ../bin/taxsolve_MA_1_2009 \
- # ../bin/taxsolve_US_8829 \
-- ../bin/taxsolve_CA_540_2009
-
-
- ../bin/taxsolve_US_1040_2009: taxsolve_US_1040_2009.c $(OBJS)
diff --git a/finance/opentaxsolver/pkg-plist b/finance/opentaxsolver/pkg-plist
index 1853fb2b992e..dd20892f78a3 100644
--- a/finance/opentaxsolver/pkg-plist
+++ b/finance/opentaxsolver/pkg-plist
@@ -1,8 +1,36 @@
bin/ots_gui
bin/taxsolve_CA_540_2009
+bin/taxsolve_MA_1_2009
+bin/taxsolve_NC_D400_2009
+bin/taxsolve_NJ_1040_2009
+bin/taxsolve_NY_IT201_2009
+bin/taxsolve_OH_IT1040_2009
+bin/taxsolve_PA_40_2009
bin/taxsolve_US_1040_2009
bin/taxsolve_US_1040_Sched_C_2009
+bin/taxsolve_VA_760_2009
share/ots/otslogo.ppm
+share/ots/examples_and_templates/CA_540/CA_540_2009_example.dat
+share/ots/examples_and_templates/CA_540/CA_540_2009_template.dat
+share/ots/examples_and_templates/CA_540/README_CA_540.txt
+share/ots/examples_and_templates/MA_1/README_MA_1.txt
+share/ots/examples_and_templates/MA_1/ma_1_2009_example.dat
+share/ots/examples_and_templates/MA_1/ma_1_2009_template.dat
+share/ots/examples_and_templates/NC_D400/NC_400_2009_example.dat
+share/ots/examples_and_templates/NC_D400/NC_400_2009_template.dat
+share/ots/examples_and_templates/NC_D400/README_NC_400.txt
+share/ots/examples_and_templates/NJ_1040/NJ_1040_2009_example.dat
+share/ots/examples_and_templates/NJ_1040/NJ_1040_2009_template.dat
+share/ots/examples_and_templates/NJ_1040/README_NJ_1040.txt
+share/ots/examples_and_templates/NY_IT201/NY_IT201_2009_example.dat
+share/ots/examples_and_templates/NY_IT201/NY_IT201_2009_template.dat
+share/ots/examples_and_templates/NY_IT201/README_NY_IT201.txt
+share/ots/examples_and_templates/OH_IT1040/OH_IT1040_2009_example.dat
+share/ots/examples_and_templates/OH_IT1040/OH_IT1040_2009_template.dat
+share/ots/examples_and_templates/OH_IT1040/README_OH_IT1040.txt
+share/ots/examples_and_templates/PA_40/PA_40_2009_example.dat
+share/ots/examples_and_templates/PA_40/PA_40_2009_template.dat
+share/ots/examples_and_templates/PA_40/README_PA_40.txt
share/ots/examples_and_templates/US_1040/README_US_1040.txt
share/ots/examples_and_templates/US_1040/US_1040_example.dat
share/ots/examples_and_templates/US_1040/US_1040_template.dat
@@ -10,7 +38,18 @@ share/ots/examples_and_templates/US_1040_Sched_C/8829_template.dat
share/ots/examples_and_templates/US_1040_Sched_C/README_US_1040_Sched_C.txt
share/ots/examples_and_templates/US_1040_Sched_C/US_1040Sched_C_2009_example.dat
share/ots/examples_and_templates/US_1040_Sched_C/US_1040Sched_C_2009_template.dat
+share/ots/examples_and_templates/VA_760/README_VA_760.txt
+share/ots/examples_and_templates/VA_760/VA_760_2009_example.dat
+share/ots/examples_and_templates/VA_760/VA_760_2009_template.dat
+@dirrm share/ots/examples_and_templates/VA_760
@dirrm share/ots/examples_and_templates/US_1040_Sched_C
@dirrm share/ots/examples_and_templates/US_1040
+@dirrm share/ots/examples_and_templates/PA_40
+@dirrm share/ots/examples_and_templates/OH_IT1040
+@dirrm share/ots/examples_and_templates/NY_IT201
+@dirrm share/ots/examples_and_templates/NJ_1040
+@dirrm share/ots/examples_and_templates/NC_D400
+@dirrm share/ots/examples_and_templates/MA_1
+@dirrm share/ots/examples_and_templates/CA_540
@dirrm share/ots/examples_and_templates
@dirrm share/ots