aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-16 04:26:57 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-16 04:26:57 +0000
commit7f242f3ed9bb3b2ae80a25deb9c8b1d6126c2637 (patch)
tree1251bc11e73dab2e59248eca8f7ecab813ebf856 /finance
parentc3496b0186c8e1d6e1d176507827917dcf212b64 (diff)
downloadports-7f242f3ed9bb3b2ae80a25deb9c8b1d6126c2637.tar.gz
ports-7f242f3ed9bb3b2ae80a25deb9c8b1d6126c2637.zip
- Add patch to deal with FreeBSD location of PFPRO_CERT_PATH
PR: ports/98996 Submitted by: Alexandr Kovalenko <never@nevermind.kiev.ua> Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=165535
Diffstat (limited to 'finance')
-rw-r--r--finance/p5-PFProAPI/Makefile3
-rw-r--r--finance/p5-PFProAPI/files/patch-PFProAPI.pm14
2 files changed, 17 insertions, 0 deletions
diff --git a/finance/p5-PFProAPI/Makefile b/finance/p5-PFProAPI/Makefile
index 4e2a117f270d..ed616bebc898 100644
--- a/finance/p5-PFProAPI/Makefile
+++ b/finance/p5-PFProAPI/Makefile
@@ -23,4 +23,7 @@ PERL_CONFIGURE= yes
MAN3= PFProAPI.3
+post-patch:
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/PFProAPI.pm
+
.include <bsd.port.mk>
diff --git a/finance/p5-PFProAPI/files/patch-PFProAPI.pm b/finance/p5-PFProAPI/files/patch-PFProAPI.pm
new file mode 100644
index 000000000000..1e36f11bdd6e
--- /dev/null
+++ b/finance/p5-PFProAPI/files/patch-PFProAPI.pm
@@ -0,0 +1,14 @@
+--- PFProAPI.pm.orig Fri Jun 16 01:37:04 2006
++++ PFProAPI.pm Fri Jun 16 01:37:13 2006
+@@ -76,6 +76,11 @@
+ my $parmlist;
+ my ($name, $value);
+
++ # If no PFPRO_CERT_PATH set, we will set default one
++ if ($ENV{'PFPRO_CERT_PATH'} eq '') {
++ $ENV{'PFPRO_CERT_PATH'} = '%%PREFIX%%/etc/pfpro/certs';
++ }
++
+ if (! $data) {
+ # If no data was passed, we will build a test transaction
+ $data->{ACCT} = "5105105105105100";