aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
commit951c257ea3655de6e80c26a36c18c69ee8047ea8 (patch)
tree249b59a23d9c6fae8db5e5639385f6273d237705 /finance
parent91926e92b73e3751382216a16044c5d8b24ad126 (diff)
downloadports-951c257ea3655de6e80c26a36c18c69ee8047ea8.tar.gz
ports-951c257ea3655de6e80c26a36c18c69ee8047ea8.zip
Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOME
releases in that it focuses more on stability and functionality than on new features. Not that it doesn't have its share of new and exciting items. See http://www.gnome.org/start/2.18/ for all the goodies in this release. GNOME 2.18 for FreeBSD would not have been possible without the hard work of the FreeBSD GNOME Team and our intrepid band of testers including J. W. Ballantine, Pawel Worach, Yasuda Keisuke, Pascal Hofstee, miwi, Yoshihiro Ota, Vladimir Grebenschikov, Jukka A. Ukkonen, Phillip Neumann, Franz Klammer, and Neal Delmonico.
Notes
Notes: svn path=/head/; revision=187702
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash/Makefile7
-rw-r--r--finance/gnucash/files/patch-src_gnome-utils_gnc-html.c11
2 files changed, 15 insertions, 3 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 75a55bf3e58b..e642c10df0ee 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -3,12 +3,12 @@
# Whom: David O'Brien (obrien@NUXI.com)
#
# $FreeBSD$
-# $MCom: ports/finance/gnucash/Makefile,v 1.12 2007/02/23 18:27:51 ahze Exp $
+# $MCom: ports/finance/gnucash/Makefile,v 1.14 2007/03/13 05:58:37 marcus Exp $
#
PORTNAME= gnucash
PORTVERSION= 2.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.gnucash.org/pub/gnucash/sources/stable/
@@ -80,7 +80,8 @@ PLIST_SUB= AQBANKING="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|$${datarootdir}/info|${PREFIX}/info|' \
+ @${REINPLACE_CMD} -e 's|$${datarootdir}/info|${PREFIX}/info| ; \
+ s|libgtkhtml-3.8|libgtkhtml-3.14|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|$$(datadir)/aclocal|${PREFIX}/share/aclocal|' \
${WRKSRC}/Makefile.in
diff --git a/finance/gnucash/files/patch-src_gnome-utils_gnc-html.c b/finance/gnucash/files/patch-src_gnome-utils_gnc-html.c
new file mode 100644
index 000000000000..92058ac13ade
--- /dev/null
+++ b/finance/gnucash/files/patch-src_gnome-utils_gnc-html.c
@@ -0,0 +1,11 @@
+--- src/gnome-utils/gnc-html.c.orig Tue Feb 20 23:18:48 2007
++++ src/gnome-utils/gnc-html.c Tue Feb 20 23:18:38 2007
+@@ -1325,7 +1325,7 @@
+ return;
+ }
+
+- gtk_html_print(GTK_HTML(html->html), ps->context);
++ gtk_html_print_page(GTK_HTML(html->html), ps->context);
+ gnc_print_session_done(ps);
+ }
+