aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-29 03:58:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-29 03:58:14 +0000
commitd23fb58f91a152e9a2cdcdd263ddf873acc42eb5 (patch)
tree36f01648eaa01e99332f6b31cb29b0ae58e761f8 /finance
parent734bdc8adf024bcdd7e6f5ad5afc546a817b1128 (diff)
downloadports-d23fb58f91a152e9a2cdcdd263ddf873acc42eb5.tar.gz
ports-d23fb58f91a152e9a2cdcdd263ddf873acc42eb5.zip
New port: finance/qtbitcointrader: Secure client uses latest OpenSSL and best encryption
Notes
Notes: svn path=/head/; revision=483365
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/qtbitcointrader/Makefile26
-rw-r--r--finance/qtbitcointrader/distinfo3
-rw-r--r--finance/qtbitcointrader/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index a229272f23da..e82306f82597 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -104,6 +104,7 @@
SUBDIR += py-vatnumber
SUBDIR += py-ystockquote
SUBDIR += qhacc
+ SUBDIR += qtbitcointrader
SUBDIR += quantlib
SUBDIR += quickfix
SUBDIR += rubygem-money
diff --git a/finance/qtbitcointrader/Makefile b/finance/qtbitcointrader/Makefile
new file mode 100644
index 000000000000..f12a21973cb1
--- /dev/null
+++ b/finance/qtbitcointrader/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= QtBitcoinTrader
+DISTVERSION= 1.40.23
+CATEGORIES= finance
+MASTER_SITES= SF/bitcointrader/SRC/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Secure client uses latest OpenSSL and best encryption
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.GPL3
+
+USES= compiler:c++11-lib gl qmake qt:5 ssl
+USE_QT= core gui multimedia network script widgets buildtools_build
+USE_GL= gl
+
+WRKSRC_SUBDIR= src
+
+QMAKE_ARGS= DESKTOPDIR=${PREFIX}/share/applications ICONDIR=${PREFIX}/share/pixmaps
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
+
+.include <bsd.port.mk>
diff --git a/finance/qtbitcointrader/distinfo b/finance/qtbitcointrader/distinfo
new file mode 100644
index 000000000000..70d6efcf8613
--- /dev/null
+++ b/finance/qtbitcointrader/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540783321
+SHA256 (QtBitcoinTrader-1.40.23.tar.gz) = 0bd864dde1992e893cedb142233717ea702cfa79350c92681ba8e40fc0192072
+SIZE (QtBitcoinTrader-1.40.23.tar.gz) = 1626737
diff --git a/finance/qtbitcointrader/pkg-descr b/finance/qtbitcointrader/pkg-descr
new file mode 100644
index 000000000000..ef23a2030af2
--- /dev/null
+++ b/finance/qtbitcointrader/pkg-descr
@@ -0,0 +1,6 @@
+Qt Bitcoin Trader is secure client uses latest OpenSSL and best encryption.
+
+It is a modern, multi-function, full-featured cryptocurrency client that is
+designed to satisfy the needs of even the most sophisticated users.
+
+WWW: https://centrabit.com/