aboutsummaryrefslogtreecommitdiff
path: root/french/homard
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-12-08 02:07:22 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-12-08 02:07:22 +0000
commitc29377595853802138b1496fc9f863cbc5de7293 (patch)
treee17f447c50d55f732d3f1b503915ac39c736785c /french/homard
parentf1102dce01f030f26a766eba8124ef2b7b4eb82a (diff)
downloadports-c29377595853802138b1496fc9f863cbc5de7293.tar.gz
ports-c29377595853802138b1496fc9f863cbc5de7293.zip
- Upgrading french/aster from 7.1 to 7.2;
- french/eficas from 1.4 to 1.5; - cad/metis-edf from 3 to 3.1; - cad/astk-serveur & cad/astk-client from 1.0.14 to 1.0.21; - french/homard from 5.5 to 6.2; . don't install Homard automatically with Aster; like Gibi, Homard depends on french/aster: this is more compliant with the licenses, and it will be possible to build packages for Aster. PR: 59312 59881 Submitted By: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=95312
Diffstat (limited to 'french/homard')
-rw-r--r--french/homard/Makefile60
-rw-r--r--french/homard/distinfo2
-rw-r--r--french/homard/pkg-plist53
3 files changed, 82 insertions, 33 deletions
diff --git a/french/homard/Makefile b/french/homard/Makefile
index b9da41f240a2..ed5fd94bba16 100644
--- a/french/homard/Makefile
+++ b/french/homard/Makefile
@@ -6,23 +6,23 @@
#
PORTNAME= homard
-PORTVERSION= 5.5
-PORTREVISION= 2
+PORTVERSION= 6.2
CATEGORIES= french cad linux python
MASTER_SITES= http://www.code-aster.org/FICHIERS/homard/
-DISTNAME= ${PORTNAME}_linux_${PORTVERSION}
+DISTNAME= ${PORTNAME:U}_V${PORTVERSION}.Linux
MAINTAINER= ports@FreeBSD.org
COMMENT= A refinement and de-refinement mesh tool
+BUILD_DEPENDS= ${LOCALBASE}/aster/${vaster}/asteru.exe:${PORTSDIR}/french/aster
+RUN_DEPENDS= ${LOCALBASE}/aster/${vaster}/asteru.exe:${PORTSDIR}/french/aster
+
RESTRICTED= "Toute personne chargeant le logiciel HOMARD s'engage à ne\
- l'utiliser qu'en couplage avec le logiciel Code_ASTER. Pour\
+ l'utiliser qu'en couplage avec le logiciel Code_Aster. Pour\
tout autre usage, un droit de licence est nécessaire.\
Contacter les administrateurs de HOMARD à l'adresse :\
<homard@edf.fr>."
-WRKSRC= ${WRKDIR}/ASTER_HOMARD
-
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
@@ -32,39 +32,53 @@ REINPLACE_ARGS= -i ""
NO_BUILD= yes
LHOMARDDIR?= apps/${PORTNAME}
-ASTER_VER= 7.1
+ASTER_VER= 7.2
vaster= STA${ASTER_VER}
ASTER_TOOLS= ${LOCALBASE}/aster/${vaster}/outils
HOMARDDIR= ${PREFIX}/${LHOMARDDIR}
AHPY= aster_homard_py
+AHPY5= aster_homard_V5x_py
+HOMARDSCRIPT= ${WRKDIR}/${PORTNAME}_base
# This name is requested to run aster's make test
HOMARDPG= ${PORTNAME:U}_V${PORTVERSION}.out
+DOCS= A_Lire.txt Readme.txt
+
.include <bsd.port.pre.mk>
unames!= ${UNAME} -s
-PLIST_SUB= HOMARDDIR=${LHOMARDDIR} AHPY=${LHOMARDDIR}/${AHPY} \
- UNAMES=${unames} HOMARDPG=${HOMARDPG}
+PLIST_SUB= HOMARDDIR=${LHOMARDDIR} AHPY=${LHOMARDDIR}/${AHPY} \
+ AHPY5=${LHOMARDDIR}/${AHPY5} UNAMES=${unames} HOMARDPG=${HOMARDPG} \
+ ASTER_TOOLS=${ASTER_TOOLS}
BRANDELF?= /usr/bin/brandelf
post-patch:
- @${REINPLACE_CMD} -e "s#HOMARD_REP_PRO=??????#HOMARD_REP_PRO=${ASTER_TOOLS}#" \
- -e "s#HOMARD_REP_EXE=??????#HOMARD_REP_EXE=${PREFIX}/bin#" \
- -e "s#PYTHON_EXE=??????#PYTHON_EXE=${PYTHON_CMD}#" \
- ${WRKSRC}/${PORTNAME}
- @${CHMOD} u+w ${WRKSRC}/${AHPY}
+ @${REINPLACE_CMD} -e "s#/home/homard/ASTER_HOMARD#${ASTER_TOOLS}#" \
+ -e "s#/logiciels/HOMARD/HOMARD_PUBLIC#${PREFIX}/bin#" \
+ -e "s#/local/edf-python-2.1.1/bin/python#${PYTHON_CMD}#" \
+ ${HOMARDSCRIPT}
do-install:
- ${MKDIR} ${HOMARDDIR}
- ${MKDIR} ${PREFIX}/bin/${unames}
- ${INSTALL_PROGRAM} ${WRKDIR}/${HOMARDPG} ${PREFIX}/bin/${unames}
- ${BRANDELF} -t Linux ${PREFIX}/bin/${unames}/${HOMARDPG}
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${HOMARDDIR}
- ${CP} -R ${WRKSRC}/${AHPY} ${HOMARDDIR}
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${HOMARDDIR}
- ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${HOMARDDIR}
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${HOMARDDIR}
+ @${MKDIR} ${HOMARDDIR}
+ @${MKDIR} ${PREFIX}/bin/${unames}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${HOMARDPG} ${PREFIX}/bin/${unames}
+ @${BRANDELF} -t Linux ${PREFIX}/bin/${unames}/${HOMARDPG}
+ @${INSTALL_SCRIPT} ${HOMARDSCRIPT} ${HOMARDDIR}/${PORTNAME}
+ @${CP} -R ${WRKSRC}/${AHPY} ${HOMARDDIR}
+ @${CP} -R ${WRKSRC}/${AHPY5} ${HOMARDDIR}
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${HOMARDDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${HOMARDDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${HOMARDDIR}
+ @${LN} -fs ${HOMARDDIR}/homard ${ASTER_TOOLS}/
+ @${LN} -fs ${HOMARDDIR}/aster_homard_py ${ASTER_TOOLS}/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOCS}
+ @${INSTALL_DATA} ${WRKDIR}/${doc} ${DOCSDIR}
+.endfor
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
post-install:
@${ECHO_MSG}
diff --git a/french/homard/distinfo b/french/homard/distinfo
index 62a641913a3c..184db7cec47b 100644
--- a/french/homard/distinfo
+++ b/french/homard/distinfo
@@ -1 +1 @@
-MD5 (homard_linux_5.5.tar.gz) = 79c2a6d0304c4409f53c5198ef366a90
+MD5 (HOMARD_V6.2.Linux.tar.gz) = 4dced6bc6912450d18bd55cf484fc46b
diff --git a/french/homard/pkg-plist b/french/homard/pkg-plist
index 5eafcc350204..663995d58583 100644
--- a/french/homard/pkg-plist
+++ b/french/homard/pkg-plist
@@ -1,4 +1,7 @@
bin/%%UNAMES%%/%%HOMARDPG%%
+%%AHPY%%/__init__.py
+%%AHPY%%/__init__.pyc
+%%AHPY%%/__init__.pyo
%%AHPY%%/aster_homard.py
%%AHPY%%/aster_homard.pyc
%%AHPY%%/aster_homard.pyo
@@ -17,20 +20,52 @@ bin/%%UNAMES%%/%%HOMARDPG%%
%%AHPY%%/aster_homard_5.py
%%AHPY%%/aster_homard_5.pyc
%%AHPY%%/aster_homard_5.pyo
-%%AHPY%%/aster_homard_6.py
-%%AHPY%%/aster_homard_6.pyc
-%%AHPY%%/aster_homard_6.pyo
-%%AHPY%%/aster_homard_7.py
-%%AHPY%%/aster_homard_7.pyc
-%%AHPY%%/aster_homard_7.pyo
-%%AHPY%%/aster_homard_8.py
-%%AHPY%%/aster_homard_8.pyc
-%%AHPY%%/aster_homard_8.pyo
%%AHPY%%/aster_homard_utilitaires.py
%%AHPY%%/aster_homard_utilitaires.pyc
%%AHPY%%/aster_homard_utilitaires.pyo
+%%AHPY5%%/__init__.py
+%%AHPY5%%/__init__.pyc
+%%AHPY5%%/__init__.pyo
+%%AHPY5%%/aster_homard_1.py
+%%AHPY5%%/aster_homard_1.pyc
+%%AHPY5%%/aster_homard_1.pyo
+%%AHPY5%%/aster_homard_2.py
+%%AHPY5%%/aster_homard_2.pyc
+%%AHPY5%%/aster_homard_2.pyo
+%%AHPY5%%/aster_homard_3.py
+%%AHPY5%%/aster_homard_3.pyc
+%%AHPY5%%/aster_homard_3.pyo
+%%AHPY5%%/aster_homard_4.py
+%%AHPY5%%/aster_homard_4.pyc
+%%AHPY5%%/aster_homard_4.pyo
+%%AHPY5%%/aster_homard_5.py
+%%AHPY5%%/aster_homard_5.pyc
+%%AHPY5%%/aster_homard_5.pyo
+%%AHPY5%%/aster_homard_6.py
+%%AHPY5%%/aster_homard_6.pyc
+%%AHPY5%%/aster_homard_6.pyo
+%%AHPY5%%/aster_homard_7.py
+%%AHPY5%%/aster_homard_7.pyc
+%%AHPY5%%/aster_homard_7.pyo
+%%AHPY5%%/aster_homard_8.py
+%%AHPY5%%/aster_homard_8.pyc
+%%AHPY5%%/aster_homard_8.pyo
+%%AHPY5%%/aster_homard_V5x.py
+%%AHPY5%%/aster_homard_V5x.pyc
+%%AHPY5%%/aster_homard_V5x.pyo
+%%AHPY5%%/aster_homard_utilitaires.py
+%%AHPY5%%/aster_homard_utilitaires.pyc
+%%AHPY5%%/aster_homard_utilitaires.pyo
%%HOMARDDIR%%/homard
+%%PORTDOCS%%%%DOCSDIR%%/A_Lire.txt
+%%PORTDOCS%%%%DOCSDIR%%/Readme.txt
@dirrm %%AHPY%%
+@dirrm %%AHPY5%%
@dirrm %%HOMARDDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@exec ln -sf %%HOMARDDIR%%/aster_homard_py %%ASTER_TOOLS%%
+@exec ln -sf %%HOMARDDIR%%/homard %%ASTER_TOOLS%%
+@unexec rm -f %%ASTER_TOOLS%%/aster_homard_py
+@unexec rm -f %%ASTER_TOOLS%%/homard
@unexec rmdir %D/bin/%%UNAMES%% 2>/dev/null || true
@unexec rmdir %D/apps 2>/dev/null || true