aboutsummaryrefslogtreecommitdiff
path: root/ftp/axel/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-26 09:58:33 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-26 09:58:33 +0000
commit1933bfac5966c4c873f2170214fc9390476dcc39 (patch)
tree0703b05c980a1a962f207fe4415499f2f3f22ae8 /ftp/axel/Makefile
parent5c7bf71301cf74b9fc42fef0bef4145a737511d3 (diff)
downloadports-1933bfac5966c4c873f2170214fc9390476dcc39.tar.gz
ports-1933bfac5966c4c873f2170214fc9390476dcc39.zip
Convert left unconverted ports in ftp to new options framework
Notes
Notes: svn path=/head/; revision=315271
Diffstat (limited to 'ftp/axel/Makefile')
-rw-r--r--ftp/axel/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/ftp/axel/Makefile b/ftp/axel/Makefile
index 73867c22f02f..ee3300825d59 100644
--- a/ftp/axel/Makefile
+++ b/ftp/axel/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: axel
-# Date created: Jul 23, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= axel
PORTVERSION= 2.4
@@ -21,12 +16,11 @@ USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
-OPTIONS= NLS "I18N support" on \
- DEBUG "Debugging support" off
+OPTIONS_DEFINE= NLS DEBUG
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
USE_ICONV= yes
PLIST_SUB+= NLS=""
@@ -36,7 +30,7 @@ PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+=--i18n=0
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--debug=1 --strip=0
.endif
@@ -47,4 +41,4 @@ post-configure:
@${REINPLACE_CMD} -e 's|gcc|${CC}|; \
s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile.settings
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>