aboutsummaryrefslogtreecommitdiff
path: root/ftp/bsdftpd-ssl
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-19 14:09:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-19 14:09:28 +0000
commit07fb09d8f42e8f81d7c75b1e33ea16fbe11a5de8 (patch)
tree5247e9d799bbaab085bb16ddeb8a1984bca5203c /ftp/bsdftpd-ssl
parent50ee70d703679062bd0ae5896a52a6674d7e66ef (diff)
downloadports-07fb09d8f42e8f81d7c75b1e33ea16fbe11a5de8.tar.gz
ports-07fb09d8f42e8f81d7c75b1e33ea16fbe11a5de8.zip
Fix build on HEAD, by properly defining the MAKE_ENV and by actually using it.
Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=323294
Diffstat (limited to 'ftp/bsdftpd-ssl')
-rw-r--r--ftp/bsdftpd-ssl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/ftp/bsdftpd-ssl/Makefile b/ftp/bsdftpd-ssl/Makefile
index 259821d2de61..41d0cbc6c66e 100644
--- a/ftp/bsdftpd-ssl/Makefile
+++ b/ftp/bsdftpd-ssl/Makefile
@@ -19,7 +19,7 @@ COMMENT= FTP command-line client utility with the TLS/SSL support
USE_OPENSSL= yes
-MAKE_ENV+= OBJFORMAT= elf
+MAKE_ENV+= OBJFORMAT=elf
.include <bsd.port.pre.mk>
@@ -61,10 +61,10 @@ pre-build:
do-build:
# Client part
- (cd ${WRKSRC}/port && make && cd ${WRKSRC}/ftp && make) || exit
+ (cd ${WRKSRC}/port && ${SETENV} ${MAKE_ENV} make && cd ${WRKSRC}/ftp && ${SETENV} ${MAKE_ENV} make) || exit
# Server part
.if !defined(CLIENT_ONLY)
- (cd ${WRKSRC}/ftpd && make) || exit
+ (cd ${WRKSRC}/ftpd && ${SETENV} ${MAKE_ENV} make) || exit
.endif
do-install: