aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-06-05 19:40:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-06-05 19:40:00 +0000
commit32027d75fc5dad5c636247930f4967e3b576a1bc (patch)
tree654b6cc541da3314a25295fc7fb789063d7b39ee /ftp/curl
parente7798bb3ac95047fffc11d2fa6e422dc13e896ea (diff)
downloadports-32027d75fc5dad5c636247930f4967e3b576a1bc.tar.gz
ports-32027d75fc5dad5c636247930f4967e3b576a1bc.zip
Update to 7.65.1
Notes
Notes: svn path=/head/; revision=503519
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile3
-rw-r--r--ftp/curl/distinfo6
-rw-r--r--ftp/curl/files/patch-lib-md4.c15
-rw-r--r--ftp/curl/files/patch-lib-url.c9
-rw-r--r--ftp/curl/files/patch-src-tool_setopt.c61
-rw-r--r--ftp/curl/files/patch-src-tool_setopt.h90
6 files changed, 4 insertions, 180 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index dd326a3fdbe7..91714b590ede 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 7.65.0
-PORTREVISION= 3
+PORTVERSION= 7.65.1
CATEGORIES= ftp net www
MASTER_SITES= https://curl.haxx.se/download/ \
LOCAL/sunpoet
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index 246e49e6080d..ff2eb3319ba2 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1558782813
-SHA256 (curl-7.65.0.tar.xz) = 7766d263929404f693905b5e5222aa0f2bdf8c66ab4b8758f0c0820a42b966cd
-SIZE (curl-7.65.0.tar.xz) = 2392324
+TIMESTAMP = 1559751348
+SHA256 (curl-7.65.1.tar.xz) = f6c22074877f235aebc7c53057dbc7ee82358f8ae58bfb767e955c18c859a77a
+SIZE (curl-7.65.1.tar.xz) = 2392672
diff --git a/ftp/curl/files/patch-lib-md4.c b/ftp/curl/files/patch-lib-md4.c
deleted file mode 100644
index 441adabe1703..000000000000
--- a/ftp/curl/files/patch-lib-md4.c
+++ /dev/null
@@ -1,15 +0,0 @@
-Obtained from: https://github.com/curl/curl/commit/0dc9a8019962d31787c4929d36de6817ae3090e7
-
---- lib/md4.c.orig 2019-05-20 08:13:23 UTC
-+++ lib/md4.c
-@@ -38,6 +38,10 @@
-
- #include "curl_setup.h"
-
-+#ifdef USE_OPENSSL
-+#include <openssl/opensslconf.h>
-+#endif
-+
- /* The NSS, OS/400, and when not included, OpenSSL and mbed TLS crypto
- * libraries do not provide the MD4 hash algorithm, so we use this
- * implementation of it */
diff --git a/ftp/curl/files/patch-lib-url.c b/ftp/curl/files/patch-lib-url.c
index 32de0d5a4a3c..770a9ca50b38 100644
--- a/ftp/curl/files/patch-lib-url.c
+++ b/ftp/curl/files/patch-lib-url.c
@@ -5,15 +5,6 @@ Last-Update: 2010-12-18
--- lib/url.c.orig 2019-05-21 17:57:39 UTC
+++ lib/url.c
-@@ -439,7 +439,7 @@ CURLcode Curl_init_userdefined(struct Cu
-
- set->httpreq = HTTPREQ_GET; /* Default HTTP request */
- set->rtspreq = RTSPREQ_OPTIONS; /* Default RTSP request */
--#ifndef CURL_DISABLE_FILE
-+#ifndef CURL_DISABLE_FTP
- set->ftp_use_epsv = TRUE; /* FTP defaults to EPSV operations */
- set->ftp_use_eprt = TRUE; /* FTP defaults to EPRT operations */
- set->ftp_use_pret = FALSE; /* mainly useful for drftpd servers */
@@ -552,6 +552,10 @@ CURLcode Curl_init_userdefined(struct Cu
CURL_HTTP_VERSION_1_1
#endif
diff --git a/ftp/curl/files/patch-src-tool_setopt.c b/ftp/curl/files/patch-src-tool_setopt.c
deleted file mode 100644
index fc1f2a7a391b..000000000000
--- a/ftp/curl/files/patch-src-tool_setopt.c
+++ /dev/null
@@ -1,61 +0,0 @@
-Obtained from: https://github.com/curl/curl/commit/f4f485c17b9a8b41c23ad1fa9fbcfc1973172ead
-
---- src/tool_setopt.c.orig 2019-05-16 20:54:53 UTC
-+++ src/tool_setopt.c
-@@ -713,4 +713,56 @@ CURLcode tool_setopt(CURL *curl, bool st
- return ret;
- }
-
-+#else /* CURL_DISABLE_LIBCURL_OPTION */
-+
-+#include "tool_cfgable.h"
-+#include "tool_setopt.h"
-+
- #endif /* CURL_DISABLE_LIBCURL_OPTION */
-+
-+CURLcode tool_real_error(CURLcode result, CURLoption tag)
-+{
-+#ifdef CURL_DISABLE_PROXY
-+ switch(tag) {
-+ case CURLOPT_HAPROXYPROTOCOL:
-+ case CURLOPT_HTTPPROXYTUNNEL:
-+ case CURLOPT_NOPROXY:
-+ case CURLOPT_PRE_PROXY:
-+ case CURLOPT_PROXY:
-+ case CURLOPT_PROXYAUTH:
-+ case CURLOPT_PROXY_CAINFO:
-+ case CURLOPT_PROXY_CAPATH:
-+ case CURLOPT_PROXY_CRLFILE:
-+ case CURLOPT_PROXYHEADER:
-+ case CURLOPT_PROXY_KEYPASSWD:
-+ case CURLOPT_PROXYPASSWORD:
-+ case CURLOPT_PROXY_PINNEDPUBLICKEY:
-+ case CURLOPT_PROXYPORT:
-+ case CURLOPT_PROXY_SERVICE_NAME:
-+ case CURLOPT_PROXY_SSLCERT:
-+ case CURLOPT_PROXY_SSLCERTTYPE:
-+ case CURLOPT_PROXY_SSL_CIPHER_LIST:
-+ case CURLOPT_PROXY_SSLKEY:
-+ case CURLOPT_PROXY_SSLKEYTYPE:
-+ case CURLOPT_PROXY_SSL_OPTIONS:
-+ case CURLOPT_PROXY_SSL_VERIFYHOST:
-+ case CURLOPT_PROXY_SSL_VERIFYPEER:
-+ case CURLOPT_PROXY_SSLVERSION:
-+ case CURLOPT_PROXY_TLS13_CIPHERS:
-+ case CURLOPT_PROXY_TLSAUTH_PASSWORD:
-+ case CURLOPT_PROXY_TLSAUTH_TYPE:
-+ case CURLOPT_PROXY_TLSAUTH_USERNAME:
-+ case CURLOPT_PROXY_TRANSFER_MODE:
-+ case CURLOPT_PROXYTYPE:
-+ case CURLOPT_PROXYUSERNAME:
-+ case CURLOPT_PROXYUSERPWD:
-+ return CURLE_OK; /* pretend it worked */
-+ default:
-+ break;
-+ }
-+#else
-+ (void)tag;
-+#endif
-+ return result;
-+}
-+
diff --git a/ftp/curl/files/patch-src-tool_setopt.h b/ftp/curl/files/patch-src-tool_setopt.h
deleted file mode 100644
index 80c75ad18226..000000000000
--- a/ftp/curl/files/patch-src-tool_setopt.h
+++ /dev/null
@@ -1,90 +0,0 @@
-Obtained from: https://github.com/curl/curl/commit/f4f485c17b9a8b41c23ad1fa9fbcfc1973172ead
-
---- src/tool_setopt.h.orig 2019-04-15 07:05:14 UTC
-+++ src/tool_setopt.h
-@@ -29,11 +29,14 @@
- * Macros used in operate()
- */
-
--#define SETOPT_CHECK(v) do { \
-- result = (v); \
-- if(result) \
-- goto show_error; \
--} WHILE_FALSE
-+#define SETOPT_CHECK(v,opt) do { \
-+ result = tool_real_error((v), opt); \
-+ if(result) \
-+ goto show_error; \
-+ } WHILE_FALSE
-+
-+/* allow removed features to simulate success: */
-+CURLcode tool_real_error(CURLcode result, CURLoption tag);
-
- #ifndef CURL_DISABLE_LIBCURL_OPTION
-
-@@ -97,25 +100,25 @@ CURLcode tool_setopt(CURL *curl, bool st
- const char *name, CURLoption tag, ...);
-
- #define my_setopt(x,y,z) \
-- SETOPT_CHECK(tool_setopt(x, FALSE, global, #y, y, z))
-+ SETOPT_CHECK(tool_setopt(x, FALSE, global, #y, y, z), y)
-
- #define my_setopt_str(x,y,z) \
-- SETOPT_CHECK(tool_setopt(x, TRUE, global, #y, y, z))
-+ SETOPT_CHECK(tool_setopt(x, TRUE, global, #y, y, z), y)
-
- #define my_setopt_enum(x,y,z) \
-- SETOPT_CHECK(tool_setopt_enum(x, global, #y, y, setopt_nv_ ## y, z))
-+ SETOPT_CHECK(tool_setopt_enum(x, global, #y, y, setopt_nv_ ## y, z), y)
-
- #define my_setopt_flags(x,y,z) \
-- SETOPT_CHECK(tool_setopt_flags(x, global, #y, y, setopt_nv_ ## y, z))
-+ SETOPT_CHECK(tool_setopt_flags(x, global, #y, y, setopt_nv_ ## y, z), y)
-
- #define my_setopt_bitmask(x,y,z) \
-- SETOPT_CHECK(tool_setopt_bitmask(x, global, #y, y, setopt_nv_ ## y, z))
-+ SETOPT_CHECK(tool_setopt_bitmask(x, global, #y, y, setopt_nv_ ## y, z), y)
-
- #define my_setopt_mimepost(x,y,z) \
-- SETOPT_CHECK(tool_setopt_mimepost(x, global, #y, y, z))
-+ SETOPT_CHECK(tool_setopt_mimepost(x, global, #y, y, z), y)
-
- #define my_setopt_slist(x,y,z) \
-- SETOPT_CHECK(tool_setopt_slist(x, global, #y, y, z))
-+ SETOPT_CHECK(tool_setopt_slist(x, global, #y, y, z), y)
-
- #define res_setopt(x,y,z) tool_setopt(x, FALSE, global, #y, y, z)
-
-@@ -126,25 +129,25 @@ CURLcode tool_setopt(CURL *curl, bool st
- /* No --libcurl, so pass options directly to library */
-
- #define my_setopt(x,y,z) \
-- SETOPT_CHECK(curl_easy_setopt(x, y, z))
-+ SETOPT_CHECK(curl_easy_setopt(x, y, z), y)
-
- #define my_setopt_str(x,y,z) \
-- SETOPT_CHECK(curl_easy_setopt(x, y, z))
-+ SETOPT_CHECK(curl_easy_setopt(x, y, z), y)
-
- #define my_setopt_enum(x,y,z) \
-- SETOPT_CHECK(curl_easy_setopt(x, y, z))
-+ SETOPT_CHECK(curl_easy_setopt(x, y, z), y)
-
- #define my_setopt_flags(x,y,z) \
-- SETOPT_CHECK(curl_easy_setopt(x, y, z))
-+ SETOPT_CHECK(curl_easy_setopt(x, y, z), y)
-
- #define my_setopt_bitmask(x,y,z) \
-- SETOPT_CHECK(curl_easy_setopt(x, y, z))
-+ SETOPT_CHECK(curl_easy_setopt(x, y, z), y)
-
- #define my_setopt_mimepost(x,y,z) \
-- SETOPT_CHECK(curl_easy_setopt(x, y, z))
-+ SETOPT_CHECK(curl_easy_setopt(x, y, z), y)
-
- #define my_setopt_slist(x,y,z) \
-- SETOPT_CHECK(curl_easy_setopt(x, y, z))
-+ SETOPT_CHECK(curl_easy_setopt(x, y, z), y)
-
- #define res_setopt(x,y,z) curl_easy_setopt(x,y,z)
-