aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-05 19:31:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-05 19:31:45 +0000
commit73b75ad884160482c8d24c6464f6afd27f7dca52 (patch)
tree0481087f6e796a92cc8227c77baccf9455b20d90 /ftp/curl
parent78371f9bcefbdbcc3c674ac98122e9eec83648d5 (diff)
downloadports-73b75ad884160482c8d24c6464f6afd27f7dca52.tar.gz
ports-73b75ad884160482c8d24c6464f6afd27f7dca52.zip
- Update to 7.14.0
- Provide WITH_GNUTLS knob to replace OpenSSL with GnuTLS PR: ports/81195 Submitted by: Vasil Dimov <vd@datamax.bg> Approved by: maintainer timeout (18 days)
Notes
Notes: svn path=/head/; revision=136850
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile21
-rw-r--r--ftp/curl/distinfo4
-rw-r--r--ftp/curl/files/patch-tests::runtests.pl6
-rw-r--r--ftp/curl/pkg-plist1
4 files changed, 24 insertions, 8 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index fd396654795f..b42d0cf48638 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 7.13.1
-PORTREVISION= 1
+PORTVERSION= 7.14.0
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
${MASTER_SITE_SOURCEFORGE} \
@@ -49,6 +48,11 @@ PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
GNU_CONFIGURE= yes
USE_BZIP2= yes
+
+.if defined(WITH_GNUTLS)
+WITHOUT_SSL= yes
+.endif
+
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
.endif
@@ -57,9 +61,20 @@ USE_OPENSSL= yes
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
-PLIST_SUB+= SSL=""
.else
CONFIGURE_ARGS= --without-ssl
+.endif
+
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+=--with-gnutls=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-gnutls
+.endif
+
+.if !defined(WITHOUT_SSL) || defined(WITH_GNUTLS)
+PLIST_SUB+= SSL=""
+.else
PLIST_SUB+= SSL="@comment "
.endif
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index 4113a05fe6cc..93bf4be8f139 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,2 +1,2 @@
-MD5 (curl-7.13.1.tar.bz2) = d673f68dbab2553acdbfb5435bd1cd48
-SIZE (curl-7.13.1.tar.bz2) = 1860688
+MD5 (curl-7.14.0.tar.bz2) = 46ce665e47d37fce1a0bad935cce58a9
+SIZE (curl-7.14.0.tar.bz2) = 1920305
diff --git a/ftp/curl/files/patch-tests::runtests.pl b/ftp/curl/files/patch-tests::runtests.pl
index a27a3eae8e77..c071e58c933b 100644
--- a/ftp/curl/files/patch-tests::runtests.pl
+++ b/ftp/curl/files/patch-tests::runtests.pl
@@ -1,11 +1,11 @@
---- tests/runtests.pl.orig Sat Mar 12 03:40:30 2005
-+++ tests/runtests.pl Sat Mar 12 03:40:39 2005
+--- tests/runtests.pl.orig Wed May 18 11:50:16 2005
++++ tests/runtests.pl Wed May 18 11:50:32 2005
@@ -29,7 +29,7 @@
@INC=(@INC, $ENV{'srcdir'}, ".");
require "getpart.pm"; # array functions
-require "valgrind.pm"; # valgrind report parser
+#require "valgrind.pm"; # valgrind report parser
+ require "ftp.pm";
my $srcdir = $ENV{'srcdir'} || '.';
- my $HOSTIP="127.0.0.1";
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index 72780d1c3bd1..00c17bc33162 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -70,6 +70,7 @@ lib/libcurl.so.%%SHLIB_VER%%
%%PORTDOCS%%%%DOCSDIR%%/examples/multi-post.c
%%PORTDOCS%%%%DOCSDIR%%/examples/multi-single.c
%%PORTDOCS%%%%DOCSDIR%%/examples/multithread.c
+%%PORTDOCS%%%%DOCSDIR%%/examples/opensslthreadlock.c
%%PORTDOCS%%%%DOCSDIR%%/examples/persistant.c
%%PORTDOCS%%%%DOCSDIR%%/examples/post-callback.c
%%PORTDOCS%%%%DOCSDIR%%/examples/postit2.c