aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-09-12 16:00:47 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-09-12 16:00:47 +0000
commite09781e206a8ada85debadc307709fd85184c34d (patch)
tree0f5af75cc5eba9900a4c866440205d075571d521 /ftp/curl
parentbbe4b23747e37f1d73671e903d7120565f51c618 (diff)
downloadports-e09781e206a8ada85debadc307709fd85184c34d.tar.gz
ports-e09781e206a8ada85debadc307709fd85184c34d.zip
- Fix nghttp2 version requirement
- Bump PORTREVISION for www/nghttp2 shlib change
Notes
Notes: svn path=/head/; revision=368037
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index d4a018b18d45..8bcdc0ef13c6 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.38.0
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -86,11 +87,11 @@ HEIMDAL_PORT_CONFIGURE_ON= --with-gssapi=${HEIMDAL_HOME}
HEIMDAL_PORT_CPPFLAGS= -I${HEIMDAL_HOME}/include
HEIMDAL_PORT_LDFLAGS= -L${HEIMDAL_HOME}/lib
HEIMDAL_PORT_LIB_DEPENDS= libgssapi.so.3:${PORTSDIR}/security/heimdal
-HTTP2_BUILD_DEPENDS= nghttp2>=0.4.0:${PORTSDIR}/www/nghttp2
+HTTP2_BUILD_DEPENDS= nghttp2>=0.6.0:${PORTSDIR}/www/nghttp2
HTTP2_CONFIGURE_OFF= --without-nghttp2
HTTP2_CONFIGURE_ON= --with-nghttp2=${LOCALBASE}
HTTP2_LIB_DEPENDS= libnghttp2.so:${PORTSDIR}/www/nghttp2
-HTTP2_RUN_DEPENDS= nghttp2>=0.4.0:${PORTSDIR}/www/nghttp2
+HTTP2_RUN_DEPENDS= nghttp2>=0.6.0:${PORTSDIR}/www/nghttp2
HTTP2_USES= pkgconfig
IDN_CONFIGURE_OFF= --without-libidn
IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE}