aboutsummaryrefslogtreecommitdiff
path: root/ftp/frox/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-19 08:16:22 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-19 08:16:22 +0000
commit822f0bd1364a0bb76dbd7abf0a142e76ed94ca97 (patch)
treeded9717f70c0a95927c1f0166d8225994622e0b2 /ftp/frox/Makefile
parentdfbd574b027eb1062ecc3254244635660d313824 (diff)
downloadports-822f0bd1364a0bb76dbd7abf0a142e76ed94ca97.tar.gz
ports-822f0bd1364a0bb76dbd7abf0a142e76ed94ca97.zip
- Update to 0.7.12
- use rcNG script - make configure script happy with CONFIGURE_TARGET - use PORTDOCS to autoaddition docs in PLIST PR: 61561 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=98532
Diffstat (limited to 'ftp/frox/Makefile')
-rw-r--r--ftp/frox/Makefile30
1 files changed, 20 insertions, 10 deletions
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
index cd0130894020..19390531bffe 100644
--- a/ftp/frox/Makefile
+++ b/ftp/frox/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= frox
-PORTVERSION= 0.7.11
+PORTVERSION= 0.7.12
CATEGORIES= ftp
MASTER_SITES= http://www.hollo.org/frox/download/ \
http://frox.sourceforge.net/download/ \
@@ -19,11 +19,22 @@ COMMENT= Transparent FTP proxy with caching support
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+USE_RC_SUBR= yes
+RC_DIR?= ${PREFIX}/etc/rc.d
+RC_SUFX?= .sh
+SED_SCRIPT= -e 's|%%PREFIX%%|${PREFIX}|g' \
+ -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
+ -e 's|%%RC_DIR%%|${RC_DIR}|g' \
+ -e 's|%%RC_SUFX%%|${RC_SUFX}|g'
+
+PLIST_SUB+= RC_DIR=${RC_DIR} RC_SUFX=${RC_SUFX}
MAN1= frox.1
MAN5= frox.conf.5
-DOCS= FAQ SECURITY CREDITS ChangeLog
+PORTDOCS= FAQ SECURITY CREDITS ChangeLog
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -63,7 +74,8 @@ pre-fetch:
@${ECHO_MSG} ""
pre-patch:
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}
+ @${SED} ${SED_SCRIPT} ${PKGDIR}/pkg-message >${PKGMESSAGE}
+ @${SED} ${SED_SCRIPT} ${FILESDIR}/frox.sh > ${WRKDIR}/frox.sh
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/frox ${PREFIX}/sbin
@@ -74,15 +86,13 @@ do-install:
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for f in ${DOCS}
+.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
.endfor
.endif
- @${STRIP_CMD} ${PREFIX}/sbin/frox
- @if [ ! -f ${PREFIX}/etc/rc.d/${PORTNAME}.sh ]; then \
- ${ECHO_MSG} "Install ${PREFIX}/etc/rc.d/${PORTNAME}.sh startup file."; \
- ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/${PORTNAME}.sh; \
- fi
- @${CAT} ${PKGMESSAGE}
+ @${STRIP_CMD} ${PREFIX}/sbin/frox; \
+ ${ECHO_MSG} "Install ${RC_DIR}/frox${RC_SUFX} startup file."; \
+ ${INSTALL_SCRIPT} -m 751 ${WRKDIR}/frox.sh ${RC_DIR}/frox${RC_SUFX}; \
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>