aboutsummaryrefslogtreecommitdiff
path: root/ftp/ftplocate
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-01-29 21:23:44 +0000
committerSteve Price <steve@FreeBSD.org>2000-01-29 21:23:44 +0000
commit722c55c877dd1c6e3837b5694f567e14ad9d96d4 (patch)
tree7649adbece9d867c1f3ad8b5052ef8ceedc437b5 /ftp/ftplocate
parent32edd5a5f81d59535521a3af50eb8d2054b4b80c (diff)
downloadports-722c55c877dd1c6e3837b5694f567e14ad9d96d4.tar.gz
ports-722c55c877dd1c6e3837b5694f567e14ad9d96d4.zip
Make sure we use the correct path to perl(1).
PR: 16202
Notes
Notes: svn path=/head/; revision=25259
Diffstat (limited to 'ftp/ftplocate')
-rw-r--r--ftp/ftplocate/Makefile16
-rw-r--r--ftp/ftplocate/pkg-plist1
2 files changed, 13 insertions, 4 deletions
diff --git a/ftp/ftplocate/Makefile b/ftp/ftplocate/Makefile
index a96150bf835e..d1052278054b 100644
--- a/ftp/ftplocate/Makefile
+++ b/ftp/ftplocate/Makefile
@@ -17,6 +17,14 @@ RUN_DEPENDS+= glimpse:${PORTSDIR}/textproc/glimpse
USE_PERL5= yes
NO_BUILD= yes
+PL_FILES= dcollect.pl dindex.pl dsearch.pl flcollect.pl flfilter.pl \
+ flhistory.pl flindex.pl flsearch.pl flserv.pl fltrain.pl
+
+post-extract:
+.for f in ${PL_FILES}
+ @${PERL} -pi -e 's,/usr/local/bin/perl,${PERL},' ${WRKSRC}/${f}
+.endfor
+
do-install:
${INSTALL} -d ${PREFIX}/www/cgi-bin/ftplocate \
${PREFIX}/www/cgi-bin/ftplocate/index \
@@ -30,14 +38,14 @@ do-install:
${INSTALL} -c -m 644 \
fl.config fl.share \
${PREFIX}/www/cgi-bin/ftplocate ;\
- ${INSTALL_SCRIPT} \
- dcollect.pl dindex.pl flcollect.pl flindex.pl indexer.sh \
- flfilter.pl flsearch.pl dsearch.pl flserv.pl flhistory.pl \
- ${PREFIX}/www/cgi-bin/ftplocate ;\
+ ${INSTALL_SCRIPT} indexer.sh ${PREFIX}/www/cgi-bin/ftplocate; \
${INSTALL_DATA} \
flhelp.html flhelp.zhtw.html \
${PREFIX}/www/data ;\
${INSTALL_SCRIPT} ftplocate ${PREFIX}/bin/
+.for f in ${PL_FILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/www/cgi-bin/ftplocate
+.endfor
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/ftp/ftplocate/pkg-plist b/ftp/ftplocate/pkg-plist
index 3e3b86c9e763..d8b2010b59ba 100644
--- a/ftp/ftplocate/pkg-plist
+++ b/ftp/ftplocate/pkg-plist
@@ -14,6 +14,7 @@ www/cgi-bin/ftplocate/flhistory.pl
www/cgi-bin/ftplocate/flindex.pl
www/cgi-bin/ftplocate/flsearch.pl
www/cgi-bin/ftplocate/flserv.pl
+www/cgi-bin/ftplocate/fltrain.pl
www/cgi-bin/ftplocate/indexer.sh
www/data/flhelp.html
www/data/flhelp.zhtw.html