aboutsummaryrefslogtreecommitdiff
path: root/ftp/ocaml-ocurl
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-08-08 19:20:32 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-08-08 19:20:32 +0000
commit75236c0e70fbf723f4238602428a528496cc2763 (patch)
treed735e82a44e9d416cf9496159c527fb2b97403f3 /ftp/ocaml-ocurl
parent551bf87ac3708333308de1338cd0773e76ddd39e (diff)
downloadports-75236c0e70fbf723f4238602428a528496cc2763.tar.gz
ports-75236c0e70fbf723f4238602428a528496cc2763.zip
Add ocaml-ocurl 0.2.0, an interface for OCaml to the curl lib.
PR: 70085 Submitted by: Marwan BURELLE
Notes
Notes: svn path=/head/; revision=115676
Diffstat (limited to 'ftp/ocaml-ocurl')
-rw-r--r--ftp/ocaml-ocurl/Makefile38
-rw-r--r--ftp/ocaml-ocurl/distinfo2
-rw-r--r--ftp/ocaml-ocurl/pkg-descr9
-rw-r--r--ftp/ocaml-ocurl/pkg-install9
4 files changed, 58 insertions, 0 deletions
diff --git a/ftp/ocaml-ocurl/Makefile b/ftp/ocaml-ocurl/Makefile
new file mode 100644
index 000000000000..75e14a639d7d
--- /dev/null
+++ b/ftp/ocaml-ocurl/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: ocurl
+# Date created: Aug 6, 2004
+# Whom: Marwan BURELLE <marwan.burelle@lri.fr>
+# $FreeBSD$
+
+PORTNAME= ocurl
+PORTVERSION= 0.2.0
+CATEGORIES= ftp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ocaml-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= marwan.burelle@lri.fr
+COMMENT= An interface for OCaml to the curl lib
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+="--with-findlib"
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+PKGDEINSTALL= ${PKGINSTALL}
+FINDLIB_PKGNAME=${PORTNAME:S/o//}
+
+post-install:
+ @${FIND} ${PREFIX}/lib/ocaml/site-lib/${FINDLIB_PKGNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/${FINDLIB_PKGNAME}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ocamlfind remove ${FINDLIB_PKGNAME} 2>/dev/null || true" >> ${TMPPLIST}
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/ftp/ocaml-ocurl/distinfo b/ftp/ocaml-ocurl/distinfo
new file mode 100644
index 000000000000..4bd654157095
--- /dev/null
+++ b/ftp/ocaml-ocurl/distinfo
@@ -0,0 +1,2 @@
+MD5 (ocurl-0.2.0.tgz) = 79200fb81232c91002b1e008dd75cba5
+SIZE (ocurl-0.2.0.tgz) = 73868
diff --git a/ftp/ocaml-ocurl/pkg-descr b/ftp/ocaml-ocurl/pkg-descr
new file mode 100644
index 000000000000..58fc9d4a6c77
--- /dev/null
+++ b/ftp/ocaml-ocurl/pkg-descr
@@ -0,0 +1,9 @@
+The Ocaml Curl Library (Ocurl) is an interface library for the
+programming language Ocaml to the networking library
+libcurl. Currently Ocurl requires libcurl 7.9.8 or newer (using older
+versions may yield compilation errors).
+
+WWW: http://sourceforge.net/projects/ocurl
+
+- Marwan Burelle
+ <marwan.burelle@lri.fr>
diff --git a/ftp/ocaml-ocurl/pkg-install b/ftp/ocaml-ocurl/pkg-install
new file mode 100644
index 000000000000..b796d70cafc8
--- /dev/null
+++ b/ftp/ocaml-ocurl/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ "$2" = "POST-INSTALL" ]; then
+ echo "${PKG_PREFIX}/lib/ocaml/site-lib/curl" >> ${PKG_PREFIX}/lib/ocaml/ld.conf
+elif [ "$2" = "DEINSTALL" ]; then
+ mv ${PKG_PREFIX}/lib/ocaml/ld.conf ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
+ grep -v curl ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp > ${PKG_PREFIX}/lib/ocaml/ld.conf
+ rm -f ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
+fi