aboutsummaryrefslogtreecommitdiff
path: root/ftp/oftpd/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 00:39:05 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 00:39:05 +0000
commitaa2ee091802a3f97a2cd5f5c0d260ae93620b321 (patch)
tree1059fc9213340ae397fe81484c1790d5e3548824 /ftp/oftpd/Makefile
parent4f461548db4db806c83f1232b96f73d45ed1ba19 (diff)
downloadports-aa2ee091802a3f97a2cd5f5c0d260ae93620b321.tar.gz
ports-aa2ee091802a3f97a2cd5f5c0d260ae93620b321.zip
Add oftpd 0.3.3, a threaded, anonymous only FTP server designed for
security. PR: 26243 Submitted by: Anders Nordby <anders@fix.no>
Notes
Notes: svn path=/head/; revision=40975
Diffstat (limited to 'ftp/oftpd/Makefile')
-rw-r--r--ftp/oftpd/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/ftp/oftpd/Makefile b/ftp/oftpd/Makefile
new file mode 100644
index 000000000000..44e14d2d8c6d
--- /dev/null
+++ b/ftp/oftpd/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: oftpd
+# Date created: 31 March 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oftpd
+PORTVERSION= 0.3.3
+CATEGORIES= ftp
+MASTER_SITES= http://www.time-travellers.org/oftpd/ \
+ http://www.freenix.no/~anders/
+
+MAINTAINER= anders@fix.no
+
+GNU_CONFIGURE= yes
+
+DOCFILES= README AUTHORS ChangeLog NEWS TODO BUGS
+
+CFLAGS+= ${PTHREAD_CFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/oftpd ${PREFIX}/libexec/oftpd
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -m 555 ${PREFIX}/share/doc/oftpd
+.for i in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/oftpd
+.endfor
+.endif
+
+post-install:
+ @${ECHO} "================================================================================"
+ @${ECHO} "oftpd only runs standalone, not from inetd."
+ @${ECHO} "Try ${PREFIX}/libexec/oftpd -h to see command line options."
+ @${ECHO} "Create a README file in the root anonymous FTP dir to have it displayed to"
+ @${ECHO} "users upon login."
+ @${ECHO} "================================================================================"
+
+.include <bsd.port.mk>