aboutsummaryrefslogtreecommitdiff
path: root/ftp/oftpd
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-08 14:28:05 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-08 14:28:05 +0000
commit5d14c6f625cb0f8e66fc22e6fed8d78936d24bc4 (patch)
tree39325a5274cc5d3b287e1c2c70170dd4e2dbf4c3 /ftp/oftpd
parentb073b822c18589bd5803a3dcf4c2f8bcdb6ace74 (diff)
downloadports-5d14c6f625cb0f8e66fc22e6fed8d78936d24bc4.tar.gz
ports-5d14c6f625cb0f8e66fc22e6fed8d78936d24bc4.zip
- Add LICENSE
- Remove the indefinite article from COMMENT - Add stage support
Notes
Notes: svn path=/head/; revision=343337
Diffstat (limited to 'ftp/oftpd')
-rw-r--r--ftp/oftpd/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/ftp/oftpd/Makefile b/ftp/oftpd/Makefile
index 7ae0b0bdd782..47cf112d3757 100644
--- a/ftp/oftpd/Makefile
+++ b/ftp/oftpd/Makefile
@@ -8,15 +8,17 @@ MASTER_SITES= http://www.time-travellers.org/oftpd/ \
http://atreides.freenix.no/~anders/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A threaded, anonymous only FTP server designed for security
+COMMENT= Threaded, anonymous only FTP server designed for security
+
+LICENSE= BSD2CLAUSE
GNU_CONFIGURE= yes
-MAN8= oftpd.8
PORTDOCS= README AUTHORS ChangeLog NEWS TODO BUGS
-PLIST_FILES= sbin/oftpd
+PLIST_FILES= sbin/oftpd man/man8/oftpd.8.gz
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g ; \
s|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@@ -25,14 +27,11 @@ post-patch:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/oftpd ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/man/oftpd.8 ${MANPREFIX}/man/man8
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/oftpd ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/man/oftpd.8 ${STAGEDIR}${MANPREFIX}/man/man8
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>