aboutsummaryrefslogtreecommitdiff
path: root/ftp/p5-Net-FTP-Recursive
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-04-11 08:25:24 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-04-11 08:25:24 +0000
commitf8657ef3943adc0ac1a3fd39e46b491092d254c8 (patch)
treec03d427e20f8f74d2cbfa6c8dd3b44dbf4ca2a51 /ftp/p5-Net-FTP-Recursive
parent3f2ac9f26d19a6f3945498fdca031cb490bc89f4 (diff)
downloadports-f8657ef3943adc0ac1a3fd39e46b491092d254c8.tar.gz
ports-f8657ef3943adc0ac1a3fd39e46b491092d254c8.zip
Add p5-Net-FTP-Recursive 1.11, perl module to provide recursive FTP
client class.
Notes
Notes: svn path=/head/; revision=132999
Diffstat (limited to 'ftp/p5-Net-FTP-Recursive')
-rw-r--r--ftp/p5-Net-FTP-Recursive/Makefile25
-rw-r--r--ftp/p5-Net-FTP-Recursive/distinfo2
-rw-r--r--ftp/p5-Net-FTP-Recursive/pkg-descr11
-rw-r--r--ftp/p5-Net-FTP-Recursive/pkg-plist4
4 files changed, 42 insertions, 0 deletions
diff --git a/ftp/p5-Net-FTP-Recursive/Makefile b/ftp/p5-Net-FTP-Recursive/Makefile
new file mode 100644
index 000000000000..ee698e54fdca
--- /dev/null
+++ b/ftp/p5-Net-FTP-Recursive/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-FTP-Recursive
+# Date Created: 11 April, 2005
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-FTP-Recursive
+PORTVERSION= 1.11
+CATEGORIES= ftp perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/J/JD/JDLEE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl module to provide recursive FTP client class
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::FTP::Recursive.3
+
+.include <bsd.port.mk>
diff --git a/ftp/p5-Net-FTP-Recursive/distinfo b/ftp/p5-Net-FTP-Recursive/distinfo
new file mode 100644
index 000000000000..265f61e9f132
--- /dev/null
+++ b/ftp/p5-Net-FTP-Recursive/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-FTP-Recursive-1.11.tar.gz) = 5e5610f9b568843c8bad3a3fd725c103
+SIZE (Net-FTP-Recursive-1.11.tar.gz) = 13906
diff --git a/ftp/p5-Net-FTP-Recursive/pkg-descr b/ftp/p5-Net-FTP-Recursive/pkg-descr
new file mode 100644
index 000000000000..43308685f532
--- /dev/null
+++ b/ftp/p5-Net-FTP-Recursive/pkg-descr
@@ -0,0 +1,11 @@
+This module augments the list of Net::FTP methods with several
+methods that automatically descend directory structures for you.
+The methods are:
+
+ rget - Retrieve an entire directory tree.
+ rput - Send an entire directory tree.
+ rdir - Receive an entire directory tree listing.
+ rls - Receive an entire directory tree listing, filenames only.
+ rdelete - Remove an entire directory tree.
+
+WWW: http://search.cpan.org/dist/Net-FTP-Recursive/
diff --git a/ftp/p5-Net-FTP-Recursive/pkg-plist b/ftp/p5-Net-FTP-Recursive/pkg-plist
new file mode 100644
index 000000000000..17e87ba7729f
--- /dev/null
+++ b/ftp/p5-Net-FTP-Recursive/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Net/FTP/Recursive.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FTP/Recursive/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FTP/Recursive
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FTP 2>/dev/null || true