aboutsummaryrefslogtreecommitdiff
path: root/ftp/p5-POE-Component-Client-FTP/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-03-02 17:59:41 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-03-02 17:59:41 +0000
commit6f44334909c89c2b89465fb6e40215b1dd95e486 (patch)
tree12e54d5fadc7a1e3dc9893aa002001da1c967782 /ftp/p5-POE-Component-Client-FTP/Makefile
parent585d14b21ee286e354979596f3b698d3e56571c4 (diff)
downloadports-6f44334909c89c2b89465fb6e40215b1dd95e486.tar.gz
ports-6f44334909c89c2b89465fb6e40215b1dd95e486.zip
Update to 0.24
- Add LICENSE - Update *_DEPENDS - Add TEST_DEPENDS - Add NO_ARCH - Convert to options target helper Changes: http://search.cpan.org/dist/POE-Component-Client-FTP/Changes
Notes
Notes: svn path=/head/; revision=435262
Diffstat (limited to 'ftp/p5-POE-Component-Client-FTP/Makefile')
-rw-r--r--ftp/p5-POE-Component-Client-FTP/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/ftp/p5-POE-Component-Client-FTP/Makefile b/ftp/p5-POE-Component-Client-FTP/Makefile
index 864b3813bbec..c0f195435d8b 100644
--- a/ftp/p5-POE-Component-Client-FTP/Makefile
+++ b/ftp/p5-POE-Component-Client-FTP/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= POE-Component-Client-FTP
-PORTVERSION= 0.22
-PORTREVISION= 1
+PORTVERSION= 0.24
CATEGORIES= ftp perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,9 +10,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Implements an FTP client POE Component
-BUILD_DEPENDS= p5-POE>=0:devel/p5-POE
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-POE>=0.38:devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-POE-Client-TCP>=0.1:devel/p5-Test-POE-Client-TCP \
+ p5-Test-POE-Server-TCP>=0.16:devel/p5-Test-POE-Server-TCP
+NO_ARCH= yes
USES= perl5 shebangfix
USE_PERL5= configure
CONFIGURE_ENV= PERL_MM_USE_DEFAULT=yes
@@ -24,7 +30,7 @@ PORTEXAMPLES= dotfer.pl list.pl sync.pl
OPTIONS_DEFINE= EXAMPLES
-post-install:
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}