aboutsummaryrefslogtreecommitdiff
path: root/ftp/py-pycurl
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-07 16:00:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-07 16:00:23 +0000
commit5f74204fe15b50f03877ece0be89d0c00ac320b6 (patch)
treea82ab161db514d1a97ff246737c36ce7b7aa8123 /ftp/py-pycurl
parent31f5998a4cdbd0f6ac492f368fb91ac2c4e9d5b7 (diff)
downloadports-5f74204fe15b50f03877ece0be89d0c00ac320b6.tar.gz
ports-5f74204fe15b50f03877ece0be89d0c00ac320b6.zip
Add DOCS option
- Fix documentation installation: - Avoid conflicts between FLAVORS - Do not install license files - Bump PORTREVISION for package change PR: 224108 Reported by: Ting-Wei Lan <lantw44@gmail.com>
Notes
Notes: svn path=/head/; revision=455712
Diffstat (limited to 'ftp/py-pycurl')
-rw-r--r--ftp/py-pycurl/Makefile9
-rw-r--r--ftp/py-pycurl/files/patch-setup.py10
2 files changed, 19 insertions, 0 deletions
diff --git a/ftp/py-pycurl/Makefile b/ftp/py-pycurl/Makefile
index bb22b301a84d..73d26520908b 100644
--- a/ftp/py-pycurl/Makefile
+++ b/ftp/py-pycurl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pycurl
PORTVERSION= 7.43.0
+PORTREVISION= 1
CATEGORIES= ftp python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,10 +18,18 @@ LICENSE_MIT= ${WRKSRC}/COPYING-MIT
LIB_DEPENDS= libcurl.so:ftp/curl
+OPTIONS_DEFINE= DOCS
+
USE_PYTHON= autoplist concurrent distutils
USES= python ssl
+PORTDOCS= AUTHORS INSTALL.rst README.rst RELEASE-NOTES.rst
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}.so
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+
.include <bsd.port.mk>
diff --git a/ftp/py-pycurl/files/patch-setup.py b/ftp/py-pycurl/files/patch-setup.py
new file mode 100644
index 000000000000..c7b99461276c
--- /dev/null
+++ b/ftp/py-pycurl/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2016-02-04 04:39:06 UTC
++++ setup.py
+@@ -815,7 +815,6 @@ if __name__ == "__main__":
+ elif len(sys.argv) > 1 and sys.argv[1] == 'docstrings-sources':
+ gen_docstrings_sources()
+ else:
+- setup_args['data_files'] = get_data_files()
+ if 'PYCURL_RELEASE' in os.environ and os.environ['PYCURL_RELEASE'].lower() in ['1', 'yes', 'true']:
+ split_extension_source = False
+ else: