aboutsummaryrefslogtreecommitdiff
path: root/ftp/py-sftp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2018-03-08 14:01:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2018-03-08 14:01:11 +0000
commitacc32870266a668febd9e44fa9d0bf11161c663d (patch)
treef6e3bed05b288a52c10781bdd5abbeb1ded60cec /ftp/py-sftp
parentc3eee4247b7614348526c5dbeac69207416140ba (diff)
downloadports-acc32870266a668febd9e44fa9d0bf11161c663d.tar.gz
ports-acc32870266a668febd9e44fa9d0bf11161c663d.zip
A simple interface to SFTP.
The module offers high level abstractions and task based routines to handle your SFTP needs. Checkout the Cook Book, in the docs, to see what pysftp can do for you. WWW: https://bitbucket.org/dundeemt/pysftp PR: 226444 Submitted by: rozhuk.im@gmail.com
Notes
Notes: svn path=/head/; revision=463889
Diffstat (limited to 'ftp/py-sftp')
-rw-r--r--ftp/py-sftp/Makefile21
-rw-r--r--ftp/py-sftp/distinfo3
-rw-r--r--ftp/py-sftp/pkg-descr6
3 files changed, 30 insertions, 0 deletions
diff --git a/ftp/py-sftp/Makefile b/ftp/py-sftp/Makefile
new file mode 100644
index 000000000000..3d1b74f8f1bd
--- /dev/null
+++ b/ftp/py-sftp/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pysftp
+DISTVERSION= 0.2.9
+CATEGORIES= ftp python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= Simple interface to SFTP
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.17:security/py-paramiko@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/ftp/py-sftp/distinfo b/ftp/py-sftp/distinfo
new file mode 100644
index 000000000000..4843fd275482
--- /dev/null
+++ b/ftp/py-sftp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520508234
+SHA256 (pysftp-0.2.9.tar.gz) = fbf55a802e74d663673400acd92d5373c1c7ee94d765b428d9f977567ac4854a
+SIZE (pysftp-0.2.9.tar.gz) = 25949
diff --git a/ftp/py-sftp/pkg-descr b/ftp/py-sftp/pkg-descr
new file mode 100644
index 000000000000..040cc6bc7d34
--- /dev/null
+++ b/ftp/py-sftp/pkg-descr
@@ -0,0 +1,6 @@
+A simple interface to SFTP.
+The module offers high level abstractions and task based routines to
+handle your SFTP needs.
+Checkout the Cook Book, in the docs, to see what pysftp can do for you.
+
+WWW: https://bitbucket.org/dundeemt/pysftp