aboutsummaryrefslogtreecommitdiff
path: root/ftp/wget
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2017-07-20 09:59:33 +0000
committerVasil Dimov <vd@FreeBSD.org>2017-07-20 09:59:33 +0000
commit8a11b286e1043abbcfdfafe8d549bdc5c0c0105d (patch)
treed2db03561f39d5a0c92edb5e1b29da5613c943ec /ftp/wget
parent9a99ec6151419724b9ee4327ba4b509fad200d5b (diff)
downloadports-8a11b286e1043abbcfdfafe8d549bdc5c0c0105d.tar.gz
ports-8a11b286e1043abbcfdfafe8d549bdc5c0c0105d.zip
ftp/wget: Make installing docs optional
Submitted by: jkim
Notes
Notes: svn path=/head/; revision=446255
Diffstat (limited to 'ftp/wget')
-rw-r--r--ftp/wget/Makefile41
-rw-r--r--ftp/wget/pkg-plist4
2 files changed, 26 insertions, 19 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 1a95d3a05138..f1c87cd9edc7 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -15,37 +15,41 @@ LICENSE_FILE= ${WRKSRC}/COPYING
TEST_DEPENDS= p5-HTTP-Daemon>=0:www/p5-HTTP-Daemon \
p5-IO-Socket-SSL>=0:security/p5-IO-Socket-SSL
-USES= charsetfix cpe iconv makeinfo perl5 tar:xz
-USE_PERL5= build
+USES= charsetfix cpe iconv tar:xz
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
OPTIONS_SUB= yes
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL=GNUTLS OPENSSL
-OPTIONS_DEFINE= IPV6 NLS IDN METALINK PCRE PSL
-OPTIONS_DEFAULT=OPENSSL IDN
+OPTIONS_DEFINE= DOCS IDN IPV6 METALINK NLS PCRE PSL
+OPTIONS_DEFAULT=DOCS IDN OPENSSL
-PCRE_DESC= Support Perl regular expressions in addition to POSIX
-
-IPV6_CONFIGURE_ENABLE= ipv6
-
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
-NLS_CPPFLAGS= -I${LOCALBASE}/include
-NLS_LDFLAGS= -L${LOCALBASE}/lib
+DOCS_DESC= Install sample config file, info page and man page
+DOCS_INFO= wget
+DOCS_USE= PERL5=build
+DOCS_USES= makeinfo perl5
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2 \
libunistring.so:devel/libunistring
IDN_CPPFLAGS= -I${LOCALBASE}/include
IDN_LDFLAGS= -L${LOCALBASE}/lib
IDN_CONFIGURE_ENABLE= iri
-IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE} --with-libunistring-prefix=${LOCALBASE}
+IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE} \
+ --with-libunistring-prefix=${LOCALBASE}
IDN_CONFIGURE_OFF= --with-included-libunistring
+IPV6_CONFIGURE_ENABLE= ipv6
+
METALINK_CONFIGURE_WITH=metalink
METALINK_LIB_DEPENDS= libmetalink.so:misc/libmetalink
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
+
+PCRE_DESC= Support Perl regular expressions in addition to POSIX
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
PCRE_CPPFLAGS= -I${LOCALBASE}/include
PCRE_LDFLAGS= -L${LOCALBASE}/lib
@@ -71,15 +75,18 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--without-ssl
.endif
-INFO= wget
-
TEST_TARGET= check
-post-patch:
+post-patch-DOCS-off:
+ ${REINPLACE_CMD} -e '/^SUBDIRS = / s/ doc / /' ${WRKSRC}/Makefile.in
+
+post-patch-DOCS-on:
${REINPLACE_CMD} -e 's,WGETRC = $$(sysconfdir)/wgetrc,&.sample,' \
${WRKSRC}/doc/Makefile.in
${REINPLACE_CMD} -e 's,/usr/local/etc/wgetrc,${PREFIX}/etc/wgetrc,' \
- ${WRKSRC}/doc/sample.wgetrc* ${WRKSRC}/doc/wget.texi ${WRKSRC}/doc/wget.info
+ ${WRKSRC}/doc/sample.wgetrc* \
+ ${WRKSRC}/doc/wget.info \
+ ${WRKSRC}/doc/wget.texi
.include <bsd.port.pre.mk>
diff --git a/ftp/wget/pkg-plist b/ftp/wget/pkg-plist
index ddd55692ec76..801e9c18bda5 100644
--- a/ftp/wget/pkg-plist
+++ b/ftp/wget/pkg-plist
@@ -1,6 +1,6 @@
bin/wget
-etc/wgetrc.sample
-man/man1/wget.1.gz
+%%DOCS%%etc/wgetrc.sample
+%%DOCS%%man/man1/wget.1.gz
%%NLS%%share/locale/be/LC_MESSAGES/wget.mo
%%NLS%%share/locale/bg/LC_MESSAGES/wget.mo
%%NLS%%share/locale/ca/LC_MESSAGES/wget.mo