aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-02 19:42:50 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-02 19:42:50 +0000
commit12a2874dac143d311d612075099093db2ccb6a9a (patch)
tree6cc807b5d396c4872e45f6b914270589d63c0ef7 /ftp
parent36fa737f3d8dec211182bde554ce98d9a55a12e6 (diff)
downloadports-12a2874dac143d311d612075099093db2ccb6a9a.tar.gz
ports-12a2874dac143d311d612075099093db2ccb6a9a.zip
ftp/cpr: Add cpr 1.6.2
C++ Requests is a simple wrapper around libcurl inspired by the excellent Python Requests project. Despite its name, libcurl's easy interface is anything but, and making mistakes misusing it is a common source of error and frustration. Using the more expressive language facilities of C++11, this library captures the essence of making network calls into a few concise idioms. WWW: https://whoshuu.github.io/cpr/ WWW: https://github.com/whoshuu/cpr
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/cpr/Makefile23
-rw-r--r--ftp/cpr/distinfo3
-rw-r--r--ftp/cpr/pkg-descr10
-rw-r--r--ftp/cpr/pkg-plist33
5 files changed, 70 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index c78424d688fd..1f22abcc54a3 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -8,6 +8,7 @@
SUBDIR += bftpd
SUBDIR += bsdftpd-ssl
SUBDIR += cmdftp
+ SUBDIR += cpr
SUBDIR += curl
SUBDIR += curlie
SUBDIR += curlpp
diff --git a/ftp/cpr/Makefile b/ftp/cpr/Makefile
new file mode 100644
index 000000000000..069034eabca0
--- /dev/null
+++ b/ftp/cpr/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= cpr
+PORTVERSION= 1.6.2
+CATEGORIES= ftp
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= C++ Requests: Curl for People
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+USES= cmake compiler:c++11-lang ssl
+
+CMAKE_OFF= CPR_BUILD_TESTS CPR_BUILD_TESTS_SSL CPR_CURL_NOSIGNAL CPR_FORCE_DARWINSSL_BACKEND CPR_FORCE_WINSSL_BACKEND CPR_GENERATE_COVERAGE CPR_USE_SYSTEM_GTEST
+CMAKE_ON= BUILD_SHARED_LIBS CPR_ENABLE_SSL CPR_FORCE_OPENSSL_BACKEND CPR_FORCE_USE_SYSTEM_CURL
+
+GH_ACCOUNT= whoshuu
+USE_GITHUB= yes
+
+.include <bsd.port.mk>
diff --git a/ftp/cpr/distinfo b/ftp/cpr/distinfo
new file mode 100644
index 000000000000..4002e0146775
--- /dev/null
+++ b/ftp/cpr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619910295
+SHA256 (whoshuu-cpr-1.6.2_GH0.tar.gz) = c45f9c55797380c6ba44060f0c73713fbd7989eeb1147aedb8723aa14f3afaa3
+SIZE (whoshuu-cpr-1.6.2_GH0.tar.gz) = 68856
diff --git a/ftp/cpr/pkg-descr b/ftp/cpr/pkg-descr
new file mode 100644
index 000000000000..7e729ce61793
--- /dev/null
+++ b/ftp/cpr/pkg-descr
@@ -0,0 +1,10 @@
+C++ Requests is a simple wrapper around libcurl inspired by the excellent Python
+Requests project.
+
+Despite its name, libcurl's easy interface is anything but, and making mistakes
+misusing it is a common source of error and frustration. Using the more
+expressive language facilities of C++11, this library captures the essence of
+making network calls into a few concise idioms.
+
+WWW: https://whoshuu.github.io/cpr/
+WWW: https://github.com/whoshuu/cpr
diff --git a/ftp/cpr/pkg-plist b/ftp/cpr/pkg-plist
new file mode 100644
index 000000000000..350587b31e97
--- /dev/null
+++ b/ftp/cpr/pkg-plist
@@ -0,0 +1,33 @@
+include/cpr/api.h
+include/cpr/auth.h
+include/cpr/bearer.h
+include/cpr/body.h
+include/cpr/callback.h
+include/cpr/connect_timeout.h
+include/cpr/cookies.h
+include/cpr/cpr.h
+include/cpr/cprtypes.h
+include/cpr/curl_container.h
+include/cpr/curlholder.h
+include/cpr/digest.h
+include/cpr/error.h
+include/cpr/limit_rate.h
+include/cpr/low_speed.h
+include/cpr/max_redirects.h
+include/cpr/multipart.h
+include/cpr/ntlm.h
+include/cpr/parameters.h
+include/cpr/payload.h
+include/cpr/proxies.h
+include/cpr/response.h
+include/cpr/session.h
+include/cpr/ssl_options.h
+include/cpr/status_codes.h
+include/cpr/timeout.h
+include/cpr/unix_socket.h
+include/cpr/user_agent.h
+include/cpr/util.h
+include/cpr/verbose.h
+lib/libcpr.so
+lib/libcpr.so.1
+lib/libcpr.so.1.6