aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-12-26 04:32:41 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-12-26 04:32:41 +0000
commit1df6d16216926eb7d9bdd759a6c25f314467d3db (patch)
tree0e84a6966206067631381d02b2346aaff2eed6d3 /ftp
parent6cb3df0ae33f77c23c9dcd800c63b9a2a55070f6 (diff)
downloadports-1df6d16216926eb7d9bdd759a6c25f314467d3db.tar.gz
ports-1df6d16216926eb7d9bdd759a6c25f314467d3db.zip
- rename files/moftpd.sh -> files/moftpd.in
- move load_config above variables checks - Bump PORTREVISION PR: ports/125651 Submitted by: pgollucci Approved by: araujo (mentor, implicit), maintainer timeout (clement 5 months)
Notes
Notes: svn path=/head/; revision=224788
Diffstat (limited to 'ftp')
-rw-r--r--ftp/moftpd/Makefile12
-rw-r--r--ftp/moftpd/files/moftpd.in (renamed from ftp/moftpd/files/moftpd.sh)5
-rw-r--r--ftp/moftpd/pkg-plist1
3 files changed, 5 insertions, 13 deletions
diff --git a/ftp/moftpd/Makefile b/ftp/moftpd/Makefile
index 64b426e9f648..d84004f6c797 100644
--- a/ftp/moftpd/Makefile
+++ b/ftp/moftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= moftpd
PORTVERSION= 1.2.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://ftp.morth.org/moftpd/ \
${MASTER_SITE_LOCAL}
@@ -18,14 +18,13 @@ COMMENT= A powerful FTP server supporting IPv6, TLS, and much more
USE_AUTOTOOLS= autoconf:262
USE_GMAKE= yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= moftpd
USE_PERL5_BUILD=yes
CONFIGURE_ENV+= LIBS="${LIBS}" CFLAGS="${CFLAGS}"
CONFIGURE_ARGS= --localstatedir=/var
MAN8= moftpd.8 moftpadmin.8
LIBS+= -lcrypt
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
.if defined(WITHOUT_TLS)
CONFIGURE_ARGS+= --without-tls
@@ -46,11 +45,4 @@ LIBS+= -L${LOCALBASE}/lib/mysql
CONFIGURE_ARGS+= --without-sql
.endif
-post-patch:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/moftpd.sh > ${WRKDIR}/moftpd.sh
-
-post-install:
- @${INSTALL_SCRIPT} ${WRKDIR}/moftpd.sh ${PREFIX}/etc/rc.d/
-
.include <bsd.port.mk>
diff --git a/ftp/moftpd/files/moftpd.sh b/ftp/moftpd/files/moftpd.in
index a1c407313bf6..6379b96c1879 100644
--- a/ftp/moftpd/files/moftpd.sh
+++ b/ftp/moftpd/files/moftpd.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/ftp/moftpd/files/Attic/moftpd.in,v 1.1 2008-12-26 04:32:41 pgollucci Exp $
#
# PROVIDE: moftpd
@@ -28,12 +28,13 @@ command="%%PREFIX%%/sbin/moftpd"
pidfile="/var/run/moftpd.pid"
required_files=%%PREFIX%%/etc/moftpd.conf
+load_rc_config $name
+
[ -z "$moftpd_enable" ] && moftpd_enable="NO"
[ -z "$moftpd_flags" ] && moftpd_flags=""
[ -z "$moftpdlimits_enable" ] && moftpdlimits_enable="NO"
[ -z "$moftpdlimits_args" ] && moftpdlimits_args="-e -C daemon"
-load_rc_config $name
checkyesno moftpdlimits_enable && \
start_precmd="eval `/usr/bin/limits ${moftpdlimits_args}` 2>/dev/null"
diff --git a/ftp/moftpd/pkg-plist b/ftp/moftpd/pkg-plist
index 942da2ac1cad..706f329afc1f 100644
--- a/ftp/moftpd/pkg-plist
+++ b/ftp/moftpd/pkg-plist
@@ -1,4 +1,3 @@
-etc/rc.d/moftpd.sh
etc/moftpd.conf.dist
sbin/moftpadmin
sbin/moftpd