aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-19 11:17:41 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-19 11:17:41 +0000
commit224cdff72db71610c2df41e176b782cbe2620e57 (patch)
tree534fde1db51159ba2f5527b99a6890e17041d040 /ftp
parentabcec5c9ed84df7012f2751e1f7cb3325ad5e4e8 (diff)
downloadports-224cdff72db71610c2df41e176b782cbe2620e57.tar.gz
ports-224cdff72db71610c2df41e176b782cbe2620e57.zip
- unbreak on 5.x
- respect PTHREAD_LIBS and CFLAGS - use REINPLACE_CMD instead of PERL - remove obsolete replacement PR: 58226 Submitted by: Markus Brueffer <brueffer@phoenix-systems.de> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=94340
Diffstat (limited to 'ftp')
-rw-r--r--ftp/kwebget/Makefile14
-rw-r--r--ftp/kwebget/files/patch-kwebget.cpp11
-rw-r--r--ftp/kwebget/pkg-plist8
3 files changed, 24 insertions, 9 deletions
diff --git a/ftp/kwebget/Makefile b/ftp/kwebget/Makefile
index 495911466fa4..44819a42ebcd 100644
--- a/ftp/kwebget/Makefile
+++ b/ftp/kwebget/Makefile
@@ -21,16 +21,12 @@ USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-CONFIGURE_TARGET= # empty
-CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
post-patch:
- @${PERL} -pi -e 's#lqt#lqt2#g' ${WRKSRC}/configure ${WRKSRC}/kwebget/Makefile.in
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/kwebget/files/patch-kwebget.cpp b/ftp/kwebget/files/patch-kwebget.cpp
new file mode 100644
index 000000000000..d4c741407375
--- /dev/null
+++ b/ftp/kwebget/files/patch-kwebget.cpp
@@ -0,0 +1,11 @@
+--- kwebget/kwebget.cpp.orig Sat Oct 18 18:26:29 2003
++++ kwebget/kwebget.cpp Sat Oct 18 18:26:50 2003
+@@ -15,6 +15,8 @@
+ * *
+ ***************************************************************************/
+
++#include <stdlib.h>
++
+ #include "kwebget.h"
+
+ #include "../pics/bg.xpm"
diff --git a/ftp/kwebget/pkg-plist b/ftp/kwebget/pkg-plist
index 8329da6ea742..e0e17dc438a3 100644
--- a/ftp/kwebget/pkg-plist
+++ b/ftp/kwebget/pkg-plist
@@ -5,4 +5,12 @@ share/doc/HTML/en/kwebget/common
share/applnk/Applications/kwebget.desktop
share/icons/locolor/32x32/apps/kwebget.png
share/icons/locolor/16x16/apps/kwebget.png
+@unexec rmdir %D/share/applnk/Applications 2>/dev/null || true
+@unexec rmdir %D/share/applnk 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
@dirrm share/doc/HTML/en/kwebget
+@unexec rmdir %D/share/doc/HTML/en 2>/dev/null || true