aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-14 22:00:28 +0000
committerRene Ladan <rene@FreeBSD.org>2023-06-27 19:34:34 +0000
commit3d9a815d9c5acbb71f4bb07738bdeab4879feacb (patch)
treeeb093f22197a2c68a88dd2372ec1922c3f6d3c10 /ftp
parentc58ef91e06e8edc4fd8579837f1453b562da3fbb (diff)
downloadports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.tar.gz
ports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.zip
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by itself. Adjust two ports that only had Python 3.7 mentioned but build fine on Python 3.8 too. finance/quickfix: mark BROKEN with PYTHON libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++ -DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable -Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi -Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings -Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x -MT _quickfix_la-QuickfixPython.lo -MD -MP -MF .deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o .libs/_quickfix_la-QuickfixPython.o warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean '-Wno-uninitialized'? [-Wunknown-warning-option] QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found ^~~~~~~~~~ 1 warning and 1 error generated. Reviewed by: portmgr, vishwin, yuri Differential Revision: <https://reviews.freebsd.org/D40568>
Diffstat (limited to 'ftp')
-rw-r--r--ftp/py-aioftp/Makefile2
-rw-r--r--ftp/py-parfive/Makefile2
-rw-r--r--ftp/py-pycurl/Makefile2
-rw-r--r--ftp/py-pyftpdlib/Makefile2
-rw-r--r--ftp/py-requests-ftp/Makefile2
-rw-r--r--ftp/py-sftp/Makefile2
-rw-r--r--ftp/py-tftpy/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/ftp/py-aioftp/Makefile b/ftp/py-aioftp/Makefile
index 176b28cc0817..0a384489f787 100644
--- a/ftp/py-aioftp/Makefile
+++ b/ftp/py-aioftp/Makefile
@@ -18,7 +18,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@$
${PYTHON_PKGNAMEPREFIX}siosocks>0:net/py-siosocks@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}idna>0:dns/py-idna@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist distutils pytest
NO_ARCH= yes
diff --git a/ftp/py-parfive/Makefile b/ftp/py-parfive/Makefile
index 99a355c47956..946f644a975a 100644
--- a/ftp/py-parfive/Makefile
+++ b/ftp/py-parfive/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}aiohttp>0:www/py-aiohttp@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist pep517
.include <bsd.port.mk>
diff --git a/ftp/py-pycurl/Makefile b/ftp/py-pycurl/Makefile
index 1af76ec5fb77..5890143dd71c 100644
--- a/ftp/py-pycurl/Makefile
+++ b/ftp/py-pycurl/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE_MIT= ${WRKSRC}/COPYING-MIT
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= python:3.6+ ssl
+USES= python ssl
USE_PYTHON= autoplist concurrent distutils
PORTDOCS= AUTHORS INSTALL.rst README.rst RELEASE-NOTES.rst
diff --git a/ftp/py-pyftpdlib/Makefile b/ftp/py-pyftpdlib/Makefile
index a5a66e2a9658..45ee601bc68b 100644
--- a/ftp/py-pyftpdlib/Makefile
+++ b/ftp/py-pyftpdlib/Makefile
@@ -10,7 +10,7 @@ WWW= https://github.com/giampaolo/pyftpdlib
LICENSE= MIT
-USES= python:3.6+ shebangfix
+USES= python shebangfix
USE_PYTHON= autoplist distutils
SHEBANG_FILES= demo/*.py
NO_ARCH= yes
diff --git a/ftp/py-requests-ftp/Makefile b/ftp/py-requests-ftp/Makefile
index c93d6a24e2c8..0f6468f19897 100644
--- a/ftp/py-requests-ftp/Makefile
+++ b/ftp/py-requests-ftp/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/Lukasa/requests-ftp
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.6+
+USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/ftp/py-sftp/Makefile b/ftp/py-sftp/Makefile
index 87ea674cfad1..901a93731f8d 100644
--- a/ftp/py-sftp/Makefile
+++ b/ftp/py-sftp/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.17:security/py-paramiko@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/ftp/py-tftpy/Makefile b/ftp/py-tftpy/Makefile
index 94828a734b2f..ecc464daa34f 100644
--- a/ftp/py-tftpy/Makefile
+++ b/ftp/py-tftpy/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/msoulier/tftpy
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes