aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-17 17:24:57 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-17 17:24:57 +0000
commit6855a055701dbac817073e10425e0e0f93f7aac6 (patch)
tree13ad981a35213ccdd24f8950b351bcf8ce13cc7f /ftp
parent11794cecd10b2a647835443462c92a462ae6f9aa (diff)
downloadports-6855a055701dbac817073e10425e0e0f93f7aac6.tar.gz
ports-6855a055701dbac817073e10425e0e0f93f7aac6.zip
- Update to 7.43.0
- Update HTTP2 option - Update DOCS Changes: http://curl.haxx.se/changes.html
Notes
Notes: svn path=/head/; revision=389953
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile18
-rw-r--r--ftp/curl/distinfo4
-rw-r--r--ftp/curl/pkg-plist3
3 files changed, 13 insertions, 12 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 2479220315bd..eee4fb9589fa 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 7.42.1
-PORTREVISION= 1
+PORTVERSION= 7.43.0
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -52,12 +51,11 @@ PORTEXAMPLES= *
CPE_VENDOR= haxx
DOCS= BINDINGS BUGS CONTRIBUTE DISTRO-DILEMMA FAQ FEATURES HISTORY \
- HTTP-COOKIES INSTALL INSTALL.devcpp INTERNALS KNOWN_BUGS \
- LIBCURL-STRUCTS LICENSE-MIXING MAIL-ETIQUETTE MANUAL \
- README.netware README.win32 RELEASE-PROCEDURE RESOURCES \
- SECURITY SSL-PROBLEMS SSLCERTS THANKS TODO \
- TheArtOfHttpScripting VERSIONS curl-config.html \
- curl-config.pdf curl.html curl.pdf index.html \
+ HTTP-COOKIES HTTP2.md INSTALL INSTALL.devcpp INTERNALS \
+ KNOWN_BUGS LICENSE-MIXING MAIL-ETIQUETTE MANUAL \
+ RELEASE-PROCEDURE RESOURCES ROADMAP.md SECURITY SSL-PROBLEMS \
+ SSLCERTS THANKS TODO TheArtOfHttpScripting VERSIONS \
+ curl-config.html curl-config.pdf curl.html curl.pdf index.html \
mk-ca-bundle.html mk-ca-bundle.pdf
.endif
@@ -94,11 +92,11 @@ GSSAPI_MIT_LDFLAGS= ${GSSAPILDFLAGS}
GSSAPI_MIT_LIBS= ${GSSAPILIBS}
GSSAPI_MIT_USES= gssapi:mit
GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
-HTTP2_BUILD_DEPENDS= nghttp2>=0.6.0:${PORTSDIR}/www/nghttp2
+HTTP2_BUILD_DEPENDS= nghttp2>=1.0.0:${PORTSDIR}/www/nghttp2
HTTP2_CONFIGURE_OFF= --without-nghttp2
HTTP2_CONFIGURE_ON= --with-nghttp2=${LOCALBASE}
HTTP2_LIB_DEPENDS= libnghttp2.so:${PORTSDIR}/www/nghttp2
-HTTP2_RUN_DEPENDS= nghttp2>=0.6.0:${PORTSDIR}/www/nghttp2
+HTTP2_RUN_DEPENDS= nghttp2>=1.0.0:${PORTSDIR}/www/nghttp2
HTTP2_USES= pkgconfig
IDN_CONFIGURE_OFF= --without-libidn
IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE}
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index 31b977f25cb9..ef8692482514 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (curl-7.42.1.tar.lzma) = 3d6c196ab5083ab2ea3691819602e7b9698404ce8480d4008e3ba64822cc2c47
-SIZE (curl-7.42.1.tar.lzma) = 2732330
+SHA256 (curl-7.43.0.tar.lzma) = e2b8d84d9c7d85f81cc8477ea3ec757e4c9908eca116be8764b7d158aa7677fa
+SIZE (curl-7.43.0.tar.lzma) = 2765536
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index 9166ab7bf5fb..d658f851a084 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -143,6 +143,7 @@ man/man3/CURLOPT_OPENSOCKETFUNCTION.3.gz
man/man3/CURLOPT_PASSWORD.3.gz
man/man3/CURLOPT_PATH_AS_IS.3.gz
man/man3/CURLOPT_PINNEDPUBLICKEY.3.gz
+man/man3/CURLOPT_PIPEWAIT.3.gz
man/man3/CURLOPT_PORT.3.gz
man/man3/CURLOPT_POST.3.gz
man/man3/CURLOPT_POSTFIELDS.3.gz
@@ -163,6 +164,7 @@ man/man3/CURLOPT_PROXYPORT.3.gz
man/man3/CURLOPT_PROXYTYPE.3.gz
man/man3/CURLOPT_PROXYUSERNAME.3.gz
man/man3/CURLOPT_PROXYUSERPWD.3.gz
+man/man3/CURLOPT_PROXY_SERVICE_NAME.3.gz
man/man3/CURLOPT_PROXY_TRANSFER_MODE.3.gz
man/man3/CURLOPT_PUT.3.gz
man/man3/CURLOPT_QUOTE.3.gz
@@ -184,6 +186,7 @@ man/man3/CURLOPT_RTSP_TRANSPORT.3.gz
man/man3/CURLOPT_SASL_IR.3.gz
man/man3/CURLOPT_SEEKDATA.3.gz
man/man3/CURLOPT_SEEKFUNCTION.3.gz
+man/man3/CURLOPT_SERVICE_NAME.3.gz
man/man3/CURLOPT_SHARE.3.gz
man/man3/CURLOPT_SOCKOPTDATA.3.gz
man/man3/CURLOPT_SOCKOPTFUNCTION.3.gz