aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-02-05 21:20:24 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-02-05 21:20:24 +0000
commit6d324c1f70c9ee4ebd41f6a689ac379f8d47927b (patch)
tree7c63a95968ed9b4eb610fca1b72ff17c7d9581c2 /ftp
parent2da0cd8de2b6a439333303b69967925ed04914ad (diff)
downloadports-6d324c1f70c9ee4ebd41f6a689ac379f8d47927b.tar.gz
ports-6d324c1f70c9ee4ebd41f6a689ac379f8d47927b.zip
- Remove inclusion of bsd.default-versions.mk from ftp/curl/Makefile so
bsd.default-versions.mk can rely on ARCH being defined. - In bsd.port.mk move inclusion of bsd.default-versions.mk from the pre-makefile section to the options section so the variables can be used earlier. Also put the bit of code sitting between the options section and the pre-makefile section into the options section. - Remove last few cases where ports set WITH_OPENSSL_PORT. This variable is handled in bsd.default-versions.mk and some ports were setting it after including bsd.port.options.mk. After FreeBSD 9 EoL all but a few ports, and then only when setting non-default options, work without setting that variable. PR: 215996 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=433456
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 6bdeec6c8bc0..86948c45f849 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -21,6 +21,7 @@ OPTIONS_RADIO_RESOLV= CARES THREADED_RESOLVER
OPTIONS_RADIO_SSL= GNUTLS NSS OPENSSL POLARSSL WOLFSSL
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
OPTIONS_DEFAULT= CA_BUNDLE COOKIES HTTP2 OPENSSL PROXY RESOLV THREADED_RESOLVER TLS_SRP
+OPTIONS_DEFAULT+= GSSAPI_${"${SSL_DEFAULT}" == "base":?BASE:NONE}
CA_BUNDLE_DESC= Install CA bundle for OpenSSL
CA_BUNDLE_IMPLIES= OPENSSL
COOKIES_DESC= Cookies support
@@ -33,14 +34,6 @@ SMB_DESC= SMB/CIFS support
THREADED_RESOLVER_DESC= Threaded DNS resolver
TLS_SRP_DESC= TLS-SRP (Secure Remote Password) support
-.include <${.CURDIR}/../../Mk/bsd.default-versions.mk>
-
-.if ${SSL_DEFAULT} != base
-OPTIONS_DEFAULT+= GSSAPI_NONE
-.else
-OPTIONS_DEFAULT+= GSSAPI_BASE
-.endif
-
CONFIGURE_ARGS= --disable-werror \
--enable-imap --enable-pop3 --enable-rtsp --enable-smtp \
--with-zsh-functions-dir=${LOCALBASE}/share/zsh/site-functions \