aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2017-11-25 07:51:20 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2017-11-25 07:51:20 +0000
commit9531bac2e74c05b233faa7c19aa7acea2bba5540 (patch)
treed8b7404c70981d5c5bb26aa1097d58910ed87b33 /ftp
parentd88397e7e8e397c229abcf607c345ab93de535f3 (diff)
downloadports-9531bac2e74c05b233faa7c19aa7acea2bba5540.tar.gz
ports-9531bac2e74c05b233faa7c19aa7acea2bba5540.zip
php*-fastdfs: remove hard-code patching
PR: 223714 Submitted by: Daniel Ylitalo <daniel@blodan.se> (maintainer) Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13137
Notes
Notes: svn path=/head/; revision=454873
Diffstat (limited to 'ftp')
-rw-r--r--ftp/php56-fastdfs/Makefile5
-rw-r--r--ftp/php56-fastdfs/files/patch-config.m411
-rw-r--r--ftp/php70-fastdfs/Makefile2
-rw-r--r--ftp/php70-fastdfs/files/patch-config.m411
-rw-r--r--ftp/php71-fastdfs/Makefile2
-rw-r--r--ftp/php71-fastdfs/files/patch-config.m411
6 files changed, 5 insertions, 37 deletions
diff --git a/ftp/php56-fastdfs/Makefile b/ftp/php56-fastdfs/Makefile
index feb236fed934..5db9a234e737 100644
--- a/ftp/php56-fastdfs/Makefile
+++ b/ftp/php56-fastdfs/Makefile
@@ -1,8 +1,9 @@
# $FreeBSD$
-PORTNAME= php56-fastdfs
+PORTNAME= fastdfs
PORTVERSION= 5.0.11
CATEGORIES= ftp
+PKGNAMEPREFIX= php56-
MAINTAINER= daniel@blodan.se
COMMENT= PHP 5.6 module for accessing a FastDFS cluster
@@ -18,10 +19,10 @@ GH_PROJECT= fastdfs
GH_TAGNAME= 1e50b4f
USES= php:ext
-IGNORE_WITH_PHP= 70 71
PHP_VER= 56
WRKSRC_SUBDIR= php_client
+CONFIGURE_ENV= ROOT=${LOCALBASE}
PHP_MODNAME= fastdfs_client
diff --git a/ftp/php56-fastdfs/files/patch-config.m4 b/ftp/php56-fastdfs/files/patch-config.m4
deleted file mode 100644
index 2017cab49190..000000000000
--- a/ftp/php56-fastdfs/files/patch-config.m4
+++ /dev/null
@@ -1,11 +0,0 @@
---- config.m4.orig 2016-08-08 07:17:50 UTC
-+++ config.m4
-@@ -7,7 +7,7 @@ if test "$PHP_FASTDFS_CLIENT" != "no"; t
- PHP_SUBST(FASTDFS_CLIENT_SHARED_LIBADD)
-
- if test -z "$ROOT"; then
-- ROOT=/usr
-+ ROOT=/usr/local
- fi
-
- PHP_ADD_INCLUDE($ROOT/include/fastcommon)
diff --git a/ftp/php70-fastdfs/Makefile b/ftp/php70-fastdfs/Makefile
index 5fbf44901f67..79fb2681bd07 100644
--- a/ftp/php70-fastdfs/Makefile
+++ b/ftp/php70-fastdfs/Makefile
@@ -19,10 +19,10 @@ GH_PROJECT= fastdfs
GH_TAGNAME= 1e50b4f
USES= php:ext
-IGNORE_WITH_PHP= 56 71
PHP_VER= 70
WRKSRC_SUBDIR= php_client
+CONFIGURE_ENV= ROOT=${LOCALBASE}
PHP_MODNAME= fastdfs_client
diff --git a/ftp/php70-fastdfs/files/patch-config.m4 b/ftp/php70-fastdfs/files/patch-config.m4
deleted file mode 100644
index 2017cab49190..000000000000
--- a/ftp/php70-fastdfs/files/patch-config.m4
+++ /dev/null
@@ -1,11 +0,0 @@
---- config.m4.orig 2016-08-08 07:17:50 UTC
-+++ config.m4
-@@ -7,7 +7,7 @@ if test "$PHP_FASTDFS_CLIENT" != "no"; t
- PHP_SUBST(FASTDFS_CLIENT_SHARED_LIBADD)
-
- if test -z "$ROOT"; then
-- ROOT=/usr
-+ ROOT=/usr/local
- fi
-
- PHP_ADD_INCLUDE($ROOT/include/fastcommon)
diff --git a/ftp/php71-fastdfs/Makefile b/ftp/php71-fastdfs/Makefile
index a4d895e0d020..feee1ee711a2 100644
--- a/ftp/php71-fastdfs/Makefile
+++ b/ftp/php71-fastdfs/Makefile
@@ -19,10 +19,10 @@ GH_PROJECT= fastdfs
GH_TAGNAME= 1e50b4f
USES= php:ext
-IGNORE_WITH_PHP= 56 70
PHP_VER= 71
WRKSRC_SUBDIR= php_client
+CONFIGURE_ENV= ROOT=${LOCALBASE}
PHP_MODNAME= fastdfs_client
diff --git a/ftp/php71-fastdfs/files/patch-config.m4 b/ftp/php71-fastdfs/files/patch-config.m4
deleted file mode 100644
index 2017cab49190..000000000000
--- a/ftp/php71-fastdfs/files/patch-config.m4
+++ /dev/null
@@ -1,11 +0,0 @@
---- config.m4.orig 2016-08-08 07:17:50 UTC
-+++ config.m4
-@@ -7,7 +7,7 @@ if test "$PHP_FASTDFS_CLIENT" != "no"; t
- PHP_SUBST(FASTDFS_CLIENT_SHARED_LIBADD)
-
- if test -z "$ROOT"; then
-- ROOT=/usr
-+ ROOT=/usr/local
- fi
-
- PHP_ADD_INCLUDE($ROOT/include/fastcommon)