aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-09 10:13:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-09 10:13:03 +0000
commita2f541608598b45cedb1c6ba1ab3fddd98350542 (patch)
treea77aeaa979e7304fbe14f3f278f321a7200912a1 /ftp
parent5ffda9ba9f5154c1502e30483a7b0fde831f0e28 (diff)
downloadports-a2f541608598b45cedb1c6ba1ab3fddd98350542.tar.gz
ports-a2f541608598b45cedb1c6ba1ab3fddd98350542.zip
- Cleanup Makefile
- Remove BUILDING_HIPHOP check: curl-hiphop was removed in r425765 - Use = instead of += for MAINTAINER, COMMENT, CONFIGURE_ARGS and CONFIGURE_ENV - Remove SLAVEDIRS - Adjust line wrapping of DOCS
Notes
Notes: svn path=/head/; revision=428175
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index e4ea84ab3e44..82f31129337a 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
-MAINTAINER?= sunpoet@FreeBSD.org
-COMMENT?= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -41,22 +41,19 @@ OPTIONS_DEFAULT+= GSSAPI_NONE
OPTIONS_DEFAULT+= GSSAPI_BASE
.endif
-CONFIGURE_ARGS+=--disable-werror \
+CONFIGURE_ARGS= --disable-werror \
--enable-imap --enable-pop3 --enable-rtsp --enable-smtp \
--with-zsh-functions-dir=${LOCALBASE}/share/zsh/site-functions \
--without-axtls
-CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
+CONFIGURE_ENV= LOCALBASE=${LOCALBASE} \
ac_cv_func_SSLv2_client_method=no
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
TEST_ENV= ${MAKE_ENV} LC_ALL=C
TEST_TARGET= test
-USE_PERL5= build
-USES= gmake libtool localbase pathfix perl5 shebangfix tar:lzma
-
-.if !defined(BUILDING_HIPHOP)
USE_LDCONFIG= yes
-USES+= cpe
+USE_PERL5= build
+USES= cpe gmake libtool localbase pathfix perl5 shebangfix tar:lzma
PORTDOCS= *
PORTEXAMPLES= *
@@ -65,16 +62,13 @@ CPE_VENDOR= haxx
DOCS= BUGS CODE_OF_CONDUCT.md CODE_STYLE.md CONTRIBUTE.md FAQ \
FEATURES HISTORY.md HTTP-COOKIES.md HTTP2.md INSTALL \
- INTERNALS.md KNOWN_BUGS LICENSE-MIXING.md \
- MAIL-ETIQUETTE MANUAL RELEASE-PROCEDURE RESOURCES ROADMAP.md \
- SECURITY.md SSL-PROBLEMS.md SSLCERTS.md THANKS TODO \
- TheArtOfHttpScripting VERSIONS
-.endif
+ INTERNALS.md KNOWN_BUGS LICENSE-MIXING.md MAIL-ETIQUETTE \
+ MANUAL RELEASE-PROCEDURE RESOURCES ROADMAP.md SECURITY.md \
+ SSL-PROBLEMS.md SSLCERTS.md THANKS TODO TheArtOfHttpScripting \
+ VERSIONS
SHEBANG_FILES= */*.pl
-SLAVEDIRS= ftp/curl-hiphop
-
CA_BUNDLE_CONFIGURE_OFF=--without-ca-bundle
CA_BUNDLE_CONFIGURE_ON= --with-ca-bundle=${LOCALBASE}/share/certs/ca-root-nss.crt
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
@@ -161,7 +155,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|include <gssapi.h>|include <gssapi/gssapi.h>|' ${WRKSRC}/lib/curl_gssapi.h ${WRKSRC}/lib/urldata.h
-.if !defined(BUILDING_HIPHOP)
post-install:
${INSTALL_DATA} ${WRKSRC}/docs/libcurl/libcurl.m4 ${STAGEDIR}${PREFIX}/share/aclocal/
@@ -173,7 +166,6 @@ post-install-DOCS-on:
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
cd ${WRKSRC}/docs/examples/ && ${INSTALL_DATA} README Makefile.example makefile* *.c *.cpp ${STAGEDIR}${EXAMPLESDIR}/
-.endif
pre-test-PROXY-off:
@${ECHO_MSG} "******************************************"