aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2017-04-06 08:56:22 +0000
committerVasil Dimov <vd@FreeBSD.org>2017-04-06 08:56:22 +0000
commita3434e296896a76a161fa739e8701a21b6bf8dca (patch)
tree8889e5d7690ba7b4b9f8ae63c3175b17bfa3e40f /ftp
parentf49f75c82a42525ac9f4e8c3294fc2ec4fccf50a (diff)
downloadports-a3434e296896a76a161fa739e8701a21b6bf8dca.tar.gz
ports-a3434e296896a76a161fa739e8701a21b6bf8dca.zip
Upgrade ftp/wget from 1.19 to 1.19.1
Changelog: http://git.savannah.gnu.org/cgit/wget.git/plain/NEWS - add test target and TEST_DEPENDS - remove gmake from USES: current version of wget can be build without gmake - unbreak IDN option: since 1.19 wget uses libidn2 instead of libidn - libidn2 uses libunistring from ports, so when the IDN option is enabled use libunistring from the ports instead of the bundled one - disabling pcre support using ./configure --disable-pcre currently works, use it - remove Makefile and configure patches which are no longer needed - patch /usr/local to $PREFIX in wget.info too - delete files/patch-src__main.c - this bug has been fixed on Mar 2, 2015 [1] [1] http://git.savannah.gnu.org/cgit/wget.git/commit/?id=9dde436dd689bd51eef71d64152dde9c8c0b5f65 PR: 218408 Submitted by: Anton Yuzhaninov <citrin+pr@citrin.ru>
Notes
Notes: svn path=/head/; revision=437857
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wget/Makefile32
-rw-r--r--ftp/wget/distinfo6
-rw-r--r--ftp/wget/files/patch-src__main.c12
3 files changed, 19 insertions, 31 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index dbf085dfca85..1a95d3a05138 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wget
-DISTVERSION= 1.19
+DISTVERSION= 1.19.1
CATEGORIES= ftp www ipv6
MASTER_SITES= GNU
@@ -12,7 +12,10 @@ COMMENT= Retrieve files from the Net via HTTP(S) and FTP
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= charsetfix cpe gmake iconv makeinfo perl5 tar:xz
+TEST_DEPENDS= p5-HTTP-Daemon>=0:www/p5-HTTP-Daemon \
+ p5-IO-Socket-SSL>=0:security/p5-IO-Socket-SSL
+
+USES= charsetfix cpe iconv makeinfo perl5 tar:xz
USE_PERL5= build
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
@@ -32,10 +35,13 @@ NLS_CONFIGURE_ENABLE= nls
NLS_CPPFLAGS= -I${LOCALBASE}/include
NLS_LDFLAGS= -L${LOCALBASE}/lib
-IDN_USES= iconv
-IDN_LIB_DEPENDS= libidn.so:dns/libidn
+IDN_LIB_DEPENDS= libidn2.so:dns/libidn2 \
+ libunistring.so:devel/libunistring
+IDN_CPPFLAGS= -I${LOCALBASE}/include
+IDN_LDFLAGS= -L${LOCALBASE}/lib
IDN_CONFIGURE_ENABLE= iri
-IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE}
+IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE} --with-libunistring-prefix=${LOCALBASE}
+IDN_CONFIGURE_OFF= --with-included-libunistring
METALINK_CONFIGURE_WITH=metalink
METALINK_LIB_DEPENDS= libmetalink.so:misc/libmetalink
@@ -43,15 +49,13 @@ METALINK_LIB_DEPENDS= libmetalink.so:misc/libmetalink
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
PCRE_CPPFLAGS= -I${LOCALBASE}/include
PCRE_LDFLAGS= -L${LOCALBASE}/lib
-PCRE_CONFIGURE_ENV_OFF= ac_cv_header_pcre_h=no
+PCRE_CONFIGURE_ENABLE= pcre
PSL_CONFIGURE_WITH= libpsl
PSL_LIB_DEPENDS= libpsl.so:dns/libpsl
.include <bsd.port.options.mk>
-CONFIGURE_ARGS+=--with-included-libunistring
-
.if ${PORT_OPTIONS:MOPENSSL}
USES+= ssl
CONFIGURE_ARGS+=--with-ssl=openssl --with-libssl-prefix=${OPENSSLBASE}
@@ -69,17 +73,13 @@ CONFIGURE_ARGS+=--without-ssl
INFO= wget
-# eliminate gmakism
+TEST_TARGET= check
+
post-patch:
- ${REINPLACE_CMD} -e 's,$$<,$$(srcdir)/wget.texi,' \
- -e 's,WGETRC = $$(sysconfdir)/wgetrc,&.sample,' \
+ ${REINPLACE_CMD} -e 's,WGETRC = $$(sysconfdir)/wgetrc,&.sample,' \
${WRKSRC}/doc/Makefile.in
${REINPLACE_CMD} -e 's,/usr/local/etc/wgetrc,${PREFIX}/etc/wgetrc,' \
- -e 's,@file{},@file{${PREFIX}},' \
- ${WRKSRC}/doc/sample.wgetrc* ${WRKSRC}/doc/wget.texi
- ${REINPLACE_CMD} -e '/ac_fn_c_check_header_mongrel.*uuid\/uuid.h/ d' \
- -e 's|-R$$found_dir|-Wl,-rpath=$$found_dir|g' \
- ${WRKSRC}/configure
+ ${WRKSRC}/doc/sample.wgetrc* ${WRKSRC}/doc/wget.texi ${WRKSRC}/doc/wget.info
.include <bsd.port.pre.mk>
diff --git a/ftp/wget/distinfo b/ftp/wget/distinfo
index 159120c6e953..05dc2d2026c5 100644
--- a/ftp/wget/distinfo
+++ b/ftp/wget/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1486213522
-SHA256 (wget-1.19.tar.xz) = 0f1157bbf4daae19f3e1ddb70c6ccb2067feb834a6aa23c9d9daa7f048606384
-SIZE (wget-1.19.tar.xz) = 2075916
+TIMESTAMP = 1491337367
+SHA256 (wget-1.19.1.tar.xz) = 0c950b9671881222a4d385b013c9604e98a8025d1988529dfca0e93617744cd2
+SIZE (wget-1.19.1.tar.xz) = 2111756
diff --git a/ftp/wget/files/patch-src__main.c b/ftp/wget/files/patch-src__main.c
deleted file mode 100644
index b2ba45411b09..000000000000
--- a/ftp/wget/files/patch-src__main.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/main.c.orig 2015-02-10 23:31:49.000000000 +0200
-+++ src/main.c 2015-03-06 21:55:03.975252490 +0200
-@@ -1272,6 +1272,9 @@
- if (opt.verbose == -1)
- opt.verbose = !opt.quiet;
-
-+ if (opt.quiet && opt.show_progress == -1)
-+ opt.show_progress = false;
-+
- /* Sanity checks. */
- if (opt.verbose && opt.quiet)
- {