aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-16 22:56:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-16 23:37:08 +0000
commita7b357c4f40e171e554250038768a751335d01c3 (patch)
treea130beda765639da8bd2203f4d915414b50bf105 /ftp
parentfc96e77b56c65223193406b3dedb0d0642f123c8 (diff)
downloadports-a7b357c4f40e171e554250038768a751335d01c3.tar.gz
ports-a7b357c4f40e171e554250038768a751335d01c3.zip
ftp/pget: New port: Fast, resumable file download client
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/pget/Makefile20
-rw-r--r--ftp/pget/distinfo5
-rw-r--r--ftp/pget/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index d4a64f8e0d8f..4bb9169126e2 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -51,6 +51,7 @@
SUBDIR += pavuk
SUBDIR += pear-Net_FTP
SUBDIR += pftpd
+ SUBDIR += pget
SUBDIR += php80-curl
SUBDIR += php80-ftp
SUBDIR += php81-curl
diff --git a/ftp/pget/Makefile b/ftp/pget/Makefile
new file mode 100644
index 000000000000..d0d984ab8bbb
--- /dev/null
+++ b/ftp/pget/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= pget
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.1
+CATEGORIES= ftp net www
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast, resumable file download client
+WWW= https://github.com/Code-Hex/pget
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/Code-Hex/pget
+GO_TARGET= ./cmd/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/ftp/pget/distinfo b/ftp/pget/distinfo
new file mode 100644
index 000000000000..97e15b0a3589
--- /dev/null
+++ b/ftp/pget/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1689545779
+SHA256 (go/ftp_pget/pget-v0.1.1/v0.1.1.mod) = 6294a649aaaf7ba2c9195ada0589457fa3e435d6143b99eabb8003124dac6e36
+SIZE (go/ftp_pget/pget-v0.1.1/v0.1.1.mod) = 1102
+SHA256 (go/ftp_pget/pget-v0.1.1/v0.1.1.zip) = 8a67eacaa7467d10e8744e2174c3eee2acb8df51b381a254d53c4f3dd6b07602
+SIZE (go/ftp_pget/pget-v0.1.1/v0.1.1.zip) = 782871
diff --git a/ftp/pget/pkg-descr b/ftp/pget/pkg-descr
new file mode 100644
index 000000000000..e11c6eb2a887
--- /dev/null
+++ b/ftp/pget/pkg-descr
@@ -0,0 +1,6 @@
+pget performs multi-connection download using parallel requests.
+
+Features:
+* Fast
+* Resumable
+* Cross-compiled (windows, linux, macOS)