aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorJesse Smith <jsmith@resonatingmedia.com>2021-09-10 05:39:54 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-09-10 13:21:52 +0000
commitc3c3d04764ff6d1999b34cb807383999babf7bda (patch)
tree97bfcd85c5b731b280ead101d494c4d1892186b2 /ftp
parent94d69d0eb64a0938309b6377491f3eecd958811d (diff)
downloadports-c3c3d04764ff6d1999b34cb807383999babf7bda.tar.gz
ports-c3c3d04764ff6d1999b34cb807383999babf7bda.zip
ftp/bftpd: Remove unnecessary patchfile
While here, pet portlint and remove unneeded post-patch. PR: 258395
Diffstat (limited to 'ftp')
-rw-r--r--ftp/bftpd/Makefile5
-rw-r--r--ftp/bftpd/files/patch-commands.c27
2 files changed, 2 insertions, 30 deletions
diff --git a/ftp/bftpd/Makefile b/ftp/bftpd/Makefile
index 28e190bda7dc..84c841887d55 100644
--- a/ftp/bftpd/Makefile
+++ b/ftp/bftpd/Makefile
@@ -10,13 +10,13 @@ COMMENT= Very configurable FTP server that can do chroot easily
LICENSE= GPLv2
+USES= autoreconf gmake
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-pam
# Fix build with clang 11
CFLAGS+= -fcommon
-USES= autoreconf gmake
-
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= sbin/${PORTNAME} etc/${PORTNAME}.conf.sample \
@@ -29,7 +29,6 @@ post-patch:
@${REINPLACE_CMD} -e 's,/etc/bftpd.conf,${PREFIX}/etc/bftpd.conf,' \
${WRKSRC}/mypaths.h
@${REINPLACE_CMD} -e 's, -ldl,,g' ${WRKSRC}/configure.in
- @${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -r
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin/
diff --git a/ftp/bftpd/files/patch-commands.c b/ftp/bftpd/files/patch-commands.c
deleted file mode 100644
index ae750c46d425..000000000000
--- a/ftp/bftpd/files/patch-commands.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- commands.c.orig 2011-05-20 14:39:41.000000000 -0300
-+++ commands.c 2011-05-20 14:40:45.000000000 -0300
-@@ -18,9 +18,6 @@
- #ifdef HAVE_SYS_SOCKET_H
- #include <sys/socket.h>
- #endif
--#ifdef HAVE_ASM_SOCKET_H
--#include <asm/socket.h>
--#endif
- #ifdef HAVE_NETINET_IN_H
- #include <netinet/in.h>
- #endif
-@@ -35,12 +32,8 @@
- #endif
- #include <fcntl.h>
- #include <string.h>
--#ifdef HAVE_WAIT_H
--# include <wait.h>
--#else
--# ifdef HAVE_SYS_WAIT_H
--# include <sys/wait.h>
--# endif
-+#ifdef HAVE_SYS_WAIT_H
-+#include <sys/wait.h>
- #endif
-
- #include "mystring.h"