aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-28 16:49:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-28 16:49:08 +0000
commitdfed6cbc6965d01b5ffcc8c9ec1d182438d3f440 (patch)
tree173e3531c6bf07296a4552ca5350f88e970c4e10 /ftp
parent3953962855b11b3c0893b789dd4a9f0e403844b8 (diff)
downloadports-dfed6cbc6965d01b5ffcc8c9ec1d182438d3f440.tar.gz
ports-dfed6cbc6965d01b5ffcc8c9ec1d182438d3f440.zip
- Rework OpenSSL/LibreSSL check
Notes
Notes: svn path=/head/; revision=390796
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 12e4c063305f..712c27d2fdba 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -162,14 +162,15 @@ IGNORE= only supports LDAPS with SSL
IGNORE= only supports LIBSSH2 with OpenSSL
.endif
-.if ${PORT_OPTIONS:MOPENSSL} && ( \
- defined(WITH_OPENSSL_PORT) || \
- (!defined(WITH_OPENSSL_BASE) && exists(${LOCALBASE}/lib/libcrypto.so)) || \
- (defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"))
-.if ${PORT_OPTIONS:MGSSAPI_BASE}
-IGNORE= GSSAPI_BASE is set, which is not compatible with OpenSSL/LibreSSL from ports. Set GSSAPI_NONE or do not use ports SSL.
+.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL} && (defined(WITH_OPENSSL_PORT) || (!defined(WITH_OPENSSL_BASE) && exists(${LOCALBASE}/lib/libcrypto.so)))
+IGNORE= GSSAPI_BASE is not compatible with OpenSSL from ports. Use other GSSAPI options or OpenSSL from base system
.endif
-.if ${PORT_OPTIONS:MTLS_SRP} && defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"
+
+.if defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"
+.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL}
+IGNORE= GSSAPI_BASE is not compatible with LibreSSL. Use other GSSAPI options
+.endif
+.if ${PORT_OPTIONS:MTLS_SRP}
IGNORE= unsupported TLS-SRP in LibreSSL
.endif
.endif