aboutsummaryrefslogtreecommitdiff
path: root/games/3dc
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-05-12 09:01:40 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-05-13 12:51:00 +0000
commit339d443d7b97dcef2ad415ff9cf743685ebea304 (patch)
treedf9cb9bd1b42ee195f584b9de1499e5f8b39fc24 /games/3dc
parenta42f04c96638c93df12270b4775c16a81f00d3eb (diff)
downloadports-339d443d7b97dcef2ad415ff9cf743685ebea304.tar.gz
ports-339d443d7b97dcef2ad415ff9cf743685ebea304.zip
games/3dc: Fix crash on boot
The call to XtVaGetValues returns a value that overwrites the `bc` variable and smashes the stack. Use a long instead. PR: 255765 Reported by: grahamperrin@gmail.com Tested by: rhurling@ MFH: 2021Q2
Diffstat (limited to 'games/3dc')
-rw-r--r--games/3dc/Makefile2
-rw-r--r--games/3dc/files/patch-xif.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/3dc/Makefile b/games/3dc/Makefile
index 6387671812dd..bb7a5b526c20 100644
--- a/games/3dc/Makefile
+++ b/games/3dc/Makefile
@@ -2,7 +2,7 @@
PORTNAME= 3dc
PORTVERSION= 0.8.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SUNSITE/games/strategy
DISTNAME= 3Dc-${PORTVERSION}
diff --git a/games/3dc/files/patch-xif.c b/games/3dc/files/patch-xif.c
new file mode 100644
index 000000000000..b184d0136707
--- /dev/null
+++ b/games/3dc/files/patch-xif.c
@@ -0,0 +1,11 @@
+--- xif.c.orig 2021-05-12 08:22:05 UTC
++++ xif.c
+@@ -171,7 +171,7 @@ InitMainWindow( GfxInfo *gfx )
+ /* undo, */ resign,
+ musterTitle
+ /* muster */;
+- int bg;
++ long bg;
+
+ form = XtVaCreateManagedWidget("form", formWidgetClass, gfx->mainWindow,
+ NULL);