aboutsummaryrefslogtreecommitdiff
path: root/games/3dpong/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-14 12:21:20 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-14 12:21:20 +0000
commit0c70864fbc4b4e55defca0bf53ba035e2b0ca635 (patch)
tree9c5b0e0f1ba5743a88f1bd59059a15c26a6ef7b0 /games/3dpong/Makefile
parent08c0128817ed46d3e85946ca76e59b215354df1b (diff)
downloadports-0c70864fbc4b4e55defca0bf53ba035e2b0ca635.tar.gz
ports-0c70864fbc4b4e55defca0bf53ba035e2b0ca635.zip
Update to version 0.5
PR: ports/69001 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=113638
Diffstat (limited to 'games/3dpong/Makefile')
-rw-r--r--games/3dpong/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/games/3dpong/Makefile b/games/3dpong/Makefile
index 816cf3a2be4b..d42fdc1d3ae0 100644
--- a/games/3dpong/Makefile
+++ b/games/3dpong/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= 3dpong
-PORTVERSION= 0.4
+PORTVERSION= 0.5
CATEGORIES= games
MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/3dpong/src/
@@ -15,11 +15,13 @@ COMMENT= X Window 3D Pong game for 1 or 2 players with a ball and paddles
USE_X_PREFIX= yes
USE_REINPLACE= yes
-MAKEFILE= makefile
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${X11BASE}/include" \
+ XLIB="-L${X11BASE}/lib -lX11"
post-patch:
- @${REINPLACE_CMD} -e 's. chmod . ${CHMOD} .g' \
- ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e \
+ 's|cat sounds/|cat ${DATADIR}/|g' ${WRKSRC}/src/3dpong.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/3dpong ${PREFIX}/bin
@@ -27,7 +29,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/sounds/*.au ${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.for file in AUTHORS.txt CHANGES.txt INSTALL.txt README.txt TODO.txt
+ ${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>