aboutsummaryrefslogtreecommitdiff
path: root/games/7kaa
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-21 12:56:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-21 12:56:58 +0000
commit1fe3c71e87c78445b250ced911919c05f453802c (patch)
tree8d0a30c50a5d9d7625d469c37eb260b646c39029 /games/7kaa
parentcb18b0c1ee8fc752dd2c9184ad7f2dca4830b67d (diff)
downloadports-1fe3c71e87c78445b250ced911919c05f453802c.tar.gz
ports-1fe3c71e87c78445b250ced911919c05f453802c.zip
This is a GPL release of the Seven Kingdoms: Ancient Adversaries
thanks to Enlight Software which granted the ability to license the game under a free and open source license in 2009. See the file "COPYING" for the details of the license. We are indebted to Enlight for making the 7kfans project possible and giving a new chance to build a community for fans of the game. WWW: http://7kfans.com/
Notes
Notes: svn path=/head/; revision=386930
Diffstat (limited to 'games/7kaa')
-rw-r--r--games/7kaa/Makefile35
-rw-r--r--games/7kaa/distinfo2
-rw-r--r--games/7kaa/files/patch-src_common_OMISC.cpp25
-rw-r--r--games/7kaa/pkg-descr8
4 files changed, 70 insertions, 0 deletions
diff --git a/games/7kaa/Makefile b/games/7kaa/Makefile
new file mode 100644
index 000000000000..11a09ea3a549
--- /dev/null
+++ b/games/7kaa/Makefile
@@ -0,0 +1,35 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= 7kaa
+PORTVERSION= 2.14.5
+CATEGORIES= games
+MASTER_SITES= SF/skfans/7KAA%20${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Seven Kingdoms: Ancient Adversaries
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libenet.so:${PORTSDIR}/net/enet
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-silent-rules \
+ --disable-nls # no translations ATM
+USES= gmake openal:al tar:xz
+USE_SDL= sdl2
+
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= *
+PORTDATA= *
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ ${RM} -f ${STAGEDIR}${DOCSDIR}/COPYING
+
+.include <bsd.port.mk>
diff --git a/games/7kaa/distinfo b/games/7kaa/distinfo
new file mode 100644
index 000000000000..6c6337c3d3db
--- /dev/null
+++ b/games/7kaa/distinfo
@@ -0,0 +1,2 @@
+SHA256 (7kaa-2.14.5.tar.xz) = c7f04fa640d324ed8f1523da49945acd0f1ee2a99e3ee82ee29b52d2f735e464
+SIZE (7kaa-2.14.5.tar.xz) = 31223408
diff --git a/games/7kaa/files/patch-src_common_OMISC.cpp b/games/7kaa/files/patch-src_common_OMISC.cpp
new file mode 100644
index 000000000000..fb3b6bbc0e5b
--- /dev/null
+++ b/games/7kaa/files/patch-src_common_OMISC.cpp
@@ -0,0 +1,25 @@
+--- src/common/OMISC.cpp.orig 2015-05-19 01:00:20 UTC
++++ src/common/OMISC.cpp
+@@ -37,6 +37,7 @@
+ #include <stdlib.h>
+ #include <time.h>
+ #include <ctype.h>
++#include <math.h>
+
+ #include <ALL.h>
+ #include <OSTR.h>
+@@ -755,10 +756,13 @@ char* Misc::format(double inNum, int for
+
+ static char outBuf[35];
+ char *outPtr=outBuf;
++ char floatBuf[35];
+ char *floatStr;
+ int i, intDigit, sign; // intDigit = no. of integer digits
+
+- floatStr = fcvt( inNum, MONEY_DEC_PLACE, &intDigit, &sign );
++ intDigit = snprintf(floatBuf, sizeof(floatBuf), "%.0lf", fabs(inNum) * 100.0);
++ intDigit -= 2;
++ floatStr = floatBuf;
+
+ #ifdef DEBUG
+ if( intDigit > 29 ) // integer digits can't exceed 29
diff --git a/games/7kaa/pkg-descr b/games/7kaa/pkg-descr
new file mode 100644
index 000000000000..6da7b3bcb349
--- /dev/null
+++ b/games/7kaa/pkg-descr
@@ -0,0 +1,8 @@
+This is a GPL release of the Seven Kingdoms: Ancient Adversaries
+thanks to Enlight Software which granted the ability to license the
+game under a free and open source license in 2009. See the file
+"COPYING" for the details of the license. We are indebted to Enlight
+for making the 7kfans project possible and giving a new chance to
+build a community for fans of the game.
+
+WWW: http://7kfans.com/