aboutsummaryrefslogtreecommitdiff
path: root/games/KnightCap
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-26 15:25:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-26 15:25:17 +0000
commite2067c1eced531e4e25097711831b9423cffa68f (patch)
tree3ade27ab5935b47a8e0be5bf7aca662722613f75 /games/KnightCap
parentb6dbde66723ba85970c70391f7fb61afa27c5c59 (diff)
downloadports-e2067c1eced531e4e25097711831b9423cffa68f.tar.gz
ports-e2067c1eced531e4e25097711831b9423cffa68f.zip
- Unbreak: remove two conflicting functions, which are never used anyway.
PR: ports/76635 Submitted by: Johan van Selst <johans@stack.nl> (maintainer)
Notes
Notes: svn path=/head/; revision=127423
Diffstat (limited to 'games/KnightCap')
-rw-r--r--games/KnightCap/Makefile8
-rw-r--r--games/KnightCap/files/patch-knightcap.h19
2 files changed, 20 insertions, 7 deletions
diff --git a/games/KnightCap/Makefile b/games/KnightCap/Makefile
index 33b735facb14..edfe375fb86f 100644
--- a/games/KnightCap/Makefile
+++ b/games/KnightCap/Makefile
@@ -26,12 +26,6 @@ DOCSDIR= ${PREFIX}/share/doc/KnightCap
PORTDOCS= README
PLIST_FILES= bin/KnightCap
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/KnightCap ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -39,4 +33,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/KnightCap/files/patch-knightcap.h b/games/KnightCap/files/patch-knightcap.h
new file mode 100644
index 000000000000..86e49fbe7591
--- /dev/null
+++ b/games/KnightCap/files/patch-knightcap.h
@@ -0,0 +1,19 @@
+--- knightcap.h Mon Jan 24 22:20:22 2005
++++ knightcap.h Mon Jan 24 22:17:19 2005
+@@ -632,16 +632,6 @@
+ return i1 > i2? i1 : i2;
+ }
+
+-static inline float fmin(float i1, float i2)
+-{
+- return i1 > i2? i2 : i1;
+-}
+-
+-static inline float fmax(float i1, float i2)
+-{
+- return i1 > i2? i1 : i2;
+-}
+-
+ static inline etype emin(etype i1, etype i2)
+ {
+ return i1 > i2? i2 : i1;