aboutsummaryrefslogtreecommitdiff
path: root/games/ags/files
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-02-22 11:34:06 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-02-22 11:34:06 +0000
commit7613e8cfd9919cdf6576ac39c9de5133e909f234 (patch)
tree54612ceb60e5e4a85464a3cc1cb82aca327717b5 /games/ags/files
parent4d1183dc5b42d0b19dab7685f3a20287c0da3c34 (diff)
downloadports-7613e8cfd9919cdf6576ac39c9de5133e909f234.tar.gz
ports-7613e8cfd9919cdf6576ac39c9de5133e909f234.zip
New port: games/ags
Adventure Game Studio (AGS) is an open source development tool that is primarily used to create graphic adventure games like e.g. - Primordia - King's Quest I: Quest for the Crown Enhanced Edition - King's Quest II: Romancing the Stones - King's Quest III Redux: To Heir is Human This port provides the runtime only and can be used for running games created with AGS. WWW: http://www.adventuregamestudio.co.uk/ Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D9702
Notes
Notes: svn path=/head/; revision=434579
Diffstat (limited to 'games/ags/files')
-rw-r--r--games/ags/files/patch-Engine_Makefile-defs.linux27
-rw-r--r--games/ags/files/patch-Engine_ac_dynobj_cc__dynamicarray.cpp11
2 files changed, 38 insertions, 0 deletions
diff --git a/games/ags/files/patch-Engine_Makefile-defs.linux b/games/ags/files/patch-Engine_Makefile-defs.linux
new file mode 100644
index 000000000000..325d9f0a29b4
--- /dev/null
+++ b/games/ags/files/patch-Engine_Makefile-defs.linux
@@ -0,0 +1,27 @@
+--- Engine/Makefile-defs.linux.orig 2017-02-07 22:37:22 UTC
++++ Engine/Makefile-defs.linux
+@@ -1,7 +1,7 @@
+ INCDIR = ../Engine ../Common ../Common/libinclude ../Plugins
+ LIBDIR =
+-CFLAGS := -O2 -g -fsigned-char -Wfatal-errors -DNDEBUG -DAGS_RUNTIME_PATCH_ALLEGRO -DAGS_HAS_CD_AUDIO -DAGS_CASE_SENSITIVE_FILESYSTEM -DALLEGRO_STATICLINK -DLINUX_VERSION -DDISABLE_MPEG_AUDIO -DBUILTIN_PLUGINS -DRTLD_NEXT $(shell pkg-config --cflags freetype2) $(CFLAGS)
+-CXXFLAGS := -fno-rtti -Wno-write-strings $(CXXFLAGS)
++CFLAGS += -fsigned-char -Wfatal-errors -DNDEBUG -DAGS_RUNTIME_PATCH_ALLEGRO -DAGS_CASE_SENSITIVE_FILESYSTEM -DALLEGRO_STATICLINK -DLINUX_VERSION -DDISABLE_MPEG_AUDIO -DBUILTIN_PLUGINS -DRTLD_NEXT $(shell pkg-config --cflags freetype2)
++CXXFLAGS += -std=c++11 -fno-rtti -Wno-write-strings
+ LIBS := -rdynamic -laldmb -ldumb -Wl,-Bdynamic
+ LIBS += $(shell pkg-config --libs allegro)
+ LIBS += $(shell pkg-config --libs x11)
+@@ -16,7 +16,7 @@ else
+ endif
+ LIBS += $(shell pkg-config --libs vorbisfile)
+ LIBS += $(shell pkg-config --libs freetype2)
+-LIBS += -ldl -lpthread -lc -lm -lstdc++
++LIBS += -lpthread -lc -lm -lstdc++
+
+ ifeq ($(ALLEGRO_MAGIC_DRV), 1)
+ CFLAGS += -DALLEGRO_MAGIC_DRV
+@@ -44,4 +44,4 @@ platform/linux/acpllnx.cpp \
+ platform/util/pe.c \
+ platform/util/libc.c
+
+-CDA = libsrc/libcda-0.5/linux.c
++# CDA = libsrc/libcda-0.5/linux.c
diff --git a/games/ags/files/patch-Engine_ac_dynobj_cc__dynamicarray.cpp b/games/ags/files/patch-Engine_ac_dynobj_cc__dynamicarray.cpp
new file mode 100644
index 000000000000..857b1ba5291d
--- /dev/null
+++ b/games/ags/files/patch-Engine_ac_dynobj_cc__dynamicarray.cpp
@@ -0,0 +1,11 @@
+--- Engine/ac/dynobj/cc_dynamicarray.cpp.orig 2017-02-21 00:32:02 UTC
++++ Engine/ac/dynobj/cc_dynamicarray.cpp
+@@ -32,7 +32,7 @@ int CCDynamicArray::Dispose(const char *
+ elementCount[0] &= ~ARRAY_MANAGED_TYPE_FLAG;
+ for (int i = 0; i < elementCount[0]; i++)
+ {
+- if (elementCount[2 + i] != NULL)
++ if (elementCount[2 + i] != 0)
+ {
+ ccReleaseObjectReference(elementCount[2 + i]);
+ }