aboutsummaryrefslogtreecommitdiff
path: root/games/alephone
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-04-20 05:17:21 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-04-20 05:17:21 +0000
commit4b0775b6c11344f47f4827359e49d61f0e2daa27 (patch)
tree7ab8815fb0e273ad95e8dde75785d72f6199beb1 /games/alephone
parentf9ccf7b04bb7bd2eec3e2b9c45958736aff9712f (diff)
downloadports-4b0775b6c11344f47f4827359e49d61f0e2daa27.tar.gz
ports-4b0775b6c11344f47f4827359e49d61f0e2daa27.zip
- Update to 20051119
PR: ports/96003 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=159982
Diffstat (limited to 'games/alephone')
-rw-r--r--games/alephone/Makefile30
-rw-r--r--games/alephone/distinfo6
-rw-r--r--games/alephone/files/patch-Source_Files-Misc-thread_priority_sdl_posix.cpp11
-rw-r--r--games/alephone/files/patch-Source_Files__Misc__Logging_gruntwork.h25
-rw-r--r--games/alephone/pkg-plist1
5 files changed, 48 insertions, 25 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 481deceaf799..c10d388146e2 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= alephone
-PORTVERSION= 20050118
+PORTVERSION= 20051119
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= marathon
@@ -15,28 +15,38 @@ DISTNAME= AlephOne-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The open source version of Bungie's Marathon game
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost
+LIB_DEPENDS= speex.3:${PORTSDIR}/audio/speex \
+ lua.5:${PORTSDIR}/lang/lua
+
+USE_X_PREFIX= yes
+USE_GNOME= gnometarget
USE_SDL= image net sdl sound
USE_GL= yes
-USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- CFLAGS="${CFLAGS} -I${X11BASE}/include" \
- CXXFLAGS="${CXXFLAGS} -I${X11BASE}/include" \
- LDFLAGS="${LDFLAGS} -L${X11BASE}/lib"
-CONFIGURE_ARGS+=--program-transform-name=""
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500035
+CXXFLAGS+= -ftemplate-depth-30
+.endif
+
post-patch:
+ @${REINPLACE_CMD} -e 's|<SDL/SDL|<SDL|g' \
+ ${WRKSRC}/Source_Files/Misc/thread_priority_sdl_posix.cpp
.if ${OSVERSION} < 500035
@${REINPLACE_CMD} -e 's|streambuf>|streambuf\.h>|' \
${WRKSRC}/Source_Files/CSeries/snprintf.h
+ @${REINPLACE_CMD} -e 's|m_buffer\.clear()|m_buffer.resize(0)|g ; \
+ s|m_displayBuffer\.clear()|m_displayBuffer.resize(0)|g' \
+ ${WRKSRC}/Source_Files/Misc/Console.cpp
.endif
post-install:
-.if !defined(NOPORTDOCS)
@${CAT} ${PKGMESSAGE}
-.endif
.include <bsd.port.post.mk>
diff --git a/games/alephone/distinfo b/games/alephone/distinfo
index f6807c5e6c59..417188aea0a0 100644
--- a/games/alephone/distinfo
+++ b/games/alephone/distinfo
@@ -1,3 +1,3 @@
-MD5 (AlephOne-20050118.tar.gz) = c30c96b7b24c7b44f39c1a83534e1446
-SHA256 (AlephOne-20050118.tar.gz) = 4b2692bfa9f80d74b214d875b9143fba56c8f06c72bd2339dc4cd44263be12af
-SIZE (AlephOne-20050118.tar.gz) = 1335814
+MD5 (AlephOne-20051119.tar.gz) = 35d42aa80d3d2ab54b5ec5015e5ddcf4
+SHA256 (AlephOne-20051119.tar.gz) = 0f6dcb1acd153babc3905b18bf460eca7a62a29ba963a812015510d0fa9d9752
+SIZE (AlephOne-20051119.tar.gz) = 6519469
diff --git a/games/alephone/files/patch-Source_Files-Misc-thread_priority_sdl_posix.cpp b/games/alephone/files/patch-Source_Files-Misc-thread_priority_sdl_posix.cpp
deleted file mode 100644
index 016752541655..000000000000
--- a/games/alephone/files/patch-Source_Files-Misc-thread_priority_sdl_posix.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- Source_Files/Misc/thread_priority_sdl_posix.cpp.orig Fri Aug 29 03:31:10 2003
-+++ Source_Files/Misc/thread_priority_sdl_posix.cpp Thu Jun 23 05:11:11 2005
-@@ -12,7 +12,7 @@
- #if defined(TARGET_API_MAC_CARBON) && __MACH__
- #include <SDL/SDL_Thread.h>
- #else
--#include <SDL/SDL_thread.h>
-+#include <SDL_thread.h>
- #endif
-
- #include <pthread.h>
diff --git a/games/alephone/files/patch-Source_Files__Misc__Logging_gruntwork.h b/games/alephone/files/patch-Source_Files__Misc__Logging_gruntwork.h
new file mode 100644
index 000000000000..0172769d3507
--- /dev/null
+++ b/games/alephone/files/patch-Source_Files__Misc__Logging_gruntwork.h
@@ -0,0 +1,25 @@
+--- Source_Files/Misc/Logging_gruntwork.h.orig Tue Aug 30 23:47:00 2005
++++ Source_Files/Misc/Logging_gruntwork.h Tue Apr 18 12:27:12 2006
+@@ -13,14 +13,14 @@
+ #define logDump(message) (GetCurrentLogger()->logMessage(logDomain, logDumpLevel, __FILE__, __LINE__, (message)))
+ #else
+ // this obsoletes this whole file, pretty much - since macros can support var args and stuff :P
+-#define logFatal(...) (GetCurrentLogger()->logMessage(logDomain, logFatalLevel, __FILE__, __LINE__, __VA_ARGS__))
+-#define logError(...) (GetCurrentLogger()->logMessage(logDomain, logErrorLevel, __FILE__, __LINE__, __VA_ARGS__))
+-#define logWarning(...) (GetCurrentLogger()->logMessage(logDomain, logWarningLevel, __FILE__, __LINE__, __VA_ARGS__))
+-#define logAnomaly(...) (GetCurrentLogger()->logMessage(logDomain, logAnomalyLevel, __FILE__, __LINE__, __VA_ARGS__))
+-#define logNote(...) (GetCurrentLogger()->logMessage(logDomain, logNoteLevel, __FILE__, __LINE__, __VA_ARGS__))
+-#define logSummary(...) (GetCurrentLogger()->logMessage(logDomain, logSummaryLevel, __FILE__, __LINE__, __VA_ARGS__))
+-#define logTrace(...) (GetCurrentLogger()->logMessage(logDomain, logTraceLevel, __FILE__, __LINE__, __VA_ARGS__))
+-#define logDump(...) (GetCurrentLogger()->logMessage(logDomain, logDumpLevel, __FILE__, __LINE__, __VA_ARGS__))
++#define logFatal(ARGS...) (GetCurrentLogger()->logMessage(logDomain, logFatalLevel, __FILE__, __LINE__, ##ARGS))
++#define logError(ARGS...) (GetCurrentLogger()->logMessage(logDomain, logErrorLevel, __FILE__, __LINE__, ##ARGS))
++#define logWarning(ARGS...) (GetCurrentLogger()->logMessage(logDomain, logWarningLevel, __FILE__, __LINE__, ##ARGS))
++#define logAnomaly(ARGS...) (GetCurrentLogger()->logMessage(logDomain, logAnomalyLevel, __FILE__, __LINE__, ##ARGS))
++#define logNote(ARGS...) (GetCurrentLogger()->logMessage(logDomain, logNoteLevel, __FILE__, __LINE__, ##ARGS))
++#define logSummary(ARGS...) (GetCurrentLogger()->logMessage(logDomain, logSummaryLevel, __FILE__, __LINE__, ##ARGS))
++#define logTrace(ARGS...) (GetCurrentLogger()->logMessage(logDomain, logTraceLevel, __FILE__, __LINE__, ##ARGS))
++#define logDump(ARGS...) (GetCurrentLogger()->logMessage(logDomain, logDumpLevel, __FILE__, __LINE__, ##ARGS))
+ #endif
+
+
diff --git a/games/alephone/pkg-plist b/games/alephone/pkg-plist
index c2e289b5d852..0bf919dbb7c6 100644
--- a/games/alephone/pkg-plist
+++ b/games/alephone/pkg-plist
@@ -1,7 +1,6 @@
bin/alephone
share/AlephOne/Fonts
share/AlephOne/MML/Interface_Rects.mml
-share/AlephOne/MML/Text_Strings.mml
share/AlephOne/MML/Transparent_Liquids.mml
share/AlephOne/MML/Transparent_Sprites.mml
share/AlephOne/Themes/Default/button_c.bmp