aboutsummaryrefslogtreecommitdiff
path: root/games/alephone
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-03-29 07:52:36 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-03-29 07:52:36 +0000
commit531dd90d4cce79bf01ffb5fd90efa4720b6e4605 (patch)
tree1e0490cf579198b4360c05b751deaede5a36933c /games/alephone
parent14e7693735f2bd0a313e0f01db893a7eee88163a (diff)
downloadports-531dd90d4cce79bf01ffb5fd90efa4720b6e4605.tar.gz
ports-531dd90d4cce79bf01ffb5fd90efa4720b6e4605.zip
Add a missing depend on graphics/sdl_image and add a regexp to allow this
to compile. PR: 36438 Submitted by: Josh Elsasser <jre@vineyard.net>
Notes
Notes: svn path=/head/; revision=56844
Diffstat (limited to 'games/alephone')
-rw-r--r--games/alephone/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index f69eb118e886..d10717c16db8 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -14,7 +14,8 @@ DISTNAME= AlephOne-${PORTVERSION}
MAINTAINER= malyn@strangeGizmo.com
-LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12:install
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12:install \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image:install
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
@@ -22,6 +23,11 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+post-patch:
+ @${PERL} -pi -e 's,^#include \"network_modem.h\".*,,' \
+ ${WRKSRC}/Source_Files/Network/network.cpp \
+ ${WRKSRC}/Source_Files/Network/network_stream.cpp \
+
post-install:
.if !defined(NOPORTDOCS)
@${CAT} ${PKGMESSAGE}