aboutsummaryrefslogtreecommitdiff
path: root/games/aop/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-05-05 07:47:27 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-05-05 07:47:27 +0000
commit9f6d49b5ceedd303a149c253ce1362467cde1462 (patch)
treea2c68b5118b7034ace74a0efddbf40be1c7da820 /games/aop/Makefile
parent8a98acce4c40bef8388338b921069f51b61353fd (diff)
downloadports-9f6d49b5ceedd303a149c253ce1362467cde1462.tar.gz
ports-9f6d49b5ceedd303a149c253ce1362467cde1462.zip
Aop (Ambassador Of Pain) is a curses based arcade game for UNIX with only 64
lines of sourcecode. The goal is to drive the hoovercraft (O) trough the level into the 'at' sign (@) and reach as much points as possible by reducing the number of moves and don't losing any time. Lost lifes (0) can easily be picked up by simply drive over them. WWW: http://aop.raffi.at/ PR: ports/65898 Submitted by: Aaron Zauner <az_mail@gmx.at> Approved by: marcus (backup mentor)
Notes
Notes: svn path=/head/; revision=108431
Diffstat (limited to 'games/aop/Makefile')
-rw-r--r--games/aop/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/games/aop/Makefile b/games/aop/Makefile
new file mode 100644
index 000000000000..1dde3fdc4273
--- /dev/null
+++ b/games/aop/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: aop
+# Date created: 22. April 2004
+# Whom: Aaron Zauner <az_mail@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aop
+PORTVERSION= 0.6
+CATEGORIES= games
+MASTER_SITES= http://raffi.at/code/aop/
+
+MAINTAINER= az_mail@gmx.at
+COMMENT= A curses based arcade game with only 64 lines of code
+
+USE_REINPLACE= yes
+DOCS= COPYING README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ ${WRKSRC}/Makefile
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for ii in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>