aboutsummaryrefslogtreecommitdiff
path: root/games/arx-libertatis
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-04-26 00:40:15 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-04-26 00:40:15 +0000
commitb93b137c4c230b40c450882a21d3d74a563637c7 (patch)
tree0e1f0b1b6e37dfb8506e291dca194718c518a31c /games/arx-libertatis
parent0d2f8ff1e381ba260b2bbb3259d399a56cbd27fb (diff)
downloadports-b93b137c4c230b40c450882a21d3d74a563637c7.tar.gz
ports-b93b137c4c230b40c450882a21d3d74a563637c7.zip
Arx Libertatis is a cross-platform, open source port of Arx Fatalis,
a 2002 first-person role-playing game developed by Arkane Studios. WWW: http://arx-libertatis.org
Notes
Notes: svn path=/head/; revision=295535
Diffstat (limited to 'games/arx-libertatis')
-rw-r--r--games/arx-libertatis/Makefile62
-rw-r--r--games/arx-libertatis/distinfo2
-rw-r--r--games/arx-libertatis/files/pkg-message.in14
-rw-r--r--games/arx-libertatis/pkg-descr4
-rw-r--r--games/arx-libertatis/pkg-plist7
5 files changed, 89 insertions, 0 deletions
diff --git a/games/arx-libertatis/Makefile b/games/arx-libertatis/Makefile
new file mode 100644
index 000000000000..0cf15e6f4652
--- /dev/null
+++ b/games/arx-libertatis/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: arx-libertatis
+# Date created: 24 Apr 2012
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arx-libertatis
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://cloud.github.com/downloads/arx/ArxLibertatis/ \
+ http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Cross-platform port of Arx Fatalis
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
+ GLEW.1:${PORTSDIR}/graphics/glew \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ boost_program_options.4:${PORTSDIR}/devel/boost-libs
+
+USE_XZ= yes
+USE_OPENAL= yes
+USE_SDL= sdl
+USE_GL= gl glu
+USE_CMAKE= yes
+CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR="man" -DDATA_DIR=arx
+MAKE_JOBS_SAFE= yes
+
+SUB_FILES= pkg-message
+
+MAN1= arxsavetool.1 arxunpak.1
+MAN6= arx.6
+
+OPTIONS= CRASHREPORTER "Build crash reporter (requires Qt4)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_CRASHREPORTER)
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui network rcc_build moc_build uic_build qmake_build
+CMAKE_ARGS+= -DBUILD_CRASHREPORTER=ON
+PLIST_SUB+= CRASHREPORTER=""
+.else
+CMAKE_ARGS+= -DBUILD_CRASHREPORTER=OFF
+PLIST_SUB+= CRASHREPORTER="@comment "
+.endif
+
+PORTDOCS= AUTHORS CHANGELOG README.md
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/games/arx-libertatis/distinfo b/games/arx-libertatis/distinfo
new file mode 100644
index 000000000000..d8301019387a
--- /dev/null
+++ b/games/arx-libertatis/distinfo
@@ -0,0 +1,2 @@
+SHA256 (arx-libertatis-1.0.1.tar.xz) = a8cdcd3ca09af86166a4913c00e1e0a1b3d65be86d9685a3cd4a11ee498b5c26
+SIZE (arx-libertatis-1.0.1.tar.xz) = 910116
diff --git a/games/arx-libertatis/files/pkg-message.in b/games/arx-libertatis/files/pkg-message.in
new file mode 100644
index 000000000000..d8b68d74c9fa
--- /dev/null
+++ b/games/arx-libertatis/files/pkg-message.in
@@ -0,0 +1,14 @@
+==========================================================================
+
+Arx Libertatis requires data files from either full version or a demo
+of Arx Fatalis. Copy the following files and directories to
+either %%PREFIX%%/share/arx or ~/.local/share/arx:
+
+ *.pak
+ graph/
+ misc/
+
+See http://arx.parpg.net/Getting_the_game_data for the information on
+getting the game data.
+
+==========================================================================
diff --git a/games/arx-libertatis/pkg-descr b/games/arx-libertatis/pkg-descr
new file mode 100644
index 000000000000..a7ac59ac6437
--- /dev/null
+++ b/games/arx-libertatis/pkg-descr
@@ -0,0 +1,4 @@
+Arx Libertatis is a cross-platform, open source port of Arx Fatalis,
+a 2002 first-person role-playing game developed by Arkane Studios.
+
+WWW: http://arx-libertatis.org
diff --git a/games/arx-libertatis/pkg-plist b/games/arx-libertatis/pkg-plist
new file mode 100644
index 000000000000..c737e95720c2
--- /dev/null
+++ b/games/arx-libertatis/pkg-plist
@@ -0,0 +1,7 @@
+bin/arx
+bin/arxsavetool
+bin/arxunpak
+%%CRASHREPORTER%%libexec/arxcrashreporter
+share/applications/arx-libertatis.desktop
+share/pixmaps/arx-libertatis.png
+@dirrmtry share/applications