aboutsummaryrefslogtreecommitdiff
path: root/games/asylum
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-21 15:24:34 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-21 15:24:34 +0000
commit8035720be88a66fa004921b4fb250eb78d02b3cf (patch)
treeac8ec99e413b37c0c65c47aa2aa2213a580cb2a5 /games/asylum
parentdab8a04b463928d5224f8542014b904c1a178f7c (diff)
downloadports-8035720be88a66fa004921b4fb250eb78d02b3cf.tar.gz
ports-8035720be88a66fa004921b4fb250eb78d02b3cf.zip
- Add games/asylum
SDL Asylum is a C port of the computer game Asylum, which was written by Andy Southgate in 1994 for the Acorn Archimedes and is now public domain. "Young Sigmund has a few problems. To help him resolve his mental instability you must enter the surreal world of his inner mind and shut down the malfunctioning brain cells which are causing him these problems." -- Instructions file from original game WWW: http://sdl-asylum.sourceforge.net/
Notes
Notes: svn path=/head/; revision=426728
Diffstat (limited to 'games/asylum')
-rw-r--r--games/asylum/Makefile48
-rw-r--r--games/asylum/distinfo3
-rw-r--r--games/asylum/files/patch-Makefile32
-rw-r--r--games/asylum/pkg-descr10
-rw-r--r--games/asylum/pkg-plist6
5 files changed, 99 insertions, 0 deletions
diff --git a/games/asylum/Makefile b/games/asylum/Makefile
new file mode 100644
index 000000000000..3532460f4586
--- /dev/null
+++ b/games/asylum/Makefile
@@ -0,0 +1,48 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= asylum
+PORTVERSION= 0.3.2
+CATEGORIES= games
+MASTER_SITES= SF/sdl-${PORTNAME}/Asylum/${PORTVERSION}/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Surreal platform shooting game
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake
+USE_SDL= sdl mixer
+ALL_TARGET= build
+USE_GL= gl glu
+
+PORTDOCS= Instruct README
+PORTDATA= *
+
+MAKE_ARGS= INSTALLRESOURCEPATH="${DATADIR}" \
+ INSTALLHISCORES="/var/games/${PORTNAME}"
+
+OPTIONS_DEFINE= DOCS
+
+post-extract:
+ @${RM} ${WRKSRC}/${PORTNAME}
+ @cd ${WRKSRC} && for f in *.c; do \
+ ${MV} $${f} $${f}pp; \
+ done
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}/var/games/${PORTNAME}
+.for f in Ego Psyche Id Extended
+ ${TOUCH} ${STAGEDIR}/var/games/${PORTNAME}/${f}HighScores.sample
+.endfor
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/asylum/distinfo b/games/asylum/distinfo
new file mode 100644
index 000000000000..ec07b2936d88
--- /dev/null
+++ b/games/asylum/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476901673
+SHA256 (asylum-0.3.2.tar.gz) = 94c5bc7de89f185cbc0ac7a4add21e890ca9680a6d01c21841aae69c4b9e724f
+SIZE (asylum-0.3.2.tar.gz) = 462671
diff --git a/games/asylum/files/patch-Makefile b/games/asylum/files/patch-Makefile
new file mode 100644
index 000000000000..9b038851275c
--- /dev/null
+++ b/games/asylum/files/patch-Makefile
@@ -0,0 +1,32 @@
+--- Makefile.orig 2009-02-20 21:46:51 UTC
++++ Makefile
+@@ -2,14 +2,15 @@ HOST=generic
+ #HOST=mingw
+ #HOST=haiku
+
+-CC=g++
++CXX?=g++
+ RM=rm
+-CFLAGS= -O3
+-COPTS= $(CFLAGS) -funsigned-char \
++CXXFLAGS?= -O3
++CXXFLAGS+= `sdl-config --cflags`
++COPTS= $(CXXFLAGS) -funsigned-char \
+ -DRESOURCEPATH=\"$(INSTALLRESOURCEPATH)\" \
+ -DSCOREPATH=\"$(INSTALLHISCORES)\"
+-LIBS= -lm -lSDL -lSDL_mixer -lGL -lGLU
+-SRCS= alien.c asylum.c bullet.c file.c keyboard.c maze.c menus.c player.c projectile.c sound.c vdu.c
++LIBS= -lm `sdl-config --libs` -lSDL_mixer -lGL -lGLU
++SRCS= alien.cpp asylum.cpp bullet.cpp file.cpp keyboard.cpp maze.cpp menus.cpp player.cpp projectile.cpp sound.cpp vdu.cpp
+
+ RESOURCES=data/Resources data/Ego data/Psyche data/Id data/Voices
+
+@@ -95,7 +96,7 @@ oggs:
+ build: asylum$(EXE)
+
+ asylum$(EXE): $(SRCS) $(OS_SOURCE) asylum.h Makefile
+- $(CC) $(COPTS) $(LDFLAGS) -o asylum$(EXE) $(SRCS) $(OS_SOURCE) $(LIBS)
++ $(CXX) $(COPTS) $(LDFLAGS) -o asylum$(EXE) $(SRCS) $(OS_SOURCE) $(LIBS)
+
+ clean:
+ $(RM) asylum$(EXE)
diff --git a/games/asylum/pkg-descr b/games/asylum/pkg-descr
new file mode 100644
index 000000000000..ca1a2bfdd122
--- /dev/null
+++ b/games/asylum/pkg-descr
@@ -0,0 +1,10 @@
+SDL Asylum is a C port of the computer game Asylum, which was
+written by Andy Southgate in 1994 for the Acorn Archimedes and is
+now public domain.
+
+"Young Sigmund has a few problems. To help him resolve his mental
+instability you must enter the surreal world of his inner mind and
+shut down the malfunctioning brain cells which are causing him these
+problems." -- Instructions file from original game
+
+WWW: http://sdl-asylum.sourceforge.net/
diff --git a/games/asylum/pkg-plist b/games/asylum/pkg-plist
new file mode 100644
index 000000000000..253f8c2c1605
--- /dev/null
+++ b/games/asylum/pkg-plist
@@ -0,0 +1,6 @@
+@(,games,2555) bin/asylum
+@sample(,games,664) /var/games/asylum/EgoHighScores.sample
+@sample(,games,664) /var/games/asylum/ExtendedHighScores.sample
+@sample(,games,664) /var/games/asylum/IdHighScores.sample
+@sample(,games,664) /var/games/asylum/PsycheHighScores.sample
+@dir(,games,775) /var/games/asylum