aboutsummaryrefslogtreecommitdiff
path: root/games/atanks/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-04-11 22:29:09 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-04-11 22:29:09 +0000
commitdc81ed497074d84c1ebeb8d57fb46511a7f5544a (patch)
treed22a07e830b9edd07f00a0167c085ff5f4c4158b /games/atanks/Makefile
parent9676434a2baf64d39416d05c8a287b6e9b95bb5c (diff)
downloadports-dc81ed497074d84c1ebeb8d57fb46511a7f5544a.tar.gz
ports-dc81ed497074d84c1ebeb8d57fb46511a7f5544a.zip
- Update to 5.9, Announce message:
This latest version of Atomic Tanks patches a few minor issues and should make the game more stable, especially when dealing with networked games. The fixes in this release are due to the kind contributions of Daniel Gutson. - Remove leading article from COMMENT - Add license (GPLv2) - USES gmake instead of USE_GMAKE - Use the new format for LIB_DEPENDS - Support STAGEDIR - Add DOCS and Option - Remove obsolete REINPLACE - Strip executable - Symlink the icon and credits.txt - Change files/patch-Makefile and recreate with make makepatch PR: ports/187636 Submitted by: Jesse <jessefrgsmith@yahoo.ca> (maintainer)
Notes
Notes: svn path=/head/; revision=351056
Diffstat (limited to 'games/atanks/Makefile')
-rw-r--r--games/atanks/Makefile43
1 files changed, 24 insertions, 19 deletions
diff --git a/games/atanks/Makefile b/games/atanks/Makefile
index 4272a2fcfca0..f36c31d310c2 100644
--- a/games/atanks/Makefile
+++ b/games/atanks/Makefile
@@ -2,32 +2,37 @@
# $FreeBSD$
PORTNAME= atanks
-PORTVERSION= 5.1
+PORTVERSION= 5.9
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
MAINTAINER= jessefrgsmith@yahoo.ca
-COMMENT= A 2D tank game with large, cartoonish weapons
+COMMENT= 2D tank game with large, cartoonish weapons
-LIB_DEPENDS= alleg:${PORTSDIR}/devel/allegro
+LICENSE= GPLv2
-USE_GMAKE= yes
+LIB_DEPENDS= liballeg.so:${PORTSDIR}/devel/allegro
+
+USES= gmake
MAKE_ARGS+= PREFIX=${PREFIX}/
PATCH_DEBUG= 1
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+PORTDOCS= Changelog README README_ru.txt credits.txt
+OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} \
- -e 's}^INSTALL[ ]*=.*}INSTALL=${INSTALL} ${COPY}};' \
- -e 's/-m *755/-m555 ${STRIP}/;' \
- -e 's/-m *644/-m444/;' \
- ${WRKSRC}/Makefile
-.if ${OSVERSION} >= 800501
- ${REINPLACE_CMD} \
- -e 's/int Filter_File( struct dirent/int Filter_File( const struct dirent/' \
- ${WRKSRC}/src/files.cpp
-.endif
-
-.include <bsd.port.post.mk>
+ @${REINPLACE_CMD} -e \
+ 's/int Filter_File( struct dirent/int Filter_File( const struct dirent/' \
+ ${WRKSRC}/src/files.cpp
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${LN} -sf ${DOCSDIR}/credits.txt ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>