aboutsummaryrefslogtreecommitdiff
path: root/games/atomix
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-12-11 02:05:07 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-12-11 02:05:07 +0000
commitf0b54ef3943066bef5ac1dc5afd18a9adf102844 (patch)
treebee5f39617ffe09be9047597eea389fc4476981f /games/atomix
parent87e836c627d5f98bbf4f0c1b76e814902d1996a0 (diff)
downloadports-f0b54ef3943066bef5ac1dc5afd18a9adf102844.tar.gz
ports-f0b54ef3943066bef5ac1dc5afd18a9adf102844.zip
Update to 1.0
Thanks to marcus@ for solving xml:lang issue.
Notes
Notes: svn path=/head/; revision=95582
Diffstat (limited to 'games/atomix')
-rw-r--r--games/atomix/Makefile13
-rw-r--r--games/atomix/distinfo2
-rw-r--r--games/atomix/files/patch-aa14
-rw-r--r--games/atomix/files/patch-ab15
-rw-r--r--games/atomix/files/patch-src::Makefile.in12
-rw-r--r--games/atomix/pkg-descr9
-rw-r--r--games/atomix/pkg-plist222
7 files changed, 139 insertions, 148 deletions
diff --git a/games/atomix/Makefile b/games/atomix/Makefile
index b6d97f0bdab0..df9e4f2757fe 100644
--- a/games/atomix/Makefile
+++ b/games/atomix/Makefile
@@ -6,17 +6,24 @@
#
PORTNAME= atomix
-PORTVERSION= 0.4.3
+PORTVERSION= 1.0
CATEGORIES= games gnome
-MASTER_SITES= http://www.informatik.uni-oldenburg.de/~pearl/download/
+MASTER_SITES= http://triq.net/~jens/download/
MAINTAINER= gnome@FreeBSD.org
COMMENT= A yet another little mind game
+USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnomelibs
+USE_GNOME= gnomeprefix gnomehack libgnome libgnomeui libgnomecanvas libxml2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+USE_REINPLACE= yes
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
+ s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";|'
.include <bsd.port.mk>
diff --git a/games/atomix/distinfo b/games/atomix/distinfo
index d13577865e71..09b159a25591 100644
--- a/games/atomix/distinfo
+++ b/games/atomix/distinfo
@@ -1 +1 @@
-MD5 (atomix-0.4.3.tar.gz) = 2df3cdb8d7712e595751cc0ef19fe4b8
+MD5 (atomix-1.0.tar.gz) = 9c2c63ab1a3ea4c7b0246e1629aa9f4e
diff --git a/games/atomix/files/patch-aa b/games/atomix/files/patch-aa
deleted file mode 100644
index e4148aa066f0..000000000000
--- a/games/atomix/files/patch-aa
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/level.c.orig Sat Feb 5 22:50:24 2000
-+++ src/level.c Sat Feb 5 22:50:51 2000
-@@ -164,10 +164,10 @@
- g_free(filepath);
- }
- }
-+ closedir(dir);
- }
-
- //g_free(dent);
-- closedir(dir);
- }
-
- for(i = 0; i < n_dirs; i++) g_free(search_dirs[i]);
diff --git a/games/atomix/files/patch-ab b/games/atomix/files/patch-ab
deleted file mode 100644
index 9fe4fa3c412a..000000000000
--- a/games/atomix/files/patch-ab
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/theme.c.orig Sat Feb 5 22:51:13 2000
-+++ src/theme.c Sat Feb 5 22:51:36 2000
-@@ -199,10 +199,10 @@
- g_free(directory);
- }
- }
-+ g_free(dent);
-+ closedir(dir);
- }
-
-- g_free(dent);
-- closedir(dir);
- }
-
- for(i = 0; i < n_dirs; i++) g_free(search_dirs[i]);
diff --git a/games/atomix/files/patch-src::Makefile.in b/games/atomix/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..c642375f9a39
--- /dev/null
+++ b/games/atomix/files/patch-src::Makefile.in
@@ -0,0 +1,12 @@
+--- src/Makefile.in.orig Thu Dec 11 10:54:14 2003
++++ src/Makefile.in Thu Dec 11 10:55:37 2003
+@@ -447,7 +447,8 @@
+ mostlyclean distclean maintainer-clean
+
+
+-@INTLTOOL_XML_RULE@
++%.xml: %.xml.in
++ @cp $< $@
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/games/atomix/pkg-descr b/games/atomix/pkg-descr
index b8ce461e8769..f5caf2f972dd 100644
--- a/games/atomix/pkg-descr
+++ b/games/atomix/pkg-descr
@@ -1,3 +1,8 @@
-a yet another little mind game
+Atomix is a little mind game where you have to build molecules
+out of single atoms. These are laying around between the walls
+and obstacles on the playfield. Once you have pushed an atom in
+one direction it moves until it hits an obstacle or another
+atom. It needs some thinking how to construct complex
+molecules with this atom behaviour.
-WWW: http://www.informatik.uni-oldenburg.de/~pearl/gnome/atomix.html
+WWW: http://triq.net/~jens/atomix.php
diff --git a/games/atomix/pkg-plist b/games/atomix/pkg-plist
index c320c0c6b427..915b0bc176c3 100644
--- a/games/atomix/pkg-plist
+++ b/games/atomix/pkg-plist
@@ -1,119 +1,115 @@
bin/atomix
-bin/atomixed
-share/gnome/apps/Games/atomix.desktop
-share/gnome/atomix/levels/aceticacid.atomix
-share/gnome/atomix/levels/acetone.atomix
-share/gnome/atomix/levels/bonus1.atomix
-share/gnome/atomix/levels/bonus2.atomix
-share/gnome/atomix/levels/bonus3.atomix
-share/gnome/atomix/levels/buthanol.atomix
-share/gnome/atomix/levels/cyclo-buthane.atomix
-share/gnome/atomix/levels/dimethylether.atomix
-share/gnome/atomix/levels/ethan.atomix
-share/gnome/atomix/levels/ethanal.atomix
-share/gnome/atomix/levels/ethanol.atomix
-share/gnome/atomix/levels/ethylene.atomix
-share/gnome/atomix/levels/formaldeyd.atomix
-share/gnome/atomix/levels/glycerin.atomix
-share/gnome/atomix/levels/lactic-acid.atomix
-share/gnome/atomix/levels/methane.atomix
-share/gnome/atomix/levels/methanol.atomix
-share/gnome/atomix/levels/propanal.atomix
-share/gnome/atomix/levels/propylen.atomix
-share/gnome/atomix/levels/pyran.atomix
-share/gnome/atomix/levels/transbutylen.atomix
-share/gnome/atomix/levels/water.atomix
-share/gnome/atomix/themes/fabian/c.png
-share/gnome/atomix/themes/fabian/f.png
-share/gnome/atomix/themes/fabian/h.png
-share/gnome/atomix/themes/fabian/link1.png
-share/gnome/atomix/themes/fabian/link10.png
-share/gnome/atomix/themes/fabian/link11.png
-share/gnome/atomix/themes/fabian/link12.png
-share/gnome/atomix/themes/fabian/link2.png
-share/gnome/atomix/themes/fabian/link3.png
-share/gnome/atomix/themes/fabian/link4.png
-share/gnome/atomix/themes/fabian/link5.png
-share/gnome/atomix/themes/fabian/link6.png
-share/gnome/atomix/themes/fabian/link7.png
-share/gnome/atomix/themes/fabian/link8.png
-share/gnome/atomix/themes/fabian/link9.png
-share/gnome/atomix/themes/fabian/n.png
-share/gnome/atomix/themes/fabian/o.png
-share/gnome/atomix/themes/fabian/selector.png
-share/gnome/atomix/themes/fabian/theme
-share/gnome/atomix/themes/fabian/wall1.png
-share/gnome/atomix/themes/fabian/wall2.png
-share/gnome/atomix/themes/fabian/wall3.png
-share/gnome/atomix/themes/fabian/wall4.png
-share/gnome/atomix/themes/fabonus/bonus1.png
-share/gnome/atomix/themes/fabonus/bonus2.png
-share/gnome/atomix/themes/fabonus/bonus3.png
-share/gnome/atomix/themes/fabonus/bonus4.png
-share/gnome/atomix/themes/fabonus/bonus5.png
-share/gnome/atomix/themes/fabonus/bonus6.png
-share/gnome/atomix/themes/fabonus/bonus7.png
-share/gnome/atomix/themes/fabonus/bonus8.png
-share/gnome/atomix/themes/fabonus/selector.png
-share/gnome/atomix/themes/fabonus/theme
-share/gnome/atomix/themes/fabonus/wall3.png
-share/gnome/atomix/themes/katomic/atom-c.png
-share/gnome/atomix/themes/katomic/atom-h.png
-share/gnome/atomix/themes/katomic/atom-n.png
-share/gnome/atomix/themes/katomic/atom-o.png
-share/gnome/atomix/themes/katomic/conn-bottom-left.png
-share/gnome/atomix/themes/katomic/conn-bottom-right.png
-share/gnome/atomix/themes/katomic/conn-bottom.png
-share/gnome/atomix/themes/katomic/conn-double-bottom.png
-share/gnome/atomix/themes/katomic/conn-double-left.png
-share/gnome/atomix/themes/katomic/conn-double-right.png
-share/gnome/atomix/themes/katomic/conn-double-top.png
-share/gnome/atomix/themes/katomic/conn-left.png
-share/gnome/atomix/themes/katomic/conn-right.png
-share/gnome/atomix/themes/katomic/conn-top-left.png
-share/gnome/atomix/themes/katomic/conn-top-right.png
-share/gnome/atomix/themes/katomic/conn-top.png
-share/gnome/atomix/themes/katomic/selector.png
-share/gnome/atomix/themes/katomic/theme
-share/gnome/atomix/themes/katomic/wall-1.png
-share/gnome/atomix/themes/katomic/wall-2.png
-share/gnome/atomix/themes/katomic/wall-3.png
-share/gnome/atomix/themes/katomic/wall-4.png
+share/gnome/applications/atomix.desktop
+share/gnome/atomix/atomix-logo.png
+share/gnome/atomix/level/aceticacid.atomix
+share/gnome/atomix/level/acetone.atomix
+share/gnome/atomix/level/buthanol.atomix
+share/gnome/atomix/level/cyclo-buthane.atomix
+share/gnome/atomix/level/dimethylether.atomix
+share/gnome/atomix/level/ethan.atomix
+share/gnome/atomix/level/ethanal.atomix
+share/gnome/atomix/level/ethanol.atomix
+share/gnome/atomix/level/ethylene.atomix
+share/gnome/atomix/level/formaldehyd.atomix
+share/gnome/atomix/level/glycerin.atomix
+share/gnome/atomix/level/lactic-acid.atomix
+share/gnome/atomix/level/methane.atomix
+share/gnome/atomix/level/methanol.atomix
+share/gnome/atomix/level/propanal.atomix
+share/gnome/atomix/level/propylen.atomix
+share/gnome/atomix/level/pyran.atomix
+share/gnome/atomix/level/sequence
+share/gnome/atomix/level/transbutylen.atomix
+share/gnome/atomix/level/water.atomix
+share/gnome/atomix/themes/default/arrow-bottom.png
+share/gnome/atomix/themes/default/arrow-left.png
+share/gnome/atomix/themes/default/arrow-right.png
+share/gnome/atomix/themes/default/arrow-top.png
+share/gnome/atomix/themes/default/atom-c.png
+share/gnome/atomix/themes/default/atom-f.png
+share/gnome/atomix/themes/default/atom-h.png
+share/gnome/atomix/themes/default/atom-n.png
+share/gnome/atomix/themes/default/atom-o.png
+share/gnome/atomix/themes/default/cursor.png
+share/gnome/atomix/themes/default/floor.png
+share/gnome/atomix/themes/default/link-bottom-double.png
+share/gnome/atomix/themes/default/link-bottom-left.png
+share/gnome/atomix/themes/default/link-bottom-right.png
+share/gnome/atomix/themes/default/link-bottom.png
+share/gnome/atomix/themes/default/link-left-double.png
+share/gnome/atomix/themes/default/link-left.png
+share/gnome/atomix/themes/default/link-right-double.png
+share/gnome/atomix/themes/default/link-right.png
+share/gnome/atomix/themes/default/link-top-double.png
+share/gnome/atomix/themes/default/link-top-left.png
+share/gnome/atomix/themes/default/link-top-right.png
+share/gnome/atomix/themes/default/link-top.png
+share/gnome/atomix/themes/default/shadow-bottom-right.png
+share/gnome/atomix/themes/default/shadow-left-top.png
+share/gnome/atomix/themes/default/shadow-left.png
+share/gnome/atomix/themes/default/shadow-top-left-both.png
+share/gnome/atomix/themes/default/shadow-top-left.png
+share/gnome/atomix/themes/default/shadow-top.png
+share/gnome/atomix/themes/default/theme
+share/gnome/atomix/themes/default/wall-bottom-left.png
+share/gnome/atomix/themes/default/wall-bottom-right.png
+share/gnome/atomix/themes/default/wall-horizontal-bottomx.png
+share/gnome/atomix/themes/default/wall-horizontal-left-end.png
+share/gnome/atomix/themes/default/wall-horizontal-right-end.png
+share/gnome/atomix/themes/default/wall-horizontal-topx.png
+share/gnome/atomix/themes/default/wall-horizontal.png
+share/gnome/atomix/themes/default/wall-single.png
+share/gnome/atomix/themes/default/wall-top-left.png
+share/gnome/atomix/themes/default/wall-top-right.png
+share/gnome/atomix/themes/default/wall-vertical-bottom-end.png
+share/gnome/atomix/themes/default/wall-vertical-leftx.png
+share/gnome/atomix/themes/default/wall-vertical-rightx.png
+share/gnome/atomix/themes/default/wall-vertical-top-end.png
+share/gnome/atomix/themes/default/wall-vertical.png
share/gnome/games/atomix.scores
-share/gnome/help/atomix/C/atomix.html
-share/gnome/help/atomix/C/authors.html
-share/gnome/help/atomix/C/docbook.css
-share/gnome/help/atomix/C/howtoplay.html
-share/gnome/help/atomix/C/images/gm_mainwin.png
-share/gnome/help/atomix/C/images/gm_pref-control.png
-share/gnome/help/atomix/C/images/gm_pref-general.png
-share/gnome/help/atomix/C/ln7.html
-share/gnome/help/atomix/C/menubar.html
-share/gnome/help/atomix/C/preferences.html
-share/gnome/help/atomixed/C/atomixed.html
-share/gnome/help/atomixed/C/authors.html
-share/gnome/help/atomixed/C/docbook.css
-share/gnome/help/atomixed/C/images/ed_mainwin.png
-share/gnome/help/atomixed/C/images/ed_themeeditorwin.png
-share/gnome/help/atomixed/C/images/ed_themewin.png
-share/gnome/help/atomixed/C/leveleditor.html
-share/gnome/help/atomixed/C/ln7.html
-share/gnome/help/atomixed/C/menus.html
-share/gnome/help/atomixed/C/overview.html
-share/gnome/help/atomixed/C/themeeditor.html
-share/gnome/pixmaps/atomix/atomix-logo.png
+share/gnome/gnome-2.0/ui/atomix-ui.xml
+share/locale/am/LC_MESSAGES/atomix.mo
+share/locale/az/LC_MESSAGES/atomix.mo
+share/locale/be/LC_MESSAGES/atomix.mo
+share/locale/ca/LC_MESSAGES/atomix.mo
+share/locale/cs/LC_MESSAGES/atomix.mo
+share/locale/da/LC_MESSAGES/atomix.mo
+share/locale/de/LC_MESSAGES/atomix.mo
+share/locale/el/LC_MESSAGES/atomix.mo
+share/locale/es/LC_MESSAGES/atomix.mo
+share/locale/et/LC_MESSAGES/atomix.mo
+share/locale/fa/LC_MESSAGES/atomix.mo
+share/locale/fr/LC_MESSAGES/atomix.mo
+share/locale/gl/LC_MESSAGES/atomix.mo
+share/locale/he/LC_MESSAGES/atomix.mo
+share/locale/hi/LC_MESSAGES/atomix.mo
+share/locale/hu/LC_MESSAGES/atomix.mo
share/locale/it/LC_MESSAGES/atomix.mo
+share/locale/ja/LC_MESSAGES/atomix.mo
+share/locale/kn/LC_MESSAGES/atomix.mo
+share/locale/ko/LC_MESSAGES/atomix.mo
+share/locale/lv/LC_MESSAGES/atomix.mo
+share/locale/ms/LC_MESSAGES/atomix.mo
+share/locale/nl/LC_MESSAGES/atomix.mo
+share/locale/no/LC_MESSAGES/atomix.mo
+share/locale/pl/LC_MESSAGES/atomix.mo
+share/locale/pt/LC_MESSAGES/atomix.mo
+share/locale/pt_BR/LC_MESSAGES/atomix.mo
+share/locale/ru/LC_MESSAGES/atomix.mo
+share/locale/sk/LC_MESSAGES/atomix.mo
+share/locale/sl/LC_MESSAGES/atomix.mo
+share/locale/sq/LC_MESSAGES/atomix.mo
+share/locale/sr/LC_MESSAGES/atomix.mo
+share/locale/sr@Latn/LC_MESSAGES/atomix.mo
share/locale/sv/LC_MESSAGES/atomix.mo
-@dirrm share/gnome/pixmaps/atomix
-@dirrm share/gnome/help/atomixed/C/images
-@dirrm share/gnome/help/atomixed/C
-@dirrm share/gnome/help/atomixed
-@dirrm share/gnome/help/atomix/C/images
-@dirrm share/gnome/help/atomix/C
-@dirrm share/gnome/help/atomix
-@dirrm share/gnome/atomix/themes/katomic
-@dirrm share/gnome/atomix/themes/fabonus
-@dirrm share/gnome/atomix/themes/fabian
+share/locale/ta/LC_MESSAGES/atomix.mo
+share/locale/tr/LC_MESSAGES/atomix.mo
+share/locale/uk/LC_MESSAGES/atomix.mo
+share/locale/vi/LC_MESSAGES/atomix.mo
+share/locale/wa/LC_MESSAGES/atomix.mo
+share/locale/zh_CN/LC_MESSAGES/atomix.mo
+share/locale/zh_TW/LC_MESSAGES/atomix.mo
+@dirrm share/gnome/atomix/themes/default
@dirrm share/gnome/atomix/themes
-@dirrm share/gnome/atomix/levels
+@dirrm share/gnome/atomix/level
@dirrm share/gnome/atomix