aboutsummaryrefslogtreecommitdiff
path: root/games/atr3d/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-10-01 13:27:48 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-10-01 13:27:48 +0000
commit42a465abfde805c8c150addda6a5849c4af89cb5 (patch)
tree503511b97d556ab51018244ca09ab64cb5e040f4 /games/atr3d/Makefile
parentcedc56400e583074d07fb09f79801f14b5c52f41 (diff)
downloadports-42a465abfde805c8c150addda6a5849c4af89cb5.tar.gz
ports-42a465abfde805c8c150addda6a5849c4af89cb5.zip
- Convert to OptionsNG
Notes
Notes: svn path=/head/; revision=305120
Diffstat (limited to 'games/atr3d/Makefile')
-rw-r--r--games/atr3d/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 75c7b04b3142..6108746c59da 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -16,7 +16,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= 3D asteroids-like multiplayer game
-OPTIONS= SOUND "Enable sound" ON
+OPTIONS_DEFINE= OPENAL
+OPTIONS_DEFAULT=OPENAL
SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
@@ -27,16 +28,15 @@ USE_GL= glut glu
USE_XORG= xmu xi x11
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-sound
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
USE_AUTOTOOLS= automake autoconf
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_SOUND)
+.if ${PORT_OPTIONS:MOPENAL}
USE_OPENAL= alut
CONFIGURE_ARGS+= --enable-sound
.else
@@ -60,4 +60,4 @@ post-configure:
's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>