aboutsummaryrefslogtreecommitdiff
path: root/games/atr3d/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /games/atr3d/Makefile
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'games/atr3d/Makefile')
-rw-r--r--games/atr3d/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 3f863cd4f266..c1aceb4fd15e 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -28,13 +28,11 @@ USE_XORG= xmu xi x11
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-sound
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- SDL_CONFIG="${SDL_CONFIG}"
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
USE_AUTOTOOLS= automake autoconf
-CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>